From mboxrd@z Thu Jan 1 00:00:00 1970 From: Marek Szyprowski Subject: Re: [PATCH v6 11/25] iommu: exynos: add support for binding more than one sysmmu to master device Date: Mon, 18 May 2015 15:03:33 +0200 Message-ID: <5559E325.2060106@samsung.com> References: <1430727380-10912-1-git-send-email-m.szyprowski@samsung.com> <1430727380-10912-12-git-send-email-m.szyprowski@samsung.com> <20150510223437.b651f6d2f3f0ead49eb72488@samsung.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii"; Format="flowed" Content-Transfer-Encoding: 7bit Return-path: In-reply-to: <20150510223437.b651f6d2f3f0ead49eb72488-Sze3O3UU22JBDgjK7y7TUQ@public.gmane.org> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: iommu-bounces-cunTk1MwBs9QetFLy7KEm3xJsTq8ys+cHZ5vskTnxNA@public.gmane.org Errors-To: iommu-bounces-cunTk1MwBs9QetFLy7KEm3xJsTq8ys+cHZ5vskTnxNA@public.gmane.org To: Cho KyongHo Cc: Rob Herring , linux-samsung-soc-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, Shaik Ameer Basha , Joonyoung Shim , Arnd Bergmann , Inki Dae , Seung-Woo Kim , Will Deacon , Tomasz Figa , linaro-mm-sig-cunTk1MwBs8s++Sfvej+rw@public.gmane.org, iommu-cunTk1MwBs9QetFLy7KEm3xJsTq8ys+cHZ5vskTnxNA@public.gmane.org, Kukjin Kim , Laurent Pinchart , Kyungmin Park , Javier Martinez Canillas , Thierry Reding , David Wodhouse , linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org List-Id: linux-samsung-soc@vger.kernel.org Hello, On 2015-05-10 15:34, Cho KyongHo wrote: > On Mon, 04 May 2015 10:16:06 +0200 Marek Szyprowski wrote: > >> This patch adds support for assigning more than one SYSMMU controller to >> the master device. This has been achieved simply by chaning the struct >> device pointer in struct exynos_iommu_owner into the list of struct >> sysmmu_drvdata of all controllers assigned to the given master device. >> >> Signed-off-by: Marek Szyprowski >> --- >> drivers/iommu/exynos-iommu.c | 11 +++++------ >> 1 file changed, 5 insertions(+), 6 deletions(-) >> >> diff --git a/drivers/iommu/exynos-iommu.c b/drivers/iommu/exynos-iommu.c >> index f2eceb6605c5..598660c87410 100644 >> --- a/drivers/iommu/exynos-iommu.c >> +++ b/drivers/iommu/exynos-iommu.c >> @@ -186,7 +186,7 @@ static char *sysmmu_fault_name[SYSMMU_FAULTS_NUM] = { >> >> /* attached to dev.archdata.iommu of the master device */ >> struct exynos_iommu_owner { >> - struct device *sysmmu; >> + struct list_head clients; > 'clients' is the list of System MMUs that are assigned to the same iommu > domain. I don't think clients is not a good list name for exynos_iommu_owner > even though the elements are the same because they are used in different > contexts. Okay, I will rename it to 'controllers' then. Best regards -- Marek Szyprowski, PhD Samsung R&D Institute Poland From mboxrd@z Thu Jan 1 00:00:00 1970 From: m.szyprowski@samsung.com (Marek Szyprowski) Date: Mon, 18 May 2015 15:03:33 +0200 Subject: [PATCH v6 11/25] iommu: exynos: add support for binding more than one sysmmu to master device In-Reply-To: <20150510223437.b651f6d2f3f0ead49eb72488@samsung.com> References: <1430727380-10912-1-git-send-email-m.szyprowski@samsung.com> <1430727380-10912-12-git-send-email-m.szyprowski@samsung.com> <20150510223437.b651f6d2f3f0ead49eb72488@samsung.com> Message-ID: <5559E325.2060106@samsung.com> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org Hello, On 2015-05-10 15:34, Cho KyongHo wrote: > On Mon, 04 May 2015 10:16:06 +0200 Marek Szyprowski wrote: > >> This patch adds support for assigning more than one SYSMMU controller to >> the master device. This has been achieved simply by chaning the struct >> device pointer in struct exynos_iommu_owner into the list of struct >> sysmmu_drvdata of all controllers assigned to the given master device. >> >> Signed-off-by: Marek Szyprowski >> --- >> drivers/iommu/exynos-iommu.c | 11 +++++------ >> 1 file changed, 5 insertions(+), 6 deletions(-) >> >> diff --git a/drivers/iommu/exynos-iommu.c b/drivers/iommu/exynos-iommu.c >> index f2eceb6605c5..598660c87410 100644 >> --- a/drivers/iommu/exynos-iommu.c >> +++ b/drivers/iommu/exynos-iommu.c >> @@ -186,7 +186,7 @@ static char *sysmmu_fault_name[SYSMMU_FAULTS_NUM] = { >> >> /* attached to dev.archdata.iommu of the master device */ >> struct exynos_iommu_owner { >> - struct device *sysmmu; >> + struct list_head clients; > 'clients' is the list of System MMUs that are assigned to the same iommu > domain. I don't think clients is not a good list name for exynos_iommu_owner > even though the elements are the same because they are used in different > contexts. Okay, I will rename it to 'controllers' then. Best regards -- Marek Szyprowski, PhD Samsung R&D Institute Poland