From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Jan Beulich" Subject: Re: [PATCH v8 01/13] x86: add socket_cpumask Date: Fri, 29 May 2015 09:01:53 +0100 Message-ID: <55683911020000780007ED2B@mail.emea.novell.com> References: <1432197704-20816-1-git-send-email-chao.p.peng@linux.intel.com> <1432197704-20816-2-git-send-email-chao.p.peng@linux.intel.com> <5567284D020000780007E93D@mail.emea.novell.com> <20150529023533.GA18422@pengc-linux.bj.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <20150529023533.GA18422@pengc-linux.bj.intel.com> Content-Disposition: inline List-Unsubscribe: , List-Post: List-Help: List-Subscribe: , Sender: xen-devel-bounces@lists.xen.org Errors-To: xen-devel-bounces@lists.xen.org To: Chao Peng Cc: wei.liu2@citrix.com, Ian.Campbell@citrix.com, stefano.stabellini@eu.citrix.com, andrew.cooper3@citrix.com, dario.faggioli@citrix.com, Ian.Jackson@eu.citrix.com, xen-devel@lists.xen.org, will.auld@intel.com, keir@xen.org, dgdegra@tycho.nsa.gov List-Id: xen-devel@lists.xenproject.org >>> On 29.05.15 at 04:35, wrote: > On Thu, May 28, 2015 at 01:38:05PM +0100, Jan Beulich wrote: >> >>> On 21.05.15 at 10:41, wrote: >> > --- a/xen/arch/x86/mpparse.c >> > +++ b/xen/arch/x86/mpparse.c >> > @@ -87,6 +87,18 @@ void __init set_nr_cpu_ids(unsigned int max_cpus) >> > #endif >> > } >> > >> > +void __init set_nr_sockets(void) >> > +{ >> > + unsigned int cpus = bitmap_weight(phys_cpu_present_map.mask, >> > + boot_cpu_data.x86_max_cores * >> > + boot_cpu_data.x86_num_siblings); >> >> How did you come to this expression for the bitmap size? I.e. >> why not simply physids_weight(phys_cpu_present_map)? > > physids_weight(phys_cpu_present_map) gives me cpus for all sockets. > While here the 'cpus' is actually _cpus_per_socket_. I used the max > possible cpus indicated in cpuid as the upper bound so bitmap_weight() > returns the actual available cpus on socket 0. In which case the variable name is badly chosen, or a respective comment is missing. >> > + >> > + if ( cpus == 0 ) >> > + cpus = 1; >> > + >> > + nr_sockets = DIV_ROUND_UP(num_processors + disabled_cpus, cpus); >> > +} >> >> Is there a reason why this can't just be added to the end of the >> immediately preceding set_nr_cpu_ids()? > > You mean the declaration or invocation? If the former I have no special > reason for it (e.g. I can change it). Neither - I just don't see the need for a new function. Jan