All of lore.kernel.org
 help / color / mirror / Atom feed
From: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
To: Matt Roper <matthew.d.roper@intel.com>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 07/24] drm/i915: Add a simple atomic crtc check function.
Date: Wed, 03 Jun 2015 08:56:10 +0200	[thread overview]
Message-ID: <556EA50A.90704@linux.intel.com> (raw)
In-Reply-To: <20150603012811.GE17555@intel.com>

Op 03-06-15 om 03:28 schreef Matt Roper:
> On Mon, Jun 01, 2015 at 03:27:10PM +0200, Maarten Lankhorst wrote:
>> Move the check for encoder cloning here.
>>
>> Signed-off-by: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
>> ---
>>  drivers/gpu/drm/i915/intel_atomic.c  |   5 +-
>>  drivers/gpu/drm/i915/intel_display.c | 131 ++++++++++++++++++++---------------
>>  2 files changed, 80 insertions(+), 56 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/i915/intel_atomic.c b/drivers/gpu/drm/i915/intel_atomic.c
>> index 156df1b59ddd..1edd1651c045 100644
>> --- a/drivers/gpu/drm/i915/intel_atomic.c
>> +++ b/drivers/gpu/drm/i915/intel_atomic.c
>> @@ -100,7 +100,10 @@ int intel_atomic_check(struct drm_device *dev,
>>  	if (ret)
>>  		return ret;
>>  
>> -	/* FIXME: move to crtc atomic check function once it is ready */
>> +	/*
>> +	 * FIXME: move to crtc atomic check function once this is
>> +	 * more atomic friendly.
>> +	 */
>>  	ret = intel_atomic_setup_scalers(dev, nuclear_crtc, crtc_state);
>>  	if (ret)
>>  		return ret;
>> diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
>> index 6f3e96930da5..0060784525dc 100644
>> --- a/drivers/gpu/drm/i915/intel_display.c
>> +++ b/drivers/gpu/drm/i915/intel_display.c
>> @@ -11404,11 +11404,87 @@ out_hang:
>>  	return ret;
>>  }
>>  
>> +static bool encoders_cloneable(const struct intel_encoder *a,
>> +			       const struct intel_encoder *b)
>> +{
>> +	/* masks could be asymmetric, so check both ways */
>> +	return a == b || (a->cloneable & (1 << b->type) &&
>> +			  b->cloneable & (1 << a->type));
>> +}
>> +
>> +static bool check_single_encoder_cloning(struct drm_atomic_state *state,
>> +					 struct intel_crtc *crtc,
>> +					 struct intel_encoder *encoder)
>> +{
>> +	struct intel_encoder *source_encoder;
>> +	struct drm_connector *connector;
>> +	struct drm_connector_state *connector_state;
>> +	int i;
>> +
>> +	for_each_connector_in_state(state, connector, connector_state, i) {
>> +		if (connector_state->crtc != &crtc->base)
>> +			continue;
>> +
>> +		source_encoder =
>> +			to_intel_encoder(connector_state->best_encoder);
>> +		if (!encoders_cloneable(encoder, source_encoder))
>> +			return false;
>> +	}
>> +
>> +	return true;
>> +}
>> +
>> +static bool check_encoder_cloning(struct drm_atomic_state *state,
>> +				  struct intel_crtc *crtc)
>> +{
>> +	struct intel_encoder *encoder;
>> +	struct drm_connector *connector;
>> +	struct drm_connector_state *connector_state;
>> +	int i;
>> +
>> +	for_each_connector_in_state(state, connector, connector_state, i) {
>> +		if (connector_state->crtc != &crtc->base)
>> +			continue;
>> +
>> +		encoder = to_intel_encoder(connector_state->best_encoder);
>> +		if (!check_single_encoder_cloning(state, crtc, encoder))
>> +			return false;
>> +	}
>> +
>> +	return true;
>> +}
>> +
>> +static int intel_atomic_check_crtc(struct drm_crtc *crtc,
>> +				   struct drm_crtc_state *crtc_state)
> The plane equivalent is 'intel_plane_atomic_check'...it would be nice if
> we could keep the naming consistent (intel_crtc_atomic_check).
>
> Not sure if this should go in intel_display.c or intel_atomic.c.  Maybe
> a future patch can shuffle a bunch of stuff around so things are a bit
> more consistent than they are today.
That's my intention. But for now keeping everything in 1 place is a lot easier. After it's hooked up as
atomic_check/atomic_commit I can move it to intel_atomic.c, but for now maintaining such a patch
would be busywork since it would break down every time I make an adjustment.

>
>> +{
>> +	struct intel_crtc *intel_crtc = to_intel_crtc(crtc);
>> +	struct drm_atomic_state *state = crtc_state->state;
>> +	int idx = crtc->base.id;
>> +	bool is_crtc_enabled = crtc_state->active;
>> +	bool was_crtc_enabled = crtc->state->active;
>> +	bool mode_changed = needs_modeset(crtc_state);
>> +
>> +	if (mode_changed && !check_encoder_cloning(state, intel_crtc)) {
>> +		DRM_DEBUG_KMS("rejecting invalid cloning configuration\n");
>> +		return -EINVAL;
>> +	}
>> +
>> +	I915_STATE_WARN(crtc->state->active != intel_crtc->active,
>> +		"[CRTC:%i] mismatch between state->active(%i) and crtc->active(%i)\n",
>> +		idx, crtc->state->active, intel_crtc->active);
>> +
>> +	DRM_DEBUG_ATOMIC("Crtc %i was enabled %i now enabled: %i\n",
>> +			 idx, was_crtc_enabled, is_crtc_enabled);
> Maybe just print this debug message when the values aren't equal (i.e.,
> an actual change) to cut down on a little spam when it isn't
> interesting?
I think it's not interesting to keep this message any more. I'll remove it.

~Maarten
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2015-06-03  6:56 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-06-01 13:27 [PATCH 00/24] Convert to atomic, part 3 Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 01/24] drm/i915: Always reset in intel_crtc_restore_mode Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 02/24] drm/i915: Use crtc state in intel_modeset_pipe_config Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 03/24] drm/i915: clean up intel_sanitize_crtc Maarten Lankhorst
2015-06-03  1:27   ` Matt Roper
2015-06-03  6:47     ` Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 04/24] drm/i915: Update power domains only on affected crtc's Maarten Lankhorst
2015-06-03  1:27   ` Matt Roper
2015-06-03  6:52     ` Maarten Lankhorst
2015-06-15 11:43       ` Daniel Vetter
2015-06-15 11:49         ` Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 05/24] drm/i915: add fastboot checks for has_audio and has_infoframe Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 06/24] drm/i915: Clean up intel_atomic_setup_scalers slightly Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 07/24] drm/i915: Add a simple atomic crtc check function Maarten Lankhorst
2015-06-03  1:28   ` Matt Roper
2015-06-03  6:56     ` Maarten Lankhorst [this message]
2015-06-01 13:27 ` [PATCH 08/24] drm/i915: Do not add planes from intel_atomic_setup_scalers Maarten Lankhorst
2015-06-03  1:29   ` Matt Roper
2015-06-03  1:52     ` Konduru, Chandra
2015-06-03  7:01       ` Maarten Lankhorst
2015-06-03 19:32         ` Konduru, Chandra
2015-06-03 23:33           ` Matt Roper
2015-06-04  3:39             ` Maarten Lankhorst
2015-06-05 19:05               ` Konduru, Chandra
2015-06-06  6:39                 ` Maarten Lankhorst
2015-06-08 17:25                   ` Konduru, Chandra
2015-06-15 11:48               ` Daniel Vetter
2015-06-01 13:27 ` [PATCH 09/24] drm/i915: Assign a new pll from the crtc check function Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 10/24] drm/i915: Do not run most checks when there's no modeset Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 11/24] drm/i915: Split skl_update_scaler Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 12/24] drm/i915: Split plane updates of crtc->atomic into a helper Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 13/24] drm/i915: move detaching scalers to begin_crtc_commit Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 14/24] drm/i915: Move crtc commit updates to separate functions Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 15/24] drm/i915: clean up plane commit functions Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 16/24] drm/i915: atomic plane updates in a nutshell Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 17/24] drm/i915: Update less state during modeset Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 18/24] drm/i915: get rid of intel_plane_restore in intel_crtc_page_flip Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 19/24] drm/i915: Make setting color key atomic Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 20/24] drm/i915: clean up atomic plane check functions Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 21/24] drm/i915: remove force argument from disable_plane Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 22/24] drm/i915: Use full atomic modeset Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 23/24] drm/i915: Unify plane updates Maarten Lankhorst
2015-06-01 13:27 ` [PATCH 24/24] drm/i915: always disable irqs in intel_pipe_update_start Maarten Lankhorst
2015-06-02  9:34 ` [PATCH 00/24] Convert to atomic, part 3 Maarten Lankhorst

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=556EA50A.90704@linux.intel.com \
    --to=maarten.lankhorst@linux.intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=matthew.d.roper@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.