All of lore.kernel.org
 help / color / mirror / Atom feed
From: Hans de Goede <j.w.r.degoede@gmail.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH v2 18/26] dm: usb: Remove inactive children after a bus scan
Date: Wed, 11 Nov 2015 18:02:28 +0100	[thread overview]
Message-ID: <564374A4.5080009@gmail.com> (raw)
In-Reply-To: <CAPnjgZ3KQPUxkBf9ZOt+q0S0bpN4d0MmwdCbeyb_oYFpW-6pBw@mail.gmail.com>

Hi,

On 11-11-15 00:30, Simon Glass wrote:
> Hi Hans,
>
> On 9 November 2015 at 12:25, Simon Glass <sjg@chromium.org> wrote:
>> Hi Hans,
>>
>> On 9 November 2015 at 00:22, Hans de Goede <hdegoede@redhat.com> wrote:
>>> Hi,
>>>
>>> On 09-11-15 07:48, Simon Glass wrote:
>>>>
>>>> Each scan of the USB bus may return different results. Existing
>>>> driver-model
>>>> devices are reused when found, but if a device no longer exists it will
>>>> stay
>>>> around, de-activated, but bound.
>>>>
>>>> Detect these devices and remove them after the scan completes.
>>>>
>>>> Signed-off-by: Simon Glass <sjg@chromium.org>
>>>
>>>
>>> I wonder how this is better then my original:
>>> "dm: usb: Use device_unbind_children to clean up usb devs on stop"
>>>
>>> Patch, the end result of both patches is the same and both are
>>> a NOP when DM_DEVICE_REMOVE is not set. Where as my code seems
>>> to be a much more KISS approach to the problem (my approach is
>>> just 3 lines vs 23 lines for yours).
>>>
>>> I know we will need usb_find_child in the DM_DEVICE_REMOVE not
>>> set case, but why not only revert the:
>>>
>>> "dm: usb: Rename usb_find_child to usb_find_emul_child"
>>>
>>> commit, keep the other 2 you revert and drop this patch ?
>>>
>>> This drops 3 patches from your patch-set and the end result is
>>> more clean IMHO.
>>
>> I would like to avoid binding/unbinding things when nothing changes if
>> possible. Also I'd like to support attaching device tree
>> nodes/properties to USB devices as necessary, as we do with PCI, and
>> removing things breaks that.
>>
>> I still have to figure out one more test case, so I'll do that before
>> commenting further.
>
> I've added the test case and pushed a new tree. However it turns out
> that this doesn't behave differently.
>
> So please can you go ahead and run your original (manual) test case?
> I'd like to make sure that my automated tests are correct and catch
> the bug you reported and fixed.

Ok, I've ran a whole battery of tests on your u-boot-dm/usb-working branch.

There are 2 issues:

1) You need to add these change to the commit introducing usb-keyb dm
support (or one of the related commits), otherwise usb-keyb support
breaks:

--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -513,6 +513,7 @@ config ARCH_SUNXI
         select DM
         select DM_GPIO
         select DM_ETH
+       select DM_KEYBOARD
         select DM_SERIAL
         select DM_USB
         select OF_CONTROL

The breakage is that without this usb_scan_device() returns -96
(EPFNOSUPPORT) for usb keyboards.

2) With that branch there still is the purely cosmetical issue,
that if one plugs a usb-stick + keyb into the same hub, then swaps
their place and do "usb reset" and then "usb tree" looks like this:

USB device tree:
   1  Hub (480 Mb/s, 100mA)
   |   USB2.0 Hub
   |
   +-3  Human Interface (1.5 Mb/s, 100mA)
   |    SINO WEALTH USB Composite Device
   |
   +-2  Mass Storage (480 Mb/s, 100mA)
        USB Flash Disk 4C0E960F

Notice the order of devices listed: 1 - 3 - 2, which is a bit weird,
as said this is purely cosmetical.

Note you can easily fix this by only reverting the:

"dm: usb: Rename usb_find_child to usb_find_emul_child"

commit, and keep the other 2 you revert and dropping this patch ?

As I already suggested before, this is both more KISS and as you
can see it solves some actually (admittedly very minor) issues.

I'm not really buying your arguments for your more complex solution,
as shown above re-using the devices actually causes issues.

Your other argument of wanting to attach device-tree properties
I also do not find a strong argument, for one there has never been
a need to do so sofar, and if we ever need this we need a way
to specify which usb-device the properties belong to based on
the topology under the host / root-hub anyway, and match things
up when first scanning the bus. And if we can match things up
on the first scan we can also match them up on subsequent scans
and attach the same of-node again.

Anyways I'm fine with doing things your way, but I still have
a preference for the more KISS and IMHO robust solution of
simple unbinding all devices on usb-stop.

###

Talking about usb-stop, there is still one (BIG!) problem after
this patch set when building usb-support with DM_DEVICE_REMOVE
not set. This means that the controllers dma engines will not
be stopped when booting the actual OS and they will still be
accessing parts of the main memory while the actual OS is
booting, which is BAD. So I suggest adding something like
this to all host drivers which use dma in this way:

#if defined CONFIG_DM_USB && !defined CONFIG_DM_DEVICE_REMOVE
#error The EHCI driver cannot be used without CONFIG_DM_DEVICE_REMOVE otherwise DMA stays active while booting the OS
#endif

Regards,

Hans




>
>>
>>>
>>>
>>>> Changes in v2: None
>>>>
>>>>    drivers/usb/host/usb-uclass.c | 23 +++++++++++++++++++++++
>>>>    1 file changed, 23 insertions(+)
>>>>
>>>> diff --git a/drivers/usb/host/usb-uclass.c b/drivers/usb/host/usb-uclass.c
>>>> index 4aa92f8..50538e0 100644
>>>> --- a/drivers/usb/host/usb-uclass.c
>>>> +++ b/drivers/usb/host/usb-uclass.c
>>>> @@ -202,6 +202,20 @@ static void usb_scan_bus(struct udevice *bus, bool
>>>> recurse)
>>>>                  printf("%d USB Device(s) found\n", priv->next_addr);
>>>>    }
>>>>
>>>> +static void remove_inactive_children(struct uclass *uc, struct udevice
>>>> *bus)
>>>> +{
>>>> +       uclass_foreach_dev(bus, uc) {
>>>> +               struct udevice *dev, *next;
>>>> +
>>>> +               if (!device_active(bus))
>>>> +                       continue;
>>>> +               device_foreach_child_safe(dev, next, bus) {
>>>> +                       if (!device_active(dev))
>>>> +                               device_unbind(dev);
>>>> +               }
>>>> +       }
>>>> +}
>>>> +
>>>>    int usb_init(void)
>>>>    {
>>>>          int controllers_initialized = 0;
>>>> @@ -270,6 +284,15 @@ int usb_init(void)
>>>>          }
>>>>
>>>>          debug("scan end\n");
>>>> +
>>>> +       /* Remove any devices that were not found on this scan */
>>>> +       remove_inactive_children(uc, bus);
>>>> +
>>>> +       ret = uclass_get(UCLASS_USB_HUB, &uc);
>>>> +       if (ret)
>>>> +               return ret;
>>>> +       remove_inactive_children(uc, bus);
>>>> +
>>>
>>>
>>> Why do you need to call remove_inactive_children twice here? This seems
>>> worthy of a comment explaining why this is necessary.
>>
>> One is removing the children of USB controllers, one is removing the
>> children of USB hubs. I'll add a comment.
>>
>>>
>>>>          /* if we were not able to find at least one working bus, bail out
>>>> */
>>>>          if (!count)
>>>>                  printf("No controllers found\n");
>>
>> Regards,
>> Simon

  reply	other threads:[~2015-11-11 17:02 UTC|newest]

Thread overview: 67+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-11-09  6:47 [U-Boot] [PATCH v2 00/26] usb: Drop requirement for USB unbinding, add tests Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 01/26] sandbox: Add a way to skip time delays Simon Glass
2015-11-20  3:30   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 02/26] dm: usb: Avoid time delays in sandbox tests Simon Glass
2015-11-20  3:30   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 03/26] Move console definitions into a new console.h file Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 04/26] Drop config.h header from display_options.c Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 05/26] Add a circular memory buffer implementation Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 06/26] console: Add a console buffer Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 07/26] sandbox: Enable console recording and silent console Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 08/26] test: Record and silence console in tests Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 09/26] usb: Refactor USB tree output code for testing Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 10/26] dm: core: Add safe device iteration macros Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 11/26] sandbox: usb: Allow dynamic emulated USB device descriptors Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 12/26] sandbox: usb: Allow up to 4 emulated devices on a hub Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 13/26] sandbox: usb: Allow finding a USB emulator for a device Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 14/26] Revert "dm: usb: Rename usb_find_child to usb_find_emul_child" Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 15/26] Revert "dm: usb: Use device_unbind_children to clean up usb devs on stop" Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 16/26] Revert "dm: Export device_remove_children / device_unbind_children" Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:47 ` [U-Boot] [PATCH v2 17/26] dm: usb: Deprecate usb_get_dev_index() Simon Glass
2015-11-20  3:31   ` Simon Glass
2015-11-09  6:48 ` [U-Boot] [PATCH v2 18/26] dm: usb: Remove inactive children after a bus scan Simon Glass
2015-11-09  8:22   ` Hans de Goede
2015-11-09 20:25     ` Simon Glass
2015-11-10 23:30       ` Simon Glass
2015-11-11 17:02         ` Hans de Goede [this message]
2015-11-11 18:15           ` Simon Glass
2015-11-12 14:08             ` Hans de Goede
2015-11-13 21:58               ` Simon Glass
2015-11-15 19:35                 ` Hans de Goede
2015-11-16 21:08                   ` Simon Glass
2015-11-20  3:32                     ` Simon Glass
2015-11-11 17:03         ` Hans de Goede
2015-11-09  6:48 ` [U-Boot] [PATCH v2 19/26] dm: test: usb: Add tests for the 'usb tree' command Simon Glass
2015-11-20  3:32   ` Simon Glass
2015-11-09  6:48 ` [U-Boot] [PATCH v2 20/26] dm: test: usb: Add a test for device reordering Simon Glass
2015-11-20  3:32   ` Simon Glass
2015-11-09  6:48 ` [U-Boot] [PATCH v2 21/26] usb: Drop unused code in usb_kbd.c Simon Glass
2015-11-20  3:32   ` Simon Glass
2015-11-09  6:48 ` [U-Boot] [PATCH v2 22/26] usb: Avoid open-coded USB constants " Simon Glass
2015-11-20  3:32   ` Simon Glass
2015-11-09  6:48 ` [U-Boot] [PATCH v2 23/26] usb: sandbox: Add support for interrupt operations Simon Glass
2015-11-20  3:32   ` Simon Glass
2015-11-09  6:48 ` [U-Boot] [PATCH v2 24/26] usb: sandbox: Add a USB emulation driver Simon Glass
2015-11-20  3:32   ` Simon Glass
2015-11-09  6:48 ` [U-Boot] [PATCH v2 25/26] sandbox: Enable USB keyboard Simon Glass
2015-11-20  3:32   ` Simon Glass
2015-11-09  6:48 ` [U-Boot] [PATCH v2 26/26] dm: test: usb: sandbox: Add keyboard tests for sandbox Simon Glass
2015-11-20  3:32   ` Simon Glass
2015-11-09  8:14 ` [U-Boot] [PATCH v2 00/26] usb: Drop requirement for USB unbinding, add tests Hans de Goede
2015-11-09 16:54   ` Simon Glass
2015-11-18 15:53     ` Simon Glass
2015-11-09 14:17 ` Marek Vasut

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=564374A4.5080009@gmail.com \
    --to=j.w.r.degoede@gmail.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.