All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH] ccid: use libcacard.h from 2.5.1
@ 2015-12-18  9:49 marcandre.lureau
  2015-12-18 12:42 ` Paolo Bonzini
  2015-12-18 13:29 ` Gerd Hoffmann
  0 siblings, 2 replies; 5+ messages in thread
From: marcandre.lureau @ 2015-12-18  9:49 UTC (permalink / raw)
  To: qemu-devel; +Cc: Marc-André Lureau, kraxel

From: Marc-André Lureau <marcandre.lureau@redhat.com>

This cleans up a bit libcacard headers inclusion.

Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
---
 configure                   | 7 ++++---
 hw/usb/ccid-card-emulated.c | 5 +----
 hw/usb/ccid-card-passthru.c | 2 +-
 3 files changed, 6 insertions(+), 8 deletions(-)

diff --git a/configure b/configure
index b9552fd..65dc5ed 100755
--- a/configure
+++ b/configure
@@ -3981,17 +3981,18 @@ EOF
 fi
 
 # check for smartcard support
+libcacard_version=2.5.1
 smartcard_cflags=""
 if test "$smartcard" != "no"; then
-    if $pkg_config libcacard; then
+    if $pkg_config "libcacard >= $libcacard_version"; then
         libcacard_cflags=$($pkg_config --cflags libcacard)
         libcacard_libs=$($pkg_config --libs libcacard)
-        QEMU_CFLAGS="$QEMU_CFLAGS $libcacard_cflags"
+        QEMU_CFLAGS= $QEMU_CFLAGS $libcacard_cflags""
         libs_softmmu="$libs_softmmu $libcacard_libs"
         smartcard="yes"
     else
         if test "$smartcard" = "yes"; then
-            feature_not_found "smartcard" "Install libcacard devel"
+            feature_not_found "smartcard" "Install libcacard(>=$libcacard_version) devel"
         fi
         smartcard="no"
     fi
diff --git a/hw/usb/ccid-card-emulated.c b/hw/usb/ccid-card-emulated.c
index 869a63c..25d3e3f 100644
--- a/hw/usb/ccid-card-emulated.c
+++ b/hw/usb/ccid-card-emulated.c
@@ -26,10 +26,7 @@
  * the db parameter.
  */
 
-#include <eventt.h>
-#include <vevent.h>
-#include <vreader.h>
-#include <vcard_emul.h>
+#include <libcacard.h>
 
 #include "qemu/thread.h"
 #include "sysemu/char.h"
diff --git a/hw/usb/ccid-card-passthru.c b/hw/usb/ccid-card-passthru.c
index 9f49c05..f4c276f 100644
--- a/hw/usb/ccid-card-passthru.c
+++ b/hw/usb/ccid-card-passthru.c
@@ -12,7 +12,7 @@
 #include "qemu/error-report.h"
 #include "qemu/sockets.h"
 #include "ccid.h"
-#include "cacard/vscard_common.h"
+#include <libcacard.h>
 
 #define DPRINTF(card, lvl, fmt, ...)                    \
 do {                                                    \
-- 
2.5.0

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PATCH] ccid: use libcacard.h from 2.5.1
  2015-12-18  9:49 [Qemu-devel] [PATCH] ccid: use libcacard.h from 2.5.1 marcandre.lureau
@ 2015-12-18 12:42 ` Paolo Bonzini
  2015-12-18 12:50   ` Marc-André Lureau
  2015-12-18 13:29 ` Gerd Hoffmann
  1 sibling, 1 reply; 5+ messages in thread
From: Paolo Bonzini @ 2015-12-18 12:42 UTC (permalink / raw)
  To: marcandre.lureau, qemu-devel; +Cc: kraxel



On 18/12/2015 10:49, marcandre.lureau@redhat.com wrote:
> From: Marc-André Lureau <marcandre.lureau@redhat.com>
> 
> This cleans up a bit libcacard headers inclusion.
> 
> Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
> ---
>  configure                   | 7 ++++---
>  hw/usb/ccid-card-emulated.c | 5 +----
>  hw/usb/ccid-card-passthru.c | 2 +-
>  3 files changed, 6 insertions(+), 8 deletions(-)

Are there any distros that have not packaged libcacard yet?  This will
break compatibility with QEMU 2.4's libcacard, I think.

Paolo

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PATCH] ccid: use libcacard.h from 2.5.1
  2015-12-18 12:42 ` Paolo Bonzini
@ 2015-12-18 12:50   ` Marc-André Lureau
  2015-12-18 13:02     ` Paolo Bonzini
  0 siblings, 1 reply; 5+ messages in thread
From: Marc-André Lureau @ 2015-12-18 12:50 UTC (permalink / raw)
  To: Paolo Bonzini; +Cc: marcandre lureau, qemu-devel, kraxel

Hi

----- Original Message -----
> 
> 
> On 18/12/2015 10:49, marcandre.lureau@redhat.com wrote:
> > From: Marc-André Lureau <marcandre.lureau@redhat.com>
> > 
> > This cleans up a bit libcacard headers inclusion.
> > 
> > Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
> > ---
> >  configure                   | 7 ++++---
> >  hw/usb/ccid-card-emulated.c | 5 +----
> >  hw/usb/ccid-card-passthru.c | 2 +-
> >  3 files changed, 6 insertions(+), 8 deletions(-)
> 
> Are there any distros that have not packaged libcacard yet?  This will
> break compatibility with QEMU 2.4's libcacard, I think.

I bumped libcacard requirement to 2.5.1 in the patch.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PATCH] ccid: use libcacard.h from 2.5.1
  2015-12-18 12:50   ` Marc-André Lureau
@ 2015-12-18 13:02     ` Paolo Bonzini
  0 siblings, 0 replies; 5+ messages in thread
From: Paolo Bonzini @ 2015-12-18 13:02 UTC (permalink / raw)
  To: Marc-André Lureau; +Cc: marcandre lureau, qemu-devel, kraxel



On 18/12/2015 13:50, Marc-André Lureau wrote:
>>> > >  configure                   | 7 ++++---
>>> > >  hw/usb/ccid-card-emulated.c | 5 +----
>>> > >  hw/usb/ccid-card-passthru.c | 2 +-
>>> > >  3 files changed, 6 insertions(+), 8 deletions(-)
>> > 
>> > Are there any distros that have not packaged libcacard yet?  This will
>> > break compatibility with QEMU 2.4's libcacard, I think.
> I bumped libcacard requirement to 2.5.1 in the patch.

Yes, the question is whether distributions would have problems with that.

Paolo

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PATCH] ccid: use libcacard.h from 2.5.1
  2015-12-18  9:49 [Qemu-devel] [PATCH] ccid: use libcacard.h from 2.5.1 marcandre.lureau
  2015-12-18 12:42 ` Paolo Bonzini
@ 2015-12-18 13:29 ` Gerd Hoffmann
  1 sibling, 0 replies; 5+ messages in thread
From: Gerd Hoffmann @ 2015-12-18 13:29 UTC (permalink / raw)
  To: marcandre.lureau; +Cc: qemu-devel

On Fr, 2015-12-18 at 10:49 +0100, marcandre.lureau@redhat.com wrote:
> From: Marc-André Lureau <marcandre.lureau@redhat.com>
> 
> This cleans up a bit libcacard headers inclusion.

Makes sense, but:  When was 2.5.1 released?  I suspect it is better to
wait a bit longer with this, to give distros some time to pick up the
package.  Maybe after 2.6 release?

cheers,
  Gerd

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2015-12-18 13:29 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-12-18  9:49 [Qemu-devel] [PATCH] ccid: use libcacard.h from 2.5.1 marcandre.lureau
2015-12-18 12:42 ` Paolo Bonzini
2015-12-18 12:50   ` Marc-André Lureau
2015-12-18 13:02     ` Paolo Bonzini
2015-12-18 13:29 ` Gerd Hoffmann

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.