All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jiri Slaby <jirislaby@kernel.org>
To: Andy Shevchenko <andy.shevchenko@gmail.com>,
	David Laight <David.Laight@aculab.com>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Subject: Re: [PATCH v1 1/3] vt: keyboard, use GENMAASK()/BIT() macros instead of open coded variants
Date: Mon, 9 Nov 2020 10:57:20 +0100	[thread overview]
Message-ID: <56794a31-26ed-39eb-4082-75b5ec7cf28a@kernel.org> (raw)
In-Reply-To: <CAHp75VfTFL_7bJ5HyyuATVk32+buD9JoNDhyf1noAfoFGqJ_OQ@mail.gmail.com>

On 06. 11. 20, 17:06, Andy Shevchenko wrote:
> On Fri, Nov 6, 2020 at 5:35 PM David Laight <David.Laight@aculab.com> wrote:
>>
>> From: Andy Shevchenko
>>> Sent: 06 November 2020 14:36
>>>
>>> There are few places when GENMASK() or BIT() macro is suitable and makes code
>>> easier to understand.
>>>
>> ...
>>> -     if ((d & ~0xff) == BRL_UC_ROW) {
>>> -             if ((ch & ~0xff) == BRL_UC_ROW)
>>> +     if ((d & ~GENMASK(7, 0)) == BRL_UC_ROW) {
>>> +             if ((ch & ~GENMASK(7, 0)) == BRL_UC_ROW)
>>>                        return d | ch;
>>
>> Do you really think that makes it more readable?
> 
> Yes. Because this tells explicitly how many bits are used for metadata
> vs. data.

No, because ~0xff is clearly what it is. GENMASK(7, 0) is:
1) longer to read & parse by brain with result: "GENMASK undefined"
2) terrible in this particular use case

Another instance of an even worse switch:
-		if (arg & ~0x77)
+		if (arg & ~(GENMASK(6, 4) | GENMASK(2, 0)))

OTOH, the switch to BIT is legit in all cases except the comparisons 
with keycode:
-	if (keycode > 127)
+	if (keycode >= BIT(7))
-		if (keycode < 128) {
+		if (keycode < BIT(7)) {

That's horrid and non-sense too.

sorry,
-- 
js
suse labs

  reply	other threads:[~2020-11-09  9:57 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-06 14:35 [PATCH v1 1/3] vt: keyboard, use GENMAASK()/BIT() macros instead of open coded variants Andy Shevchenko
2020-11-06 14:35 ` [PATCH v1 2/3] vt: keyboard, replace numbers with \r, \n where appropriate Andy Shevchenko
2020-11-09  9:58   ` Jiri Slaby
2020-11-06 14:35 ` [PATCH v1 3/3] vt: keyboard, make use of assign_bit() API Andy Shevchenko
2020-11-09  9:58   ` Jiri Slaby
2020-11-06 15:33 ` [PATCH v1 1/3] vt: keyboard, use GENMAASK()/BIT() macros instead of open coded variants David Laight
2020-11-06 16:06   ` Andy Shevchenko
2020-11-09  9:57     ` Jiri Slaby [this message]
2020-11-09 10:10       ` Andy Shevchenko
2020-11-09 10:20         ` David Laight
2020-11-09 10:44           ` 'Andy Shevchenko'
2020-11-09 10:27         ` Andy Shevchenko
2020-11-09 10:41           ` Jiri Slaby
2020-11-09 10:54             ` Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=56794a31-26ed-39eb-4082-75b5ec7cf28a@kernel.org \
    --to=jirislaby@kernel.org \
    --cc=David.Laight@aculab.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=andy.shevchenko@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.