From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from eggs.gnu.org ([2001:4830:134:3::10]:52829) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1b56Pr-0007g4-1d for qemu-devel@nongnu.org; Tue, 24 May 2016 03:06:12 -0400 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71) (envelope-from ) id 1b56Po-000275-LW for qemu-devel@nongnu.org; Tue, 24 May 2016 03:06:09 -0400 Received: from mail-lf0-x244.google.com ([2a00:1450:4010:c07::244]:36436) by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1b56Po-00026w-8m for qemu-devel@nongnu.org; Tue, 24 May 2016 03:06:08 -0400 Received: by mail-lf0-x244.google.com with SMTP id d132so519881lfb.3 for ; Tue, 24 May 2016 00:06:07 -0700 (PDT) References: <1463912514-12658-1-git-send-email-davidkiarie4@gmail.com> <1463912514-12658-3-git-send-email-davidkiarie4@gmail.com> <20160524065432.GF8247@pxdev.xzpeter.org> From: Valentine Sinitsyn Message-ID: <5743FD5C.8060002@gmail.com> Date: Tue, 24 May 2016 12:06:04 +0500 MIME-Version: 1.0 In-Reply-To: <20160524065432.GF8247@pxdev.xzpeter.org> Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Subject: Re: [Qemu-devel] [V11 2/4] hw/i386: ACPI IVRS table List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , To: Peter Xu , David Kiarie Cc: qemu-devel@nongnu.org, jan.kiszka@web.de, mst@redhat.com, marcel@redhat.com Hi all, On 24.05.2016 11:54, Peter Xu wrote: > On Sun, May 22, 2016 at 01:21:52PM +0300, David Kiarie wrote: > [...] >> +static void >> +build_amd_iommu(GArray *table_data, GArray *linker) >> +{ >> + int iommu_start = table_data->len; >> + bool iommu_ambig; >> + >> + /* IVRS definition - table header has an extra 2-byte field */ >> + acpi_data_push(table_data, (sizeof(AcpiTableHeader))); >> + /* common virtualization information */ >> + build_append_int_noprefix(table_data, AMD_IOMMU_HOST_ADDRESS_WIDTH << 8, 4); >> + /* reserved */ >> + build_append_int_noprefix(table_data, 0, 8); >> + >> + AMDVIState *s = (AMDVIState *)object_resolve_path_type("", >> + TYPE_AMD_IOMMU_DEVICE, &iommu_ambig); >> + >> + /* IVDB definition - type 10h */ >> + if (!iommu_ambig) { >> + /* IVHD definition - type 10h */ >> + build_append_int_noprefix(table_data, 0x10, 1); >> + /* virtualization flags */ >> + build_append_int_noprefix(table_data, (IVHD_HT_TUNEN | >> + IVHD_PPRSUP | IVHD_IOTLBSUP | IVHD_PREFSUP), 1); >> + /* ivhd length */ >> + build_append_int_noprefix(table_data, 0x20, 2); >> + /* iommu device id */ >> + build_append_int_noprefix(table_data, PCI_DEVICE_ID_RD890_IOMMU, 2); >> + /* offset of capability registers */ >> + build_append_int_noprefix(table_data, s->capab_offset, 2); >> + /* mmio base register */ >> + build_append_int_noprefix(table_data, s->mmio.addr, 8); >> + /* pci segment */ >> + build_append_int_noprefix(table_data, 0, 2); >> + /* interrupt numbers */ >> + build_append_int_noprefix(table_data, 0, 2); >> + /* feature reporting */ >> + build_append_int_noprefix(table_data, (IVHD_EFR_GTSUP | >> + IVHD_EFR_HATS | IVHD_EFR_GATS), 4); >> + /* Add device flags here >> + * These are 4-byte device entries currently reporting the range of >> + * devices 00h - ffffh; all devices >> + * Device setting affecting all devices should be made here >> + * >> + * Refer to >> + * (http://developer.amd.com/wordpress/media/2012/10/488821.pdf) >> + * Table 95 > > I failed to find Table 95 in the document. Is that typo? I guess it should be "Table 75". David, am I right? On a side note, 2.0 specification you mention is rather outdated. Please consider referencing something newer, like 2.6. > > [...] > >> static >> void acpi_build(AcpiBuildTables *tables, MachineState *machine) >> { >> @@ -2657,6 +2721,7 @@ void acpi_build(AcpiBuildTables *tables, MachineState *machine) >> AcpiMcfgInfo mcfg; >> PcPciInfo pci; >> uint8_t *u; >> + IommuType IOMMUType = has_iommu(); >> size_t aml_len = 0; >> GArray *tables_blob = tables->table_data; >> AcpiSlicOem slic_oem = { .id = NULL, .table_id = NULL }; >> @@ -2722,7 +2787,13 @@ void acpi_build(AcpiBuildTables *tables, MachineState *machine) >> acpi_add_table(table_offsets, tables_blob); >> build_mcfg_q35(tables_blob, tables->linker, &mcfg); >> } >> - if (acpi_has_iommu()) { >> + >> + if (IOMMUType == TYPE_AMD) { >> + acpi_add_table(table_offsets, tables_blob); >> + build_amd_iommu(tables_blob, tables->linker); >> + } >> + >> + if (IOMMUType == TYPE_INTEL) { >> acpi_add_table(table_offsets, tables_blob); >> build_dmar_q35(tables_blob, tables->linker); >> } > > Nit: I'd prefer: > > if (type == Intel) { > ... > } else if (type == AMD) { > ... > } > > for better readability. > > Thanks, > > -- peterx > Best, Valentine