On 06/15/2016 11:56 AM, Markus Armbruster wrote: > PcPciInfo has two (ill-named) members: Range w32 is the PCI hole, and > w64 is the PCI64 hole. > > Three users: > > * I440FXState and MCHPCIState have a member PcPciInfo pci_info, but > only pci_info.w32 is actually used. This is confusing. Replace by > Range pci_hole. > > * acpi_build() uses auto PcPciInfo pci_info to forward both PCI holes > from acpi_get_pci_info() to build_dsdt(). Replace by two variables > Range pci_hole, pci_hole64. Rename acpi_get_pci_info() to > acpi_get_pci_holes(). > > PcPciInfo is now unused; drop it. > > Signed-off-by: Markus Armbruster > --- > hw/i386/acpi-build.c | 43 ++++++++++++++++++++++--------------------- > hw/pci-host/piix.c | 10 +++++----- > hw/pci-host/q35.c | 12 ++++++------ > include/hw/i386/pc.h | 5 ----- > include/hw/pci-host/q35.h | 2 +- > 5 files changed, 34 insertions(+), 38 deletions(-) > > +++ b/include/hw/i386/pc.h > @@ -148,11 +148,6 @@ struct PCMachineClass { > > /* PC-style peripherals (also used by other machines). */ > > -typedef struct PcPciInfo { > - Range w32; > - Range w64; > -} PcPciInfo; Confusing indeed. Good riddance. Reviewed-by: Eric Blake -- Eric Blake eblake redhat com +1-919-301-3266 Libvirt virtualization library http://libvirt.org