All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] ALSA: riptide: Use DIV_ROUND_UP
@ 2016-06-29 14:56 Amitoj Kaur Chawla
  2016-06-30  2:14 ` Takashi Sakamoto
  2016-06-30  6:35   ` Takashi Iwai
  0 siblings, 2 replies; 4+ messages in thread
From: Amitoj Kaur Chawla @ 2016-06-29 14:56 UTC (permalink / raw)
  To: perex, tiwai, alsa-devel, linux-kernel; +Cc: julia.lawall

The kernel.h macro DIV_ROUND_UP performs the computation
(((n) + (d) - 1) /(d)) but is perhaps more readable.

The Coccinelle script used to make this change is as follows:
@haskernel@
@@

#include <linux/kernel.h>

@depends on haskernel@
expression n,d;
@@

(
- (n + d - 1) / d
+ DIV_ROUND_UP(n,d)
|
- (n + (d - 1)) / d
+ DIV_ROUND_UP(n,d)
)

Signed-off-by: Amitoj Kaur Chawla <amitoj1606@gmail.com>
---
 sound/pci/riptide/riptide.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/sound/pci/riptide/riptide.c b/sound/pci/riptide/riptide.c
index 94639d6..067a912 100644
--- a/sound/pci/riptide/riptide.c
+++ b/sound/pci/riptide/riptide.c
@@ -1496,7 +1496,7 @@ static int snd_riptide_prepare(struct snd_pcm_substream *substream)
 		f = PAGE_SIZE;
 		while ((size + (f >> 1) - 1) <= (f << 7) && (f << 1) > period)
 			f = f >> 1;
-		pages = (size + f - 1) / f;
+		pages = DIV_ROUND_UP(size, f);
 		data->size = size;
 		data->pages = pages;
 		snd_printdd
-- 
1.9.1

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP
  2016-06-29 14:56 [PATCH] ALSA: riptide: Use DIV_ROUND_UP Amitoj Kaur Chawla
@ 2016-06-30  2:14 ` Takashi Sakamoto
  2016-06-30  6:35   ` Takashi Iwai
  1 sibling, 0 replies; 4+ messages in thread
From: Takashi Sakamoto @ 2016-06-30  2:14 UTC (permalink / raw)
  To: Amitoj Kaur Chawla, perex, tiwai, alsa-devel, linux-kernel; +Cc: julia.lawall

On Jun 29 2016 23:56, Amitoj Kaur Chawla wrote:
> The kernel.h macro DIV_ROUND_UP performs the computation
> (((n) + (d) - 1) /(d)) but is perhaps more readable.
>
> The Coccinelle script used to make this change is as follows:
> @haskernel@
> @@
>
> #include <linux/kernel.h>
>
> @depends on haskernel@
> expression n,d;
> @@
>
> (
> - (n + d - 1) / d
> + DIV_ROUND_UP(n,d)
> |
> - (n + (d - 1)) / d
> + DIV_ROUND_UP(n,d)
> )
>
> Signed-off-by: Amitoj Kaur Chawla <amitoj1606@gmail.com>
> ---
>   sound/pci/riptide/riptide.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/sound/pci/riptide/riptide.c b/sound/pci/riptide/riptide.c
> index 94639d6..067a912 100644
> --- a/sound/pci/riptide/riptide.c
> +++ b/sound/pci/riptide/riptide.c
> @@ -1496,7 +1496,7 @@ static int snd_riptide_prepare(struct snd_pcm_substream *substream)
>   		f = PAGE_SIZE;
>   		while ((size + (f >> 1) - 1) <= (f << 7) && (f << 1) > period)
>   			f = f >> 1;
> -		pages = (size + f - 1) / f;
> +		pages = DIV_ROUND_UP(size, f);
>   		data->size = size;
>   		data->pages = pages;
>   		snd_printdd
>

Reviewed-by: Takashi Sakamoto <o-takashi@sakamocchi.jp>


Regards

Takashi Sakamoto

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP
  2016-06-29 14:56 [PATCH] ALSA: riptide: Use DIV_ROUND_UP Amitoj Kaur Chawla
@ 2016-06-30  6:35   ` Takashi Iwai
  2016-06-30  6:35   ` Takashi Iwai
  1 sibling, 0 replies; 4+ messages in thread
From: Takashi Iwai @ 2016-06-30  6:35 UTC (permalink / raw)
  To: Amitoj Kaur Chawla; +Cc: alsa-devel, perex, linux-kernel, julia.lawall

On Wed, 29 Jun 2016 16:56:28 +0200,
Amitoj Kaur Chawla wrote:
> 
> The kernel.h macro DIV_ROUND_UP performs the computation
> (((n) + (d) - 1) /(d)) but is perhaps more readable.
> 
> The Coccinelle script used to make this change is as follows:
> @haskernel@
> @@
> 
> #include <linux/kernel.h>
> 
> @depends on haskernel@
> expression n,d;
> @@
> 
> (
> - (n + d - 1) / d
> + DIV_ROUND_UP(n,d)
> |
> - (n + (d - 1)) / d
> + DIV_ROUND_UP(n,d)
> )
> 
> Signed-off-by: Amitoj Kaur Chawla <amitoj1606@gmail.com>

Applied, thanks.


Takashi

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP
@ 2016-06-30  6:35   ` Takashi Iwai
  0 siblings, 0 replies; 4+ messages in thread
From: Takashi Iwai @ 2016-06-30  6:35 UTC (permalink / raw)
  To: Amitoj Kaur Chawla; +Cc: alsa-devel, perex, linux-kernel, julia.lawall

On Wed, 29 Jun 2016 16:56:28 +0200,
Amitoj Kaur Chawla wrote:
> 
> The kernel.h macro DIV_ROUND_UP performs the computation
> (((n) + (d) - 1) /(d)) but is perhaps more readable.
> 
> The Coccinelle script used to make this change is as follows:
> @haskernel@
> @@
> 
> #include <linux/kernel.h>
> 
> @depends on haskernel@
> expression n,d;
> @@
> 
> (
> - (n + d - 1) / d
> + DIV_ROUND_UP(n,d)
> |
> - (n + (d - 1)) / d
> + DIV_ROUND_UP(n,d)
> )
> 
> Signed-off-by: Amitoj Kaur Chawla <amitoj1606@gmail.com>

Applied, thanks.


Takashi

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2016-06-30  6:35 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-06-29 14:56 [PATCH] ALSA: riptide: Use DIV_ROUND_UP Amitoj Kaur Chawla
2016-06-30  2:14 ` Takashi Sakamoto
2016-06-30  6:35 ` Takashi Iwai
2016-06-30  6:35   ` Takashi Iwai

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.