All of lore.kernel.org
 help / color / mirror / Atom feed
From: Stanislav Kholmanskikh <stanislav.kholmanskikh@oracle.com>
To: ltp@lists.linux.it
Subject: [LTP] [PATCH 3/8] syscalls/waitpid: implement waitpid_ret_test()
Date: Fri, 19 Aug 2016 12:47:27 +0300	[thread overview]
Message-ID: <57B6D5AF.2040003@oracle.com> (raw)
In-Reply-To: <20160818155423.GC31953@rei.lan>



On 08/18/2016 06:54 PM, Cyril Hrubis wrote:
> Hi!
>> #define WAITPID_RET_TEST(wp_pid, wp_status, wp_opts, wp_ret, wp_errno)  \
>>         do {                                                            \
>>                 if (waitpid_ret_test(wp_pid, wp_status,                 \
>>                                      wp_opts, wp_ret, wp_errno)) {      \
>>                         tst_res_(__FILE__, __LINE__, TFAIL,             \
>>                                  "waitpid_ret_test() failed");          \
>>                         return;                                         \
>>                 }                                                       \
>>         } while (0)
>>
>> ?
>>
>> This will produce:
>>
>> [stas@kholmanskikh waitpid]$ ./waitpid07
>> tst_test.c:756: INFO: Timeout per run is 0h 05m 00s
>> waitpid_common.h:97: FAIL: waitpid() returned 0, expected 666
>> waitpid07.c:51: FAIL: waitpid_ret_test() failed
> 
> I guess that we can go this way and turn the last TFAIL into the TINFO.
> 
> Well, we may also do something as:
> 
> #define TST_TRACE(expr) \
> 	({int ret = expr; ret != 0 ? tst_res(TINFO, #expr " failed"), ret : ret;})

I like this idea with '#expr'.

Do you want me to put this in tst_test.h, or is it acceptable if I keep
this in waitpid_common.h? If it's acceptable, I'd rename it to
WAITPID_TEST and used the 'return' statement"

#define WAITPID_TEST(expr) \
   do { \
      if (expr) { \
          tst_rest(TINFO, #expr " failed"); \
          return; \
      } \
   } while (0);

and call it

WAITPID_TEST(waitpid_ret_test());
WAITPID_TEST(reap_children());

> 
> 
> Then call it as:
> 
> 	if (TST_TRACE(waitpid_ret_test(...)))
> 		return;
> 

  reply	other threads:[~2016-08-19  9:47 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-08-10  8:40 [LTP] waitpid: new API (part 2) Stanislav Kholmanskikh
2016-08-10  8:40 ` [LTP] [PATCH 1/8] waitpid09: use the new API Stanislav Kholmanskikh
2016-08-10  8:41   ` [LTP] [PATCH 2/8] waitpid10: " Stanislav Kholmanskikh
2016-08-10  8:41     ` [LTP] [PATCH 3/8] syscalls/waitpid: implement waitpid_ret_test() Stanislav Kholmanskikh
2016-08-10  8:41       ` [LTP] [PATCH 4/8] syscalls/waitpid: make reap_children() fail if errno is not ECHILD Stanislav Kholmanskikh
2016-08-10  8:41         ` [LTP] [PATCH 5/8] waitpid11: update the description Stanislav Kholmanskikh
2016-08-10  8:41           ` [LTP] [PATCH 6/8] waitpid12: use the new API Stanislav Kholmanskikh
2016-08-10  8:41             ` [LTP] [PATCH 7/8] waitpid13: " Stanislav Kholmanskikh
2016-08-10  8:41               ` [LTP] [PATCH 8/8] waitpid08: test stopped children Stanislav Kholmanskikh
2016-08-16 13:03                 ` Cyril Hrubis
2016-08-18 10:12                   ` Stanislav Kholmanskikh
2016-08-18 10:48                     ` Cyril Hrubis
2016-08-18 11:37                       ` Stanislav Kholmanskikh
2016-08-16 13:24               ` [LTP] [PATCH 7/8] waitpid13: use the new API Cyril Hrubis
2016-08-16 13:20             ` [LTP] [PATCH 6/8] waitpid12: " Cyril Hrubis
2016-08-15 15:51           ` [LTP] [PATCH 5/8] waitpid11: update the description Cyril Hrubis
2016-08-15 15:49         ` [LTP] [PATCH 4/8] syscalls/waitpid: make reap_children() fail if errno is not ECHILD Cyril Hrubis
2016-08-15 15:27       ` [LTP] [PATCH 3/8] syscalls/waitpid: implement waitpid_ret_test() Cyril Hrubis
2016-08-18  9:54         ` Stanislav Kholmanskikh
2016-08-18 10:42           ` Cyril Hrubis
2016-08-18 15:15             ` Stanislav Kholmanskikh
2016-08-18 15:43               ` Cyril Hrubis
2016-08-18 15:54               ` Cyril Hrubis
2016-08-19  9:47                 ` Stanislav Kholmanskikh [this message]
2016-08-22 17:38                   ` Cyril Hrubis
2016-08-15 14:36     ` [LTP] [PATCH 2/8] waitpid10: use the new API Cyril Hrubis
2016-08-18  8:25       ` Stanislav Kholmanskikh
2016-08-18  8:33         ` Stanislav Kholmanskikh
2016-08-18  9:19           ` Cyril Hrubis
2016-08-15 13:55   ` [LTP] [PATCH 1/8] waitpid09: " Cyril Hrubis
2016-08-18  7:40     ` [LTP] [PATCH 1/8 V2] " Stanislav Kholmanskikh

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=57B6D5AF.2040003@oracle.com \
    --to=stanislav.kholmanskikh@oracle.com \
    --cc=ltp@lists.linux.it \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.