From mboxrd@z Thu Jan 1 00:00:00 1970 From: Laura Abbott Subject: Re: [PATCH v2] dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro Date: Wed, 19 Apr 2017 17:28:46 -0700 Message-ID: <69283988-3a6b-fba3-529a-d5ad70eda32b@redhat.com> References: <1492630570-879-1-git-send-email-logang@deltatee.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <1492630570-879-1-git-send-email-logang-OTvnGxWRz7hWk0Htik3J/w@public.gmane.org> Content-Language: en-US Sender: linux-tegra-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org To: Logan Gunthorpe , linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, intel-gfx-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW@public.gmane.org, linux-media-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, dri-devel-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW@public.gmane.org, linux-tegra-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, devel-gWbeCf7V1WCQmaza687I9mD2FQJk+8+b@public.gmane.org Cc: Christoph Hellwig , Sumit Semwal , Russell King , David Airlie , Daniel Vetter , Jani Nikula , Sean Paul , Tomi Valkeinen , Thierry Reding , Stephen Warren , Alexandre Courbot , VMware Graphics , Sinclair Yeh , Thomas Hellstrom , Pawel Osciak , Marek Szyprowski , Kyungmin Park , Mauro Carvalho Chehab , Greg Kroah-Hartman List-Id: linux-tegra@vger.kernel.org On 04/19/2017 12:36 PM, Logan Gunthorpe wrote: > Seeing the kunmap_atomic dma_buf_ops share the same name with a macro > in highmem.h, the former can be aliased if any dma-buf user includes > that header. > > I'm personally trying to include highmem.h inside scatterlist.h and this > breaks the dma-buf code proper. > > Christoph Hellwig suggested [1] renaming it and pushing this patch ASAP. > > To maintain consistency I've renamed all four of kmap* and kunmap* to be > map* and unmap*. (Even though only kmap_atomic presently conflicts.) > > [1] https://www.spinics.net/lists/target-devel/msg15070.html > > Signed-off-by: Logan Gunthorpe > Reviewed-by: Sinclair Yeh > --- > > Changes since v1: > > - Added the missing tegra driver (noticed by kbuild robot) > - Rebased off of drm-intel-next to get the i915 selftest that is new > - Fixed nits Sinclair pointed out. > > drivers/dma-buf/dma-buf.c | 16 ++++++++-------- > drivers/gpu/drm/armada/armada_gem.c | 8 ++++---- > drivers/gpu/drm/drm_prime.c | 8 ++++---- > drivers/gpu/drm/i915/i915_gem_dmabuf.c | 8 ++++---- > drivers/gpu/drm/i915/selftests/mock_dmabuf.c | 8 ++++---- > drivers/gpu/drm/omapdrm/omap_gem_dmabuf.c | 8 ++++---- > drivers/gpu/drm/tegra/gem.c | 8 ++++---- > drivers/gpu/drm/udl/udl_dmabuf.c | 8 ++++---- > drivers/gpu/drm/vmwgfx/vmwgfx_prime.c | 8 ++++---- > drivers/media/v4l2-core/videobuf2-dma-contig.c | 4 ++-- > drivers/media/v4l2-core/videobuf2-dma-sg.c | 4 ++-- > drivers/media/v4l2-core/videobuf2-vmalloc.c | 4 ++-- > drivers/staging/android/ion/ion.c | 8 ++++---- > include/linux/dma-buf.h | 22 +++++++++++----------- > 14 files changed, 61 insertions(+), 61 deletions(-) > For Ion, Acked-by: Laura Abbott I did some major Ion refactoring but I don't think this will conflict. Thanks, Laura From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S938511AbdDTA2y (ORCPT ); Wed, 19 Apr 2017 20:28:54 -0400 Received: from mail-io0-f172.google.com ([209.85.223.172]:33346 "EHLO mail-io0-f172.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S937603AbdDTA2v (ORCPT ); Wed, 19 Apr 2017 20:28:51 -0400 Subject: Re: [PATCH v2] dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro To: Logan Gunthorpe , linux-kernel@vger.kernel.org, intel-gfx@lists.freedesktop.org, linux-media@vger.kernel.org, dri-devel@lists.freedesktop.org, linux-tegra@vger.kernel.org, devel@driverdev.osuosl.org Cc: Christoph Hellwig , Sumit Semwal , Russell King , David Airlie , Daniel Vetter , Jani Nikula , Sean Paul , Tomi Valkeinen , Thierry Reding , Stephen Warren , Alexandre Courbot , VMware Graphics , Sinclair Yeh , Thomas Hellstrom , Pawel Osciak , Marek Szyprowski , Kyungmin Park , Mauro Carvalho Chehab , Greg Kroah-Hartman , =?UTF-8?Q?Arve_Hj=c3=b8nnev=c3=a5g?= , Riley Andrews References: <1492630570-879-1-git-send-email-logang@deltatee.com> From: Laura Abbott Message-ID: <69283988-3a6b-fba3-529a-d5ad70eda32b@redhat.com> Date: Wed, 19 Apr 2017 17:28:46 -0700 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.0 MIME-Version: 1.0 In-Reply-To: <1492630570-879-1-git-send-email-logang@deltatee.com> Content-Type: text/plain; charset=utf-8; format=flowed Content-Language: en-US Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 04/19/2017 12:36 PM, Logan Gunthorpe wrote: > Seeing the kunmap_atomic dma_buf_ops share the same name with a macro > in highmem.h, the former can be aliased if any dma-buf user includes > that header. > > I'm personally trying to include highmem.h inside scatterlist.h and this > breaks the dma-buf code proper. > > Christoph Hellwig suggested [1] renaming it and pushing this patch ASAP. > > To maintain consistency I've renamed all four of kmap* and kunmap* to be > map* and unmap*. (Even though only kmap_atomic presently conflicts.) > > [1] https://www.spinics.net/lists/target-devel/msg15070.html > > Signed-off-by: Logan Gunthorpe > Reviewed-by: Sinclair Yeh > --- > > Changes since v1: > > - Added the missing tegra driver (noticed by kbuild robot) > - Rebased off of drm-intel-next to get the i915 selftest that is new > - Fixed nits Sinclair pointed out. > > drivers/dma-buf/dma-buf.c | 16 ++++++++-------- > drivers/gpu/drm/armada/armada_gem.c | 8 ++++---- > drivers/gpu/drm/drm_prime.c | 8 ++++---- > drivers/gpu/drm/i915/i915_gem_dmabuf.c | 8 ++++---- > drivers/gpu/drm/i915/selftests/mock_dmabuf.c | 8 ++++---- > drivers/gpu/drm/omapdrm/omap_gem_dmabuf.c | 8 ++++---- > drivers/gpu/drm/tegra/gem.c | 8 ++++---- > drivers/gpu/drm/udl/udl_dmabuf.c | 8 ++++---- > drivers/gpu/drm/vmwgfx/vmwgfx_prime.c | 8 ++++---- > drivers/media/v4l2-core/videobuf2-dma-contig.c | 4 ++-- > drivers/media/v4l2-core/videobuf2-dma-sg.c | 4 ++-- > drivers/media/v4l2-core/videobuf2-vmalloc.c | 4 ++-- > drivers/staging/android/ion/ion.c | 8 ++++---- > include/linux/dma-buf.h | 22 +++++++++++----------- > 14 files changed, 61 insertions(+), 61 deletions(-) > For Ion, Acked-by: Laura Abbott I did some major Ion refactoring but I don't think this will conflict. Thanks, Laura