All of lore.kernel.org
 help / color / mirror / Atom feed
From: Hannes Reinecke <hare@suse.de>
To: Christoph Hellwig <hch@lst.de>, Song Liu <song@kernel.org>
Cc: Logan Gunthorpe <logang@deltatee.com>,
	linux-raid@vger.kernel.org, linux-block@vger.kernel.org
Subject: Re: [PATCH 04/10] md: rename md_free to md_kobj_release
Date: Mon, 18 Jul 2022 09:01:34 +0200	[thread overview]
Message-ID: <6a0d6dec-a1b8-f211-2432-dd08f8b454d9@suse.de> (raw)
In-Reply-To: <20220718063410.338626-5-hch@lst.de>

On 7/18/22 08:34, Christoph Hellwig wrote:
> The md_free name is rather misleading, so pick a better one.
> 
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>   drivers/md/md.c | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/md/md.c b/drivers/md/md.c
> index 1e658d5060842..96b4e901ff6b5 100644
> --- a/drivers/md/md.c
> +++ b/drivers/md/md.c
> @@ -5589,7 +5589,7 @@ md_attr_store(struct kobject *kobj, struct attribute *attr,
>   	return rv;
>   }
>   
> -static void md_free(struct kobject *ko)
> +static void md_kobj_release(struct kobject *ko)
>   {
>   	struct mddev *mddev = container_of(ko, struct mddev, kobj);
>   
> @@ -5609,7 +5609,7 @@ static const struct sysfs_ops md_sysfs_ops = {
>   	.store	= md_attr_store,
>   };
>   static struct kobj_type md_ktype = {
> -	.release	= md_free,
> +	.release	= md_kobj_release,
>   	.sysfs_ops	= &md_sysfs_ops,
>   	.default_groups	= md_attr_groups,
>   };
Reviewed-by: Hannes Reinecke <hare@suse.de>

Cheers,

Hannes


  reply	other threads:[~2022-07-18  7:01 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-18  6:34 fix md disk_name lifetime problems v3 Christoph Hellwig
2022-07-18  6:34 ` [PATCH 01/10] md: fix mddev->kobj lifetime Christoph Hellwig
2022-07-18  6:55   ` Hannes Reinecke
2022-07-18 19:48   ` Logan Gunthorpe
2022-07-18  6:34 ` [PATCH 02/10] md: fix error handling in md_alloc Christoph Hellwig
2022-07-18  7:00   ` Hannes Reinecke
2022-07-18 19:48   ` Logan Gunthorpe
2022-07-18  6:34 ` [PATCH 03/10] md: implement ->free_disk Christoph Hellwig
2022-07-18  7:01   ` Hannes Reinecke
2022-07-18 20:01   ` Logan Gunthorpe
2022-07-18  6:34 ` [PATCH 04/10] md: rename md_free to md_kobj_release Christoph Hellwig
2022-07-18  7:01   ` Hannes Reinecke [this message]
2022-07-18 20:02   ` Logan Gunthorpe
2022-07-18  6:34 ` [PATCH 05/10] md: factor out the rdev overlaps check from rdev_size_store Christoph Hellwig
2022-07-18  7:02   ` Hannes Reinecke
2022-07-18 20:02   ` Logan Gunthorpe
2022-07-18  6:34 ` [PATCH 06/10] md: stop using for_each_mddev in md_do_sync Christoph Hellwig
2022-07-18  7:03   ` Hannes Reinecke
2022-07-18 20:02   ` Logan Gunthorpe
2022-07-18  6:34 ` [PATCH 07/10] md: stop using for_each_mddev in md_notify_reboot Christoph Hellwig
2022-07-18  7:05   ` Hannes Reinecke
2022-07-18 20:03   ` Logan Gunthorpe
2022-07-18  6:34 ` [PATCH 08/10] md: stop using for_each_mddev in md_exit Christoph Hellwig
2022-07-18  7:10   ` Hannes Reinecke
2022-07-19  7:03     ` Christoph Hellwig
2022-07-19  7:06       ` Hannes Reinecke
2022-07-18 20:03   ` Logan Gunthorpe
2022-07-18  6:34 ` [PATCH 09/10] md: only delete entries from all_mddevs when the disk is freed Christoph Hellwig
2022-07-18  7:17   ` Hannes Reinecke
2022-07-18 18:20     ` Song Liu
2022-07-19  5:06       ` Christoph Hellwig
2022-07-19  6:28         ` Song Liu
2022-07-19  7:00         ` Hannes Reinecke
2022-07-19  7:14     ` Christoph Hellwig
2022-07-19  7:59       ` Hannes Reinecke
2022-07-18  6:34 ` [PATCH 10/10] md: simplify md_open Christoph Hellwig
2022-07-18  7:19   ` Hannes Reinecke
2022-07-19  9:18 fix md disk_name lifetime problems v4 Christoph Hellwig
2022-07-19  9:18 ` [PATCH 04/10] md: rename md_free to md_kobj_release Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=6a0d6dec-a1b8-f211-2432-dd08f8b454d9@suse.de \
    --to=hare@suse.de \
    --cc=hch@lst.de \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=logang@deltatee.com \
    --cc=song@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.