All of lore.kernel.org
 help / color / mirror / Atom feed
From: James Morse <james.morse@arm.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Fenghua Yu <fenghua.yu@intel.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
	shameerali.kolothum.thodi@huawei.com,
	Jamie Iles <jamie@nuviainc.com>,
	D Scott Phillips OS <scott@os.amperecomputing.com>,
	lcherian@marvell.com, "Luck, Tony" <tony.luck@intel.com>
Subject: Re: [PATCH v4 00/24] x86/resctrl: Merge the CDP resources
Date: Thu, 17 Jun 2021 18:03:57 +0100	[thread overview]
Message-ID: <6bf16e35-003a-0847-c15e-ed66fb302390@arm.com> (raw)
In-Reply-To: <f0f112c3-e17d-958f-2378-b73643c7ca58@intel.com>

Hi Reinette,

On 15/06/2021 19:05, Reinette Chatre wrote:
> On 6/15/2021 9:48 AM, James Morse wrote:
>> On 15/06/2021 17:16, Reinette Chatre wrote:
>>> On 6/14/2021 1:09 PM, James Morse wrote:
>>> For the most part I think this series looks good. The one thing I am concerned about is
>>> the resctrl user interface change. On a system that supports L3 CDP there is a visible
>>> change when CDP is not enabled:
>>>
>>> Before this series:
>>> # cat schemata
>>>     L3:0=fffff;1=fffff
>>>
>>> After this series:
>>> # cat schemata
>>> L3:0=fffff;1=fffff
>>
>> Hmm, I thought I'd fixed this with v2, ... I see this is subtly different.
>>
>> This could be tweaked by getting schemata_list_add() to include the length of the longest
>> suffix if the resource supports CDP, but its not enabled. (Discovering that means
>> cdp_capable moves to be something the 'fs' bits of resctrl can see.)

>> I'm a little nervous 'adding 4 spaces' because user-space expects them. (I agree if it
>> breaks user-space it has to be done). I guess this is the problem with string parsing as
>> part of the interface!

> This is a tricky and interesting one. It seems that the original intended behavior is
> indeed the way you changed it to. By originally using for_each_enabled_rdt_resource() to
> determine the maximum width in de016df88f23 ("x86/intel_rdt: Update schemata read to show
> data in tabular format"). This was added in v4.12 and dictated the interface until v4.13.
> This was changed in 1b5c0b758317 ("x86/intel_rdt: Cleanup namespace to support RDT
> monitoring") when it used for_each_alloc_capable_rdt_resource(r) instead, added in v4.14
> that is a stable kernel and the most likely interface used by users.
> 
> To me the less risky change is to maintain the existing interface, but perhaps there are
> some other guidance in this regard?

I think this is just the problem with having anything other than 'one value per file', as
sysfs does. Maintaining it involves getting painted into a corner by the worst parser
user-space manages to come up with!


>> I assume that in the (distant) future having CDP capable resources with names more than 2
>> characters isn't going to be a problem. (I don't have an example)
> 
> The last statement is not clear to me. Could you please elaborate why two characters would
> be significant? From what I understand the expectation would be that the width is the
> maximum name length of all possible schema, whether they are enabled or not.

Great - I was nervous that if shorter strings are a problem, what about longer?

( Arm SoCs often have a system-cache that lives between the LLC and DRAM. Its not a CPU
cache, so its not really L4. Because of the way CDP gets emulated it affects all caches.
If people build these things with MPAM support - and we choose to add a schema for them:
you'd end up with 'SYSTEM-CACHECODE' and 'SYSTEM-CACHEDATA'. Its not a real example as if
its needed, 'SC' is probably acceptable.)


>>> There are a few user space tools that parse the resctrl schemata file and it may be easier
>>> to keep the interface consistent than to find and audit them all to ensure they will keep
>>> working.
> 
> To me this continues the biggest hurdle in maintaining the behavior as you have it in this
> series.

No problem - I've changed it as described.


>>> A heads-up is that there are some kernel-doc fixups in the works that will conflict with
>>> your series. You yourself fix at least one of these kernel-doc issues in this series - the
>>> description of mbm_width in the first patch. I will ask the submitter of the kernel-doc
>>> fixups to use your text to help with the merging.
>>
>> Please point me at something to rebase onto!
>> (as far as I can see, tip/x86/cache hasn't moved)
> 
> These patches have not yet been merged. The most recent version was sent yesterday. Your
> current base is good.

I've based on tip/master, which merged rc6....


Thanks,

James

  reply	other threads:[~2021-06-17 17:04 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-14 20:09 [PATCH v4 00/24] x86/resctrl: Merge the CDP resources James Morse
2021-06-14 20:09 ` [PATCH v4 01/24] x86/resctrl: Split struct rdt_resource James Morse
2021-06-15 18:07   ` Reinette Chatre
2021-06-14 20:09 ` [PATCH v4 02/24] x86/resctrl: Split struct rdt_domain James Morse
2021-06-15 17:51   ` Babu Moger
2021-06-17 17:02     ` James Morse
2021-06-15 18:07   ` Reinette Chatre
2021-06-14 20:09 ` [PATCH v4 03/24] x86/resctrl: Add a separate schema list for resctrl James Morse
2021-06-15 17:51   ` Babu Moger
2021-06-17 17:02     ` James Morse
2021-06-14 20:09 ` [PATCH v4 04/24] x86/resctrl: Pass the schema in info dir's private pointer James Morse
2021-06-14 20:09 ` [PATCH v4 05/24] x86/resctrl: Label the resources with their configuration type James Morse
2021-06-15 18:08   ` Reinette Chatre
2021-06-14 20:09 ` [PATCH v4 06/24] x86/resctrl: Walk the resctrl schema list instead of an arch list James Morse
2021-06-14 20:09 ` [PATCH v4 07/24] x86/resctrl: Store the effective num_closid in the schema James Morse
2021-06-14 20:09 ` [PATCH v4 08/24] x86/resctrl: Add resctrl_arch_get_num_closid() James Morse
2021-06-14 20:09 ` [PATCH v4 09/24] x86/resctrl: Pass the schema to resctrl filesystem functions James Morse
2021-06-15 18:08   ` Reinette Chatre
2021-06-14 20:09 ` [PATCH v4 10/24] x86/resctrl: Swizzle rdt_resource and resctrl_schema in pseudo_lock_region James Morse
2021-06-14 20:09 ` [PATCH v4 11/24] x86/resctrl: Move the schemata names into struct resctrl_schema James Morse
2021-06-15 18:08   ` Reinette Chatre
2021-06-14 20:09 ` [PATCH v4 12/24] x86/resctrl: Group staged configuration into a separate struct James Morse
2021-06-15 18:08   ` Reinette Chatre
2021-06-14 20:09 ` [PATCH v4 13/24] x86/resctrl: Allow different CODE/DATA configurations to be staged James Morse
2021-06-14 20:09 ` [PATCH v4 14/24] x86/resctrl: Rename update_domains() resctrl_arch_update_domains() James Morse
2021-06-14 20:09 ` [PATCH v4 15/24] x86/resctrl: Add a helper to read a closid's configuration James Morse
2021-06-14 20:09 ` [PATCH v4 16/24] x86/resctrl: Add a helper to read/set the CDP configuration James Morse
2021-06-14 20:09 ` [PATCH v4 17/24] x86/resctrl: Pass configuration type to resctrl_arch_get_config() James Morse
2021-06-14 20:09 ` [PATCH v4 18/24] x86/resctrl: Make ctrlval arrays the same size James Morse
2021-06-15 18:09   ` Reinette Chatre
2021-06-17 17:03     ` James Morse
2021-06-14 20:09 ` [PATCH v4 19/24] x86/resctrl: Apply offset correction when config is staged James Morse
2021-06-14 20:09 ` [PATCH v4 20/24] x86/resctrl: Calculate the index from the configuration type James Morse
2021-06-14 20:09 ` [PATCH v4 21/24] x86/resctrl: Merge the ctrl_val arrays James Morse
2021-06-14 20:09 ` [PATCH v4 22/24] x86/resctrl: Remove rdt_cdp_peer_get() James Morse
2021-06-14 20:09 ` [PATCH v4 23/24] x86/resctrl: Expand resctrl_arch_update_domains()'s msr_param range James Morse
2021-06-14 20:09 ` [PATCH v4 24/24] x86/resctrl: Merge the CDP resources James Morse
2021-06-15 16:16 ` [PATCH v4 00/24] " Reinette Chatre
2021-06-15 16:48   ` James Morse
2021-06-15 17:25     ` Borislav Petkov
2021-06-15 18:05     ` Reinette Chatre
2021-06-17 17:03       ` James Morse [this message]
2021-06-15 17:50 ` Babu Moger

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=6bf16e35-003a-0847-c15e-ed66fb302390@arm.com \
    --to=james.morse@arm.com \
    --cc=Babu.Moger@amd.com \
    --cc=bp@alien8.de \
    --cc=fenghua.yu@intel.com \
    --cc=hpa@zytor.com \
    --cc=jamie@nuviainc.com \
    --cc=lcherian@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=reinette.chatre@intel.com \
    --cc=scott@os.amperecomputing.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=tglx@linutronix.de \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.