All of lore.kernel.org
 help / color / mirror / Atom feed
From: Thomas Huth <thuth@redhat.com>
To: Pierre Morel <pmorel@linux.ibm.com>, kvm@vger.kernel.org
Cc: linux-s390@vger.kernel.org, frankja@linux.ibm.com,
	david@redhat.com, cohuck@redhat.com
Subject: Re: [kvm-unit-tests PATCH v8 01/12] s390x: Use PSW bits definitions in cstart
Date: Mon, 8 Jun 2020 17:30:53 +0200	[thread overview]
Message-ID: <77f6ed8f-4b4c-be0f-f29a-429618c9e3c0@redhat.com> (raw)
In-Reply-To: <d94b6f43-2250-17ee-e146-1347c0350294@linux.ibm.com>

On 08/06/2020 17.28, Pierre Morel wrote:
> 
> 
> On 2020-06-08 16:52, Thomas Huth wrote:
>> On 08/06/2020 16.33, Pierre Morel wrote:
>>>
>>>
>>> On 2020-06-08 10:43, Thomas Huth wrote:
>>>> On 08/06/2020 10.12, Pierre Morel wrote:
>>>>> This patch defines the PSW bits EA/BA used to initialize the PSW masks
>>>>> for exceptions.
>>>>>
>>>>> Since some PSW mask definitions exist already in arch_def.h we add
>>>>> these
>>>>> definitions there.
>>>>> We move all PSW definitions together and protect assembler code
>>>>> against
>>>>> C syntax.
>>>>>
>>>>> Signed-off-by: Pierre Morel <pmorel@linux.ibm.com>
>>>>> Reviewed-by: Janosch Frank <frankja@linux.ibm.com>
>>>>> ---
>>>>>    lib/s390x/asm/arch_def.h | 15 +++++++++++----
>>>>>    s390x/cstart64.S         | 15 ++++++++-------
>>>>>    2 files changed, 19 insertions(+), 11 deletions(-)
>>>>>
>>>>> diff --git a/lib/s390x/asm/arch_def.h b/lib/s390x/asm/arch_def.h
>>>>> index 1b3bb0c..5388114 100644
>>>>> --- a/lib/s390x/asm/arch_def.h
>>>>> +++ b/lib/s390x/asm/arch_def.h
>>>>> @@ -10,15 +10,21 @@
>>>>>    #ifndef _ASM_S390X_ARCH_DEF_H_
>>>>>    #define _ASM_S390X_ARCH_DEF_H_
>>>>>    +#define PSW_MASK_EXT            0x0100000000000000UL
>>>>> +#define PSW_MASK_DAT            0x0400000000000000UL
>>>>> +#define PSW_MASK_SHORT_PSW        0x0008000000000000UL
>>>>> +#define PSW_MASK_PSTATE            0x0001000000000000UL
>>>>> +#define PSW_MASK_BA            0x0000000080000000UL
>>>>> +#define PSW_MASK_EA            0x0000000100000000UL
>>>>> +
>>>>> +#define PSW_EXCEPTION_MASK    (PSW_MASK_EA | PSW_MASK_BA)
>>>>
>>>> PSW_EXCEPTION_MASK sounds a little bit unfortunate - that term rather
>>>> reminds me of something that disables some interrupts
>>>> ... in case you
>>>> respin, maybe rather use something like "PSW_EXC_ADDR_MODE" ?
>>>
>>> EXCEPTIONS_PSW_MASK ?
>>
>> I think it is the _MASK suffix that mainly bugs me here, since this is
>> not a define that you normally use for extracting the bits from a PSW...
>> so EXCEPTIONS_PSW without _MASK would be fine for me... but as long as
>> I'm the only one who has a strange feeling about this, it's also ok if
>> you keep the current name.
>>
>>   Thomas
>>
> 
> The _MASK is because it is applied to the psw.mask and not to the
> psw.addr part.
> 
> But I agree that the name is not good, to keep the naming convention,
> may be it should be:
> 
> PSW_MASK_ON_EXCEPTION
> 
> beginning with PSW_MASK_ like all other psw.mask definitions and
> ON_EXCEPTION clearly define when it is used.

Good idea, PSW_MASK_ON_EXCEPTION sounds better for me, too!

 Thomas

  reply	other threads:[~2020-06-08 15:31 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-08  8:12 [kvm-unit-tests PATCH v8 00/12] s390x: Testing the Channel Subsystem I/O Pierre Morel
2020-06-08  8:12 ` [kvm-unit-tests PATCH v8 01/12] s390x: Use PSW bits definitions in cstart Pierre Morel
2020-06-08  8:43   ` Thomas Huth
2020-06-08 14:33     ` Pierre Morel
2020-06-08 14:52       ` Thomas Huth
2020-06-08 15:28         ` Pierre Morel
2020-06-08 15:30           ` Thomas Huth [this message]
2020-06-08  8:12 ` [kvm-unit-tests PATCH v8 02/12] s390x: Move control register bit definitions and add AFP to them Pierre Morel
2020-06-08  8:45   ` Thomas Huth
2020-06-08 14:25     ` Pierre Morel
2020-06-08  8:12 ` [kvm-unit-tests PATCH v8 03/12] s390x: saving regs for interrupts Pierre Morel
2020-06-08  9:05   ` Thomas Huth
2020-06-08 14:24     ` Pierre Morel
2020-06-08 15:29       ` Thomas Huth
2020-06-08 16:03         ` Pierre Morel
2020-06-08  8:12 ` [kvm-unit-tests PATCH v8 04/12] s390x: interrupt registration Pierre Morel
2020-06-08  8:12 ` [kvm-unit-tests PATCH v8 05/12] s390x: export the clock get_clock_ms() utility Pierre Morel
2020-06-08  8:12 ` [kvm-unit-tests PATCH v8 06/12] s390x: clock and delays caluculations Pierre Morel
2020-06-08 15:55   ` Thomas Huth
2020-06-08 16:16     ` Pierre Morel
2020-06-08  8:12 ` [kvm-unit-tests PATCH v8 07/12] s390x: define function to wait for interrupt Pierre Morel
2020-06-09  5:07   ` Thomas Huth
2020-06-09  7:54     ` Pierre Morel
2020-06-08  8:12 ` [kvm-unit-tests PATCH v8 08/12] s390x: retrieve decimal and hexadecimal kernel parameters Pierre Morel
2020-06-09  5:21   ` Thomas Huth
2020-06-09  7:53     ` Pierre Morel
2020-06-08  8:12 ` [kvm-unit-tests PATCH v8 09/12] s390x: Library resources for CSS tests Pierre Morel
2020-06-09  7:09   ` Thomas Huth
2020-06-09 15:01     ` Pierre Morel
2020-06-10 14:51       ` Thomas Huth
2020-06-10 15:10         ` Pierre Morel
2020-06-08  8:12 ` [kvm-unit-tests PATCH v8 10/12] s390x: css: stsch, enumeration test Pierre Morel
2020-06-09  7:39   ` Thomas Huth
2020-06-09 12:20     ` Pierre Morel
2020-06-10 15:54       ` Cornelia Huck
2020-06-08  8:13 ` [kvm-unit-tests PATCH v8 11/12] s390x: css: msch, enable test Pierre Morel
2020-06-09  7:47   ` Thomas Huth
2020-06-09  7:56     ` Pierre Morel
2020-06-08  8:13 ` [kvm-unit-tests PATCH v8 12/12] s390x: css: ssch/tsch with sense and interrupt Pierre Morel
2020-06-09  8:15   ` Thomas Huth
2020-06-09 12:02     ` Pierre Morel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=77f6ed8f-4b4c-be0f-f29a-429618c9e3c0@redhat.com \
    --to=thuth@redhat.com \
    --cc=cohuck@redhat.com \
    --cc=david@redhat.com \
    --cc=frankja@linux.ibm.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-s390@vger.kernel.org \
    --cc=pmorel@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.