All of lore.kernel.org
 help / color / mirror / Atom feed
From: Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
To: Lee Jones <lee.jones@linaro.org>
Cc: Rob Herring <robh+dt@kernel.org>,
	Liam Girdwood <lgirdwood@gmail.com>,
	Mark Brown <broonie@kernel.org>,
	Wim Van Sebroeck <wim@linux-watchdog.org>,
	Guenter Roeck <linux@roeck-us.net>,
	Geert Uytterhoeven <geert+renesas@glider.be>,
	devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-power@fi.rohmeurope.com, linux-watchdog@vger.kernel.org,
	Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
Subject: Re: [PATCH v7 2/6] mfd: Support ROHM BD9576MUF and BD9573MUF
Date: Wed, 10 Feb 2021 08:15:44 +0200	[thread overview]
Message-ID: <79e133f33ed9bf03b255aab00542d360ad91174c.camel@fi.rohmeurope.com> (raw)
In-Reply-To: <20210209145507.GA220368@dell>

Hello Lee,

On Tue, 2021-02-09 at 14:55 +0000, Lee Jones wrote:
> On Fri, 22 Jan 2021, Matti Vaittinen wrote:
> 
> > Add core support for ROHM BD9576MUF and BD9573MUF PMICs which are
> > mainly used to power the R-Car series processors.
> > 
> > Signed-off-by: Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
> > ---
> > +
> > +static struct mfd_cell bd9573_mfd_cells[] = {
> > +	{ .name = "bd9573-pmic", },
> > +	{ .name = "bd9576-wdt", },
> > +};
> > +
> > +static struct mfd_cell bd9576_mfd_cells[] = {
> > +	{ .name = "bd9576-pmic", },
> > +	{ .name = "bd9576-wdt", },
> > +};
> 
> What is a PMIC in this context?
> 
> To me a PMIC is a bunch of devices.  What is this probing?

I agree. PMIC is the IC as a whole. This name was not the best one. 
> 
> Maybe this is *-regulator?

That would be more descriptive and I can change this. However, it means
I need to change the already applied regulator part too. Furthermore,
all other ROHM PMIC drivers I've written use the <part-name>-pmic for
regulators and so does a few other drivers at least for ICs from Maxim,
Samsung and TI. That's why I don't think the <partname>-pmic is that
confusing. If it was my decision, I would stick with the pmic for the
sake of the consistency.

+
> > +	ret = devm_mfd_add_devices(&i2c->dev, PLATFORM_DEVID_AUTO, mfd,
> > cells,
> 
> This nomenclature is confusing.
> 
> cells and num_cells would clear it up.

I can change it.
+
> > +#define BD957X_MAX_REGISTER 0x61
> 
> Nit: Can you tab these out for improved readability please?
Sure, no problem.

Thanks for the review!

Best Regards
	--Matti

--
Matti Vaittinen, Linux device drivers
ROHM Semiconductors, Finland
SWDC
Kiviharjunlenkki 1E
90220 OULU
FINLAND

~~~ "I don't think so," said Rene Descartes. Just then he vanished ~~~

Simon says - in Latin please.
"non cogito me" dixit Rene Descarte, deinde evanescavit

(Thanks for the translation Simon)



  reply	other threads:[~2021-02-10  6:17 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-22 14:30 [PATCH v7 0/6] Support ROHM BD9576MUF and BD9573MUF PMICs Matti Vaittinen
2021-01-22 14:32 ` [PATCH v7 1/6] dt_bindings: mfd: Add " Matti Vaittinen
2021-01-22 14:32 ` [PATCH v7 2/6] mfd: Support ROHM BD9576MUF and BD9573MUF Matti Vaittinen
2021-02-09 14:55   ` Lee Jones
2021-02-10  6:15     ` Matti Vaittinen [this message]
2021-01-22 14:33 ` [PATCH v7 3/6] mfd: bd9576: Add IRQ support Matti Vaittinen
2021-02-09 15:25   ` Lee Jones
2021-02-10  7:01     ` Matti Vaittinen
2021-02-11  7:15       ` Vaittinen, Matti
2021-01-22 14:34 ` [PATCH v7 4/6] wdt: Support wdt on ROHM BD9576MUF and BD9573MUF Matti Vaittinen
2021-01-22 14:35 ` [PATCH v7 5/6] MAINTAINERS: Add ROHM BD9576MUF and BD9573MUF drivers Matti Vaittinen
2021-01-23 18:38   ` Guenter Roeck
2021-01-22 14:36 ` [PATCH v7 6/6] regulator: bd9576: Support error reporting Matti Vaittinen
2021-01-24 18:56   ` kernel test robot
2021-01-24 18:56     ` kernel test robot
2021-02-09 14:19 ` [PATCH v7 0/6] Support ROHM BD9576MUF and BD9573MUF PMICs Vaittinen, Matti

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=79e133f33ed9bf03b255aab00542d360ad91174c.camel@fi.rohmeurope.com \
    --to=matti.vaittinen@fi.rohmeurope.com \
    --cc=broonie@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=geert+renesas@glider.be \
    --cc=lee.jones@linaro.org \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-power@fi.rohmeurope.com \
    --cc=linux-watchdog@vger.kernel.org \
    --cc=linux@roeck-us.net \
    --cc=robh+dt@kernel.org \
    --cc=wim@linux-watchdog.org \
    --cc=yoshihiro.shimoda.uh@renesas.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.