All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jani Nikula <jani.nikula@intel.com>
To: Lyude Paul <lyude@redhat.com>, intel-gfx@lists.freedesktop.org
Subject: Re: [Intel-gfx] [PATCH 0/3] drm/i915: better backlight & panel abstractions
Date: Wed, 25 Aug 2021 20:36:34 +0300	[thread overview]
Message-ID: <875yvte89p.fsf@intel.com> (raw)
In-Reply-To: <f6a0203f9871cb91fb8da5a83bc8a608e2bb1607.camel@redhat.com>

On Wed, 25 Aug 2021, Lyude Paul <lyude@redhat.com> wrote:
> Reviewed-by: Lyude Paul <lyude@redhat.com> (assuming this still applies)
>
> As I mentioned on IRC pretty much all of the DPCD backlight helpers already
> made it upstream. There are some changes I'm working on right now for VESA
> backlights that use PWM for controlling the brightness level (so we can
> hopefully fix https://gitlab.freedesktop.org/drm/intel/-/issues/3680 ,
> otherwise I've gotta do some more poking with the backlight folks from Intel I
> got in touch with), but I have no problem with rebasing this when the time
> comes.

Thanks!

BR,
Jani.

>
> On Wed, 2021-08-25 at 14:06 +0300, Jani Nikula wrote:
>> Extract the backlight code out of intel_panel.c, and rename the panel
>> and backlight functions according to usual conventions.
>> 
>> Lyude, I haven't seen follow-ups on the DPCD backlight stuff you've
>> worked on. Is it okay to merge this (and inevitably cause you conflicts)
>> or shall I wait more?
>> 
>> BR,
>> Jani.
>> 
>> 
>> Cc: Lyude Paul <lyude@redhat.com>
>> 
>> Jani Nikula (3):
>>   drm/i915/backlight: extract backlight code to a separate file
>>   drm/i915/backlight: mass rename functions to have intel_backlight_
>>     prefix
>>   drm/i915/panel: mass rename functions to have intel_panel_ prefix
>> 
>>  drivers/gpu/drm/i915/Makefile                 |    1 +
>>  drivers/gpu/drm/i915/display/g4x_dp.c         |    4 +-
>>  drivers/gpu/drm/i915/display/icl_dsi.c        |   13 +-
>>  .../gpu/drm/i915/display/intel_backlight.c    | 1776 ++++++++++++++++
>>  .../gpu/drm/i915/display/intel_backlight.h    |   52 +
>>  .../gpu/drm/i915/display/intel_connector.c    |    4 +-
>>  drivers/gpu/drm/i915/display/intel_ddi.c      |    4 +-
>>  drivers/gpu/drm/i915/display/intel_dp.c       |   16 +-
>>  .../drm/i915/display/intel_dp_aux_backlight.c |   12 +-
>>  drivers/gpu/drm/i915/display/intel_dvo.c      |    2 +-
>>  drivers/gpu/drm/i915/display/intel_hdmi.c     |    2 +-
>>  drivers/gpu/drm/i915/display/intel_lvds.c     |   18 +-
>>  drivers/gpu/drm/i915/display/intel_opregion.c |    5 +-
>>  drivers/gpu/drm/i915/display/intel_panel.c    | 1786 +----------------
>>  drivers/gpu/drm/i915/display/intel_panel.h    |   42 +-
>>  drivers/gpu/drm/i915/display/vlv_dsi.c        |   16 +-
>>  16 files changed, 1895 insertions(+), 1858 deletions(-)
>>  create mode 100644 drivers/gpu/drm/i915/display/intel_backlight.c
>>  create mode 100644 drivers/gpu/drm/i915/display/intel_backlight.h
>> 

-- 
Jani Nikula, Intel Open Source Graphics Center

  reply	other threads:[~2021-08-25 17:36 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-08-25 11:06 [Intel-gfx] [PATCH 0/3] drm/i915: better backlight & panel abstractions Jani Nikula
2021-08-25 11:06 ` [Intel-gfx] [PATCH 1/3] drm/i915/backlight: extract backlight code to a separate file Jani Nikula
2021-08-25 11:06 ` [Intel-gfx] [PATCH 2/3] drm/i915/backlight: mass rename functions to have intel_backlight_ prefix Jani Nikula
2021-08-25 11:06 ` [Intel-gfx] [PATCH 3/3] drm/i915/panel: mass rename functions to have intel_panel_ prefix Jani Nikula
2021-08-25 12:13 ` [Intel-gfx] ✗ Fi.CI.CHECKPATCH: warning for drm/i915: better backlight & panel abstractions Patchwork
2021-08-25 12:44 ` [Intel-gfx] ✓ Fi.CI.BAT: success " Patchwork
2021-08-25 16:50 ` [Intel-gfx] [PATCH 0/3] " Lyude Paul
2021-08-25 17:36   ` Jani Nikula [this message]
2021-08-26  7:48     ` Jani Nikula
2021-08-25 18:01 ` [Intel-gfx] ✓ Fi.CI.IGT: success for " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=875yvte89p.fsf@intel.com \
    --to=jani.nikula@intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=lyude@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.