Lukasz Kalamarz writes: > getparam is used in few places across IGT, but no helper function > is used to reduce code duplication. > v2: Added doc part and changed return value in case of error > > Signed-off-by: Lukasz Kalamarz > > Cc: Michal Winiarski > Cc: Katarzyna Dec > Cc: Daniele Ceraolo Spurio > --- > lib/ioctl_wrappers.c | 22 ++++++++++++++++++++++ > lib/ioctl_wrappers.h | 1 + > 2 files changed, 23 insertions(+) > > diff --git a/lib/ioctl_wrappers.c b/lib/ioctl_wrappers.c > index 9f255508..aec4f15e 100644 > --- a/lib/ioctl_wrappers.c > +++ b/lib/ioctl_wrappers.c > @@ -468,6 +468,28 @@ void gem_sync(int fd, uint32_t handle) > errno = 0; > } > > +/** > + * drm_get_param: > + * @fd: open i915 drm file descriptor > + * @param: drm parameter we want to read Could we please call this i915_get_param, to match the commit message, instead of drm_get_param()? I know igt used to call i915-only ioctls drm_* or gem_*, but it would be nice to see new functions use a more appropriate namespace. (I wouldn't block this, but if people decide not to do that then the commit message subject should at least change)