All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: Greg Kurz <groug@kaod.org>
Cc: peter.maydell@linaro.org, vsementsov@virtuozzo.com,
	berrange@redhat.com, ehabkost@redhat.com, qemu-block@nongnu.org,
	qemu-devel@nongnu.org, pbonzini@redhat.com
Subject: Re: [PATCH v3 03/44] qdev: Use returned bool to check for qdev_realize() etc. failure
Date: Mon, 06 Jul 2020 13:35:19 +0200	[thread overview]
Message-ID: <87k0zganbc.fsf@dusky.pond.sub.org> (raw)
In-Reply-To: <20200706120718.70c37bc0@bahia.lan> (Greg Kurz's message of "Mon,  6 Jul 2020 12:08:16 +0200")

Greg Kurz <groug@kaod.org> writes:

> On Mon,  6 Jul 2020 10:09:09 +0200
> Markus Armbruster <armbru@redhat.com> wrote:
>
>> Convert
>> 
>>     foo(..., &err);
>>     if (err) {
>>         ...
>>     }
>> 
>> to
>> 
>>     if (!foo(..., &err)) {
>>         ...
>>     }
>> 
>> for qdev_realize(), qdev_realize_and_unref(), qbus_realize() and their
>> wrappers isa_realize_and_unref(), pci_realize_and_unref(),
>> sysbus_realize(), sysbus_realize_and_unref(), usb_realize_and_unref().
>> Coccinelle script:
>> 
>>     @@
>>     identifier fun = {
>>         isa_realize_and_unref, pci_realize_and_unref, qbus_realize,
>>         qdev_realize, qdev_realize_and_unref, sysbus_realize,
>>         sysbus_realize_and_unref, usb_realize_and_unref
>>     };
>>     expression list args, args2;
>>     typedef Error;
>>     Error *err;
>>     @@
>>     -    fun(args, &err, args2);
>>     -    if (err)
>>     +    if (!fun(args, &err, args2))
>>          {
>>              ...
>>          }
>> 
>> Chokes on hw/arm/musicpal.c's lcd_refresh() with the unhelpful error
>> message "no position information".  Nothing to convert there; skipped.
>> 
>> Fails to convert hw/arm/armsse.c, because Coccinelle gets confused by
>> ARMSSE being used both as typedef and function-like macro there.
>> Converted manually.
>> 
>> A few line breaks tidied up manually.
>> 
>> Signed-off-by: Markus Armbruster <armbru@redhat.com>
>> Reviewed-by: Eric Blake <eblake@redhat.com>
>> Reviewed-by: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com>
>> ---
>
> FWIW I had posted an R-b for this patch in v1 (20200629124037.2b9a269e@bahia.lan).

When I sliced and diced my patches for v2, I dropped R-bys for patches
substantially altered.  This one was borderline: the patch does strictly
less, and the work it no longer does us done by later patches.

Example: v1's first hunk

    diff --git a/hw/arm/allwinner-a10.c b/hw/arm/allwinner-a10.c
    index 52e0d83760..3e45aa4141 100644
    --- a/hw/arm/allwinner-a10.c
    +++ b/hw/arm/allwinner-a10.c
    @@ -72,17 +72,12 @@ static void aw_a10_realize(DeviceState *dev, Error **errp)
     {
         AwA10State *s = AW_A10(dev);
         SysBusDevice *sysbusdev;
    -    Error *err = NULL;

    -    qdev_realize(DEVICE(&s->cpu), NULL, &err);
    -    if (err != NULL) {
    -        error_propagate(errp, err);
    +    if (!qdev_realize(DEVICE(&s->cpu), NULL, errp)) {
             return;
         }

    -    sysbus_realize(SYS_BUS_DEVICE(&s->intc), &err);
    -    if (err != NULL) {
    -        error_propagate(errp, err);
    +    if (!sysbus_realize(SYS_BUS_DEVICE(&s->intc), errp)) {
             return;
         }
         sysbusdev = SYS_BUS_DEVICE(&s->intc);

became

    diff --git a/hw/arm/allwinner-a10.c b/hw/arm/allwinner-a10.c
    index 52e0d83760..e1acffe5f6 100644
    --- a/hw/arm/allwinner-a10.c
    +++ b/hw/arm/allwinner-a10.c
    @@ -74,14 +74,12 @@ static void aw_a10_realize(DeviceState *dev, Error **errp)
         SysBusDevice *sysbusdev;
         Error *err = NULL;

    -    qdev_realize(DEVICE(&s->cpu), NULL, &err);
    -    if (err != NULL) {
    +    if (!qdev_realize(DEVICE(&s->cpu), NULL, &err)) {
             error_propagate(errp, err);
             return;
         }

    -    sysbus_realize(SYS_BUS_DEVICE(&s->intc), &err);
    -    if (err != NULL) {
    +    if (!sysbus_realize(SYS_BUS_DEVICE(&s->intc), &err)) {
             error_propagate(errp, err);
             return;
         }


in v2 and v3.  The two error_propagate() and the local variable now go
away only in PATCH v3 33.

Would you like me to record your R-by for the patch's current version?



  reply	other threads:[~2020-07-06 11:36 UTC|newest]

Thread overview: 65+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-06  8:09 [PATCH v3 00/44] Less clumsy error checking Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 01/44] error: Improve examples in error.h's big comment Markus Armbruster
2020-07-06 14:33   ` Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 02/44] error: Document Error API usage rules Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 03/44] qdev: Use returned bool to check for qdev_realize() etc. failure Markus Armbruster
2020-07-06 10:08   ` Greg Kurz
2020-07-06 11:35     ` Markus Armbruster [this message]
2020-07-06 14:43       ` Greg Kurz
2020-07-06  8:09 ` [PATCH v3 04/44] macio: Tidy up error handling in macio_newworld_realize() Markus Armbruster
2020-07-06 14:47   ` Greg Kurz
2020-07-06  8:09 ` [PATCH v3 05/44] virtio-crypto-pci: Tidy up virtio_crypto_pci_realize() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 06/44] qemu-option: Check return value instead of @err where convenient Markus Armbruster
2020-07-06 15:59   ` Greg Kurz
2020-07-06 20:01     ` Markus Armbruster
2020-07-07  8:25       ` Greg Kurz
2020-07-06  8:09 ` [PATCH v3 07/44] qemu-option: Make uses of find_desc_by_name() more similar Markus Armbruster
2020-07-07  8:26   ` Greg Kurz
2020-07-06  8:09 ` [PATCH v3 08/44] qemu-option: Factor out helper find_default_by_name() Markus Armbruster
2020-07-07  8:47   ` Greg Kurz
2020-07-06  8:09 ` [PATCH v3 09/44] qemu-option: Simplify around find_default_by_name() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 10/44] qemu-option: Factor out helper opt_create() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 11/44] qemu-option: Replace opt_set() by cleaner opt_validate() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 12/44] qemu-option: Make functions taking Error ** return bool, not void Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 13/44] qemu-option: Use returned bool to check for failure Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 14/44] block: Avoid error accumulation in bdrv_img_create() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 15/44] hmp: Eliminate a variable in hmp_migrate_set_parameter() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 16/44] qapi: Make visitor functions taking Error ** return bool, not void Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 17/44] qapi: Use returned bool to check for failure, Coccinelle part Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 18/44] qapi: Use returned bool to check for failure, manual part Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 19/44] s390x/pci: Fix harmless mistake in zpci's property fid's setter Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 20/44] qom: Use error_reportf_err() instead of g_printerr() in examples Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 21/44] qom: Rename qdev_get_type() to object_get_type() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 22/44] qom: Crash more nicely on object_property_get_link() failure Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 23/44] qom: Don't handle impossible " Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 24/44] qom: Use return values to check for error where that's simpler Markus Armbruster
2020-07-06 11:23   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 25/44] qom: Put name parameter before value / visitor parameter Markus Armbruster
2020-07-06 15:19   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 26/44] qom: Make functions taking Error ** return bool, not void Markus Armbruster
2020-07-06 15:44   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 27/44] qom: Use returned bool to check for failure, Coccinelle part Markus Armbruster
2020-07-06 16:08   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 28/44] qom: Use returned bool to check for failure, manual part Markus Armbruster
2020-07-06 16:39   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 29/44] qom: Make functions taking Error ** return bool, not 0/-1 Markus Armbruster
2020-07-06 16:52   ` Vladimir Sementsov-Ogievskiy
2020-07-06 20:07     ` Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 30/44] qdev: Make functions taking Error ** return bool, not void Markus Armbruster
2020-07-06 16:58   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 31/44] qdev: Use returned bool to check for failure, Coccinelle part Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 32/44] error: Avoid unnecessary error_propagate() after error_setg() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 33/44] error: Eliminate error_propagate() with Coccinelle, part 1 Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 34/44] error: Eliminate error_propagate() with Coccinelle, part 2 Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 35/44] error: Eliminate error_propagate() manually Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 36/44] error: Reduce unnecessary error propagation Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 37/44] block/parallels: Simplify parallels_open() after previous commit Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 38/44] qapi: Smooth another visitor error checking pattern Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 39/44] qapi: Smooth visitor error checking in generated code Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 40/44] qapi: Purge error_propagate() from QAPI core Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 41/44] error: Avoid error_propagate() after migrate_add_blocker() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 42/44] qemu-img: Ignore Error objects where the return value suffices Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 43/44] qdev: " Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 44/44] hmp: " Markus Armbruster
2020-07-06  8:12 ` [PATCH v3 00/44] Less clumsy error checking Markus Armbruster
2020-07-06 13:44   ` Eric Blake

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87k0zganbc.fsf@dusky.pond.sub.org \
    --to=armbru@redhat.com \
    --cc=berrange@redhat.com \
    --cc=ehabkost@redhat.com \
    --cc=groug@kaod.org \
    --cc=pbonzini@redhat.com \
    --cc=peter.maydell@linaro.org \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    --cc=vsementsov@virtuozzo.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.