All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jani Nikula <jani.nikula@linux.intel.com>
To: Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>,
	Lucas De Marchi <lucas.demarchi@intel.com>,
	intel-gfx@lists.freedesktop.org
Subject: Re: [Intel-gfx] [PATCH v2 08/12] drm/i915: finish removal of gen_mask
Date: Thu, 15 Apr 2021 13:22:58 +0300	[thread overview]
Message-ID: <87lf9jetj1.fsf@intel.com> (raw)
In-Reply-To: <319004ad-55cd-3058-3836-cc0bcb26e95c@linux.intel.com>

On Wed, 14 Apr 2021, Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com> wrote:
> On 14/04/2021 14:13, Jani Nikula wrote:
>> On Wed, 14 Apr 2021, Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com> wrote:
>>> On 13/04/2021 06:09, Lucas De Marchi wrote:
>>>> Now that it's not used anywhere, remove it from struct
>>>> intel_device_info. To allow a period in which code will be converted to
>>>> the new macro, keep IS_GEN_RANGE() around, just redefining it to use
>>>> the new fields. The size advantage from IS_GEN_RANGE() using a mask is
>>>> not that big as it has pretty limited use througout the driver:
>>>>
>>>>      text    data     bss     dec     hex filename
>>>> 2758497   95965    6496 2860958  2ba79e drivers/gpu/drm/i915/i915.ko.old
>>>> 2758586   95953    6496 2861035  2ba7eb drivers/gpu/drm/i915/i915.ko.new
>>>
>>> This delta refers to this patch - I mean this point in the series?
>>> Asking because it may not be 100% representative since some of the
>>> previous patches have already removed some gen mask usages.
>>>
>>> While I am here, I am a bit fond of the mask approach and wonder if
>>> using it for all (gt/media/whatelse) new fields would still make sense.
>>>
>>> Presence of the range check helpers suggests that it might, but I
>>> haven't looked at how prevalent their usage ends up after the series is
>>> done. So just in principle, I don't see why not still go with masks
>>> since that guarantees elegant check at each range check site. It would
>>> be all hidden in the macro implementation so easy.
>>>
>>> Also for historical reference, another reason why I went for masks
>>> everywhere approach is that at some point we had a feature request to
>>> allow compiling out platforms/gens. I *think* that was much easier to do
>>> with masking and in experiments back then I was able for instance to
>>> build just for Gen9+ and drop like 30% of the binary size.
>>>
>>> Oh I found the branch now.. The reason for IS_GEN(p, v) was also in that
>>> series. I don't know if I ever RFC-ed or trybotted it.. google suggests
>>> no and I neither can find it in my mailboxes. I could send out the old
>>> patches for reference? But to be honest I have no idea if this feature
>>> request (targeted driver builds) will ever resurface..
>> 
>> I completely agreed with the direction of using the masks way back when,
>> especially with the goal of the conditional/targeted compilation.
>> 
>> I think the question now is whether we want to keep maintaining them
>> just for the sake of the masks. Keeping them means having three masks
>> instead of one. And we wouldn't be using most of the benefits with them,
>> we'd mostly just get the downsides.
>> 
>> Having the masks per se is not such a big deal, but they're also not
>> such a big deal to add back later on if needed. It's the codebase all
>> over that's the hard part. And arguably it's not getting that much
>> different with the series at hand; the direct uses of INTEL_GEN() and
>> DISPLAY_VER() vastly outnumber IS_GEN(), IS_GEN_RANGE() and
>> IS_DISPLAY_RANGE() which could benefit from the mask.
>> 
>> We'd still be retaining the range macros as IS_GRAPHICS_VER(),
>> IS_MEDIA_VER() and IS_DISPLAY_VER(), although more for clarity than for
>> any other reason.
>
> Adding masks later would not a big deal, but another cycle of changing 
> "xxx_VER == n" to "IS_xxx_VER(n)" is a churn which could presumably be 
> avoided.

Direct xxx_VER <, >, <= and >= already exist all over the place, and
their numbers trump the == cases. Seems confusing to treat ==
differently.

> It is moot yes, but I don't see a clear case for doing the reversal as 
> part of this series. With a disclaimer that I only glanced over the 
> commit messages today for the first time.

So I wanted to keep using the range check macros for a couple of
reasons. Having (VER >= x && VER <= y) gets long, it needs braces, and
we use a bunch of negation !(VER >= x && VER <= y) vs. VER < x || VER >
y. !IS_GEN_RANGE() has more clarity.

Now, adding IS_GRAPHICS_VER_RANGE() gets long. Dropping the VER for
IS_GRAPHICS_RANGE() gets confusing ("what graphics range?"). Now, if we
use == for specific version check, we can repurpose IS_GRAPHICS_VER() to
do the ranges.

> So I think from me its neither ack or nack, at least since I don't 
> understand the attractiveness of using the "ver == n" and numerical 
> range check forms everywhere. As said, if we are churning I'd rather go 
> the other direction. But that's a soft objection only so feel free to 
> proceed.

Thanks, noted. However, unless stronger objections arise, I think we're
going to go with the patches at hand.


BR,
Jani.


-- 
Jani Nikula, Intel Open Source Graphics Center
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2021-04-15 10:23 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-04-13  5:09 [Intel-gfx] [PATCH v2 00/12] drm/i915: Extend GEN renames to the rest of the driver Lucas De Marchi
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 01/12] drm/i915/display: use DISPLAY_VER() on remaining users Lucas De Marchi
2021-04-13  9:24   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 02/12] drm/i915: rename display.version to display.ver Lucas De Marchi
2021-04-13  9:25   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 03/12] drm/i915/display: rename display version macros Lucas De Marchi
2021-04-13  9:35   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 04/12] drm/i915: add macros for graphics and media versions Lucas De Marchi
2021-04-13  9:33   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 05/12] drm/i915/gt: replace gen use in intel_engine_cs Lucas De Marchi
2021-04-13  9:36   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 06/12] drm/i915/selftests: replace unused mask with simple version Lucas De Marchi
2021-04-13  9:36   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 07/12] drm/i915/selftests: eliminate use of gen_mask Lucas De Marchi
2021-04-13  9:38   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 08/12] drm/i915: finish removal " Lucas De Marchi
2021-04-13  9:40   ` Jani Nikula
2021-04-14 11:38   ` Tvrtko Ursulin
2021-04-14 13:13     ` Jani Nikula
2021-04-14 13:46       ` Tvrtko Ursulin
2021-04-15 10:22         ` Jani Nikula [this message]
2021-04-14 17:41     ` Lucas De Marchi
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 09/12] drm/i915: eliminate remaining uses of intel_device_info->gen Lucas De Marchi
2021-04-13  9:43   ` Jani Nikula
2021-04-13  5:10 ` [Intel-gfx] [PATCH v2 10/12] drm/i915: finish removal of gen from intel_device_info Lucas De Marchi
2021-04-13  9:45   ` Jani Nikula
2021-04-13  5:10 ` [Intel-gfx] [PATCH v2 11/12] drm/i915: add media and display versions to device_info print Lucas De Marchi
2021-04-13  9:46   ` Jani Nikula
2021-04-13  5:10 ` [Intel-gfx] [PATCH v2 12/12] drm/i915: split dgfx features from gen 12 Lucas De Marchi
2021-04-13  9:47   ` Jani Nikula
2021-04-13  5:43 ` [Intel-gfx] ✗ Fi.CI.CHECKPATCH: warning for drm/i915: Extend GEN renames to the rest of the driver (rev3) Patchwork
2021-04-13  5:45 ` [Intel-gfx] ✗ Fi.CI.SPARSE: " Patchwork
2021-04-13  5:48 ` [Intel-gfx] ✗ Fi.CI.DOCS: " Patchwork
2021-04-13  6:10 ` [Intel-gfx] ✓ Fi.CI.BAT: success " Patchwork
2021-04-13  7:29 ` [Intel-gfx] ✓ Fi.CI.IGT: " Patchwork
2021-04-13 10:03 ` [Intel-gfx] [PATCH v2 00/12] drm/i915: Extend GEN renames to the rest of the driver Jani Nikula
2021-04-14  8:08   ` Jani Nikula
2021-04-14 10:06     ` Jani Nikula
2021-04-14 11:17       ` Joonas Lahtinen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87lf9jetj1.fsf@intel.com \
    --to=jani.nikula@linux.intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=lucas.demarchi@intel.com \
    --cc=tvrtko.ursulin@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.