From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-14.0 required=3.0 tests=BAYES_00,INCLUDES_CR_TRAILER, INCLUDES_PATCH,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 1543AC433FE for ; Mon, 20 Sep 2021 18:51:42 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id F287860EE4 for ; Mon, 20 Sep 2021 18:51:41 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1386019AbhITSxH (ORCPT ); Mon, 20 Sep 2021 14:53:07 -0400 Received: from mail.kernel.org ([198.145.29.99]:37308 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1385889AbhITSwh (ORCPT ); Mon, 20 Sep 2021 14:52:37 -0400 Received: from disco-boy.misterjones.org (disco-boy.misterjones.org [51.254.78.96]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPSA id B8E4F61159; Mon, 20 Sep 2021 18:01:52 +0000 (UTC) Received: from sofa.misterjones.org ([185.219.108.64] helo=why.misterjones.org) by disco-boy.misterjones.org with esmtpsa (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1mSNby-00BrY4-Oo; Mon, 20 Sep 2021 19:01:50 +0100 Date: Mon, 20 Sep 2021 19:01:50 +0100 Message-ID: <87mto7unw1.wl-maz@kernel.org> From: Marc Zyngier To: Kishon Vijay Abraham I Cc: Thomas Gleixner , Bjorn Helgaas , , , Lorenzo Pieralisi , Subject: Re: [PATCH 1/3] PCI: Add support in pci_walk_bus() to invoke callback matching RID In-Reply-To: <49b2ba0c-c69d-266c-5db6-549fab031ffd@ti.com> References: <20210920064133.14115-1-kishon@ti.com> <20210920064133.14115-2-kishon@ti.com> <8735pzwrq0.wl-maz@kernel.org> <49b2ba0c-c69d-266c-5db6-549fab031ffd@ti.com> User-Agent: Wanderlust/2.15.9 (Almost Unreal) SEMI-EPG/1.14.7 (Harue) FLIM-LB/1.14.9 (=?UTF-8?B?R29qxY0=?=) APEL-LB/10.8 EasyPG/1.0.0 Emacs/27.1 (x86_64-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO) MIME-Version: 1.0 (generated by SEMI-EPG 1.14.7 - "Harue") Content-Type: text/plain; charset=US-ASCII X-SA-Exim-Connect-IP: 185.219.108.64 X-SA-Exim-Rcpt-To: kishon@ti.com, tglx@linutronix.de, bhelgaas@google.com, linux-kernel@vger.kernel.org, linux-pci@vger.kernel.org, lorenzo.pieralisi@arm.com, lokeshvutla@ti.com X-SA-Exim-Mail-From: maz@kernel.org X-SA-Exim-Scanned: No (on disco-boy.misterjones.org); SAEximRunCond expanded to false Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, 20 Sep 2021 15:28:52 +0100, Kishon Vijay Abraham I wrote: > > Hi Marc, > > On 20/09/21 2:26 pm, Marc Zyngier wrote: > > On Mon, 20 Sep 2021 07:41:31 +0100, > > Kishon Vijay Abraham I wrote: > >> > >> Add two arguments to pci_walk_bus() [requestorID and mask], and add > >> support in pci_walk_bus() to invoke the *callback* only for devices > >> whose RequestorID after applying *mask* matches with *requestorID* > >> passed as argument. > >> > >> This is done in preparation for calculating the total number of > >> interrupt vectors that has to be supported by a specific GIC ITS device ID, > >> specifically when "msi-map-mask" is populated in device tree. > >> > >> Signed-off-by: Kishon Vijay Abraham I > >> --- > >> drivers/pci/bus.c | 13 +++++++++---- > >> include/linux/pci.h | 7 +++++-- > >> 2 files changed, 14 insertions(+), 6 deletions(-) > >> > >> diff --git a/drivers/pci/bus.c b/drivers/pci/bus.c > >> index 3cef835b375f..e381e639ceaa 100644 > >> --- a/drivers/pci/bus.c > >> +++ b/drivers/pci/bus.c > >> @@ -358,10 +358,12 @@ void pci_bus_add_devices(const struct pci_bus *bus) > >> } > >> EXPORT_SYMBOL(pci_bus_add_devices); > >> > >> -/** pci_walk_bus - walk devices on/under bus, calling callback. > >> +/** __pci_walk_bus - walk devices on/under bus matching requestor ID, calling callback. > >> * @top bus whose devices should be walked > >> * @cb callback to be called for each device found > >> * @userdata arbitrary pointer to be passed to callback. > >> + * @rid Requestor ID that has to be matched for the callback to be invoked > >> + * @mask Mask that has to be applied to pci_dev_id(), before compating it with @rid > >> * > >> * Walk the given bus, including any bridged devices > >> * on buses under this bus. Call the provided callback > >> @@ -371,8 +373,8 @@ EXPORT_SYMBOL(pci_bus_add_devices); > >> * other than 0, we break out. > >> * > >> */ > >> -void pci_walk_bus(struct pci_bus *top, int (*cb)(struct pci_dev *, void *), > >> - void *userdata) > >> +void __pci_walk_bus(struct pci_bus *top, int (*cb)(struct pci_dev *, void *), > >> + void *userdata, u32 rid, u32 mask) > >> { > >> struct pci_dev *dev; > >> struct pci_bus *bus; > >> @@ -399,13 +401,16 @@ void pci_walk_bus(struct pci_bus *top, int (*cb)(struct pci_dev *, void *), > >> } else > >> next = dev->bus_list.next; > >> > >> + if (mask != 0xffff && ((pci_dev_id(dev) & mask) != rid)) > > > > Why the check for the mask? I also wonder whether the mask should apply > > to the rid as well: > > If the mask is set for all 16bits, then there is not going to be two PCIe > devices which gets the same ITS device ID right? So no need for calculating > total number of vectors? Are we really arguing about the cost of a compare+branch vs some readability? Or is there an actual correctness issue here? > > > > if ((pci_dev_id(dev) & mask) != (rid & mask)) Because I think the above expression is a lot more readable (and likely more correct) than what you are suggesting. > > > >> + continue; > >> + > >> retval = cb(dev, userdata); > >> if (retval) > >> break; > >> } > >> up_read(&pci_bus_sem); > >> } > >> -EXPORT_SYMBOL_GPL(pci_walk_bus); > >> +EXPORT_SYMBOL_GPL(__pci_walk_bus); > >> > >> struct pci_bus *pci_bus_get(struct pci_bus *bus) > >> { > >> diff --git a/include/linux/pci.h b/include/linux/pci.h > >> index cd8aa6fce204..8500fec56e50 100644 > >> --- a/include/linux/pci.h > >> +++ b/include/linux/pci.h > >> @@ -1473,14 +1473,17 @@ const struct pci_device_id *pci_match_id(const struct pci_device_id *ids, > >> int pci_scan_bridge(struct pci_bus *bus, struct pci_dev *dev, int max, > >> int pass); > >> > >> -void pci_walk_bus(struct pci_bus *top, int (*cb)(struct pci_dev *, void *), > >> - void *userdata); > >> +void __pci_walk_bus(struct pci_bus *top, int (*cb)(struct pci_dev *, void *), > >> + void *userdata, u32 rid, u32 mask); > >> int pci_cfg_space_size(struct pci_dev *dev); > >> unsigned char pci_bus_max_busnr(struct pci_bus *bus); > >> void pci_setup_bridge(struct pci_bus *bus); > >> resource_size_t pcibios_window_alignment(struct pci_bus *bus, > >> unsigned long type); > >> > >> +#define pci_walk_bus(top, cb, userdata) \ > >> + __pci_walk_bus((top), (cb), (userdata), 0x0, 0xffff) > > > > Please keep this close to the helper it replaces. I also really > > dislike the use of this raw 0xffff. Don't we already have a named > > constant that represents the mask for a RID? > > I didn't find one on quick look but let me check. Worse case, you could create your own. Thanks, M. -- Without deviation from the norm, progress is not possible.