All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: Alistair Francis <alistair.francis@xilinx.com>
Cc: qemu-devel@nongnu.org, alistair23@gmail.com, philippe@mathieu-daude.net
Subject: Re: [Qemu-devel] [RFC v3 2/3] qemu-error: Implement a more generic error reporting
Date: Thu, 06 Jul 2017 08:15:54 +0200	[thread overview]
Message-ID: <87r2xuay5h.fsf@dusky.pond.sub.org> (raw)
In-Reply-To: <2c9645b5dce991f7a324dc2b61e2553e08230a9f.1499276048.git.alistair.francis@xilinx.com> (Alistair Francis's message of "Wed, 5 Jul 2017 10:36:28 -0700")

Alistair Francis <alistair.francis@xilinx.com> writes:

> This patch converts the existing error_vreport() function into a generic
> qmesg_vreport() function that takes an enum describing the
> information to be reported.
>
> As part of this change a new qmesg_report() function is added as well with the
> same capability.
>
> To maintain full compatibility the original error_report() function is
> maintained and no changes to the way errors are printed have been made.
> To improve access to the new informaiton and warning options wrapper functions
> similar to error_report() have been added for warnings and information
> printing.
>
> Signed-off-by: Alistair Francis <alistair.francis@xilinx.com>

In addition to the typos Thomas pointed out, please wrap your lines at
column 70 or so.

> ---
> RFC V3:
>  - Change the function and enum names to be more descriptive
>  - Add wrapper functions for *_report() and *_vreport()
>
>  include/qemu/error-report.h | 16 +++++++++
>  scripts/checkpatch.pl       |  8 ++++-
>  util/qemu-error.c           | 80 +++++++++++++++++++++++++++++++++++++++++++--
>  3 files changed, 100 insertions(+), 4 deletions(-)
>
> diff --git a/include/qemu/error-report.h b/include/qemu/error-report.h
> index 3001865896..62fc167ace 100644
> --- a/include/qemu/error-report.h
> +++ b/include/qemu/error-report.h
> @@ -21,6 +21,12 @@ typedef struct Location {
>      struct Location *prev;
>  } Location;
>  
> +typedef enum {
> +    REPORT_TYPE_ERROR,
> +    REPORT_TYPE_WARNING,
> +    REPORT_TYPE_INFO,
> +} report_type;
> +
>  Location *loc_push_restore(Location *loc);
>  Location *loc_push_none(Location *loc);
>  Location *loc_pop(Location *loc);
> @@ -30,13 +36,23 @@ void loc_set_none(void);
>  void loc_set_cmdline(char **argv, int idx, int cnt);
>  void loc_set_file(const char *fname, int lno);
>  
> +void qmsg_vreport(report_type type, const char *fmt, va_list ap) GCC_FMT_ATTR(2, 0);
> +void qmsg_report(report_type type, const char *fmt, ...)  GCC_FMT_ATTR(2, 3);
> +

Let's keep these hidden in qemu-error.c until we have users outside of
qemu-error.c.  @report_type, too.  No need for qmsg_report() then.  Not
sure we need the qmsg_ prefix; I find it ugly.  I'd prefer vreport(),
msg_vreport() or maybe do_vreport().

Suggest to update the commit message to put less emphasis on the
(static) generic functions, and more on the functions we're actually
going to use, starting with your PATCH 3, perhaps like this:

    error: Functions to report warnings and informational messages

    Add warn_report(), warn_vreport() for reporting warnings, and
    info_report(), info_vreport() for informational messages.

    Implement them with a helper function factored out of
    error_vreport(), suitably generalized.  Take care not to change the
    way error messages are printed.


>  void error_vprintf(const char *fmt, va_list ap) GCC_FMT_ATTR(1, 0);
>  void error_printf(const char *fmt, ...) GCC_FMT_ATTR(1, 2);
>  void error_vprintf_unless_qmp(const char *fmt, va_list ap) GCC_FMT_ATTR(1, 0);
>  void error_printf_unless_qmp(const char *fmt, ...) GCC_FMT_ATTR(1, 2);
>  void error_set_progname(const char *argv0);
> +
>  void error_vreport(const char *fmt, va_list ap) GCC_FMT_ATTR(1, 0);
> +void warn_vreport(const char *fmt, va_list ap) GCC_FMT_ATTR(1, 0);
> +void info_vreport(const char *fmt, va_list ap) GCC_FMT_ATTR(1, 0);
> +
>  void error_report(const char *fmt, ...) GCC_FMT_ATTR(1, 2);
> +void warn_report(const char *fmt, ...) GCC_FMT_ATTR(1, 2);
> +void info_report(const char *fmt, ...) GCC_FMT_ATTR(1, 2);
> +
>  const char *error_get_progname(void);
>  extern bool enable_timestamp_msg;
>  
> diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
> index 45027b9281..8b02621739 100755
> --- a/scripts/checkpatch.pl
> +++ b/scripts/checkpatch.pl
> @@ -2530,8 +2530,14 @@ sub process {
>  				error_set|
>  				error_prepend|
>  				error_reportf_err|
> +				qmsg_vreport|
>  				error_vreport|
> -				error_report}x;
> +				warn_vreport|
> +				info_vreport|
> +				qmsg_report|
> +				error_report|
> +				warn_report|
> +				info_report}x;
>  
>  	if ($rawline =~ /\b(?:$qemu_error_funcs)\s*\(.*\".*\\n/) {
>  		ERROR("Error messages should not contain newlines\n" . $herecurr);

Extra points for updating checkpatch.pl :)

> diff --git a/util/qemu-error.c b/util/qemu-error.c
> index 1c5e35ecdb..63fdc0e174 100644
> --- a/util/qemu-error.c
> +++ b/util/qemu-error.c
> @@ -179,17 +179,29 @@ static void print_loc(void)
>  
>  bool enable_timestamp_msg;
>  /*
> - * Print an error message to current monitor if we have one, else to stderr.
> + * Print a message to current monitor if we have one, else to stderr.
>   * Format arguments like vsprintf().  The resulting message should be
>   * a single phrase, with no newline or trailing punctuation.
>   * Prepend the current location and append a newline.
>   * It's wrong to call this in a QMP monitor.  Use error_setg() there.
>   */
> -void error_vreport(const char *fmt, va_list ap)
> +void qmsg_vreport(report_type type, const char *fmt, va_list ap)
>  {
>      GTimeVal tv;
>      gchar *timestr;
>  
> +    switch (type) {
> +    case REPORT_TYPE_ERROR:
> +        /* To maintain compatibility we don't add anything here */

I feel the comment isn't going to be useful in the future.  Let's drop
it.

> +        break;
> +    case REPORT_TYPE_WARNING:
> +        error_printf("warning: ");
> +        break;
> +    case REPORT_TYPE_INFO:
> +        error_printf("info: ");
> +        break;

       default:
           assert(0);

> +    }
> +
>      if (enable_timestamp_msg && !cur_mon) {
>          g_get_current_time(&tv);
>          timestr = g_time_val_to_iso8601(&tv);
> @@ -204,16 +216,78 @@ void error_vreport(const char *fmt, va_list ap)
>  
>  /*
>   * Print an error message to current monitor if we have one, else to stderr.
> + */
> +void error_vreport(const char *fmt, va_list ap)
> +{
> +    qmsg_vreport(REPORT_TYPE_ERROR, fmt, ap);
> +}
> +
> +/*
> + * Print a warning message to current monitor if we have one, else to stderr.
> + */
> +void warn_vreport(const char *fmt, va_list ap)
> +{
> +    qmsg_vreport(REPORT_TYPE_WARNING, fmt, ap);
> +}
> +
> +/*
> + * Print an information message to current monitor if we have one, else to
> + * stderr.
> + */
> +void info_vreport(const char *fmt, va_list ap)
> +{
> +    qmsg_vreport(REPORT_TYPE_INFO, fmt, ap);
> +}
> +
> +/*
> + * Print a message to current monitor if we have one, else to stderr.
>   * Format arguments like sprintf().  The resulting message should be a
>   * single phrase, with no newline or trailing punctuation.
>   * Prepend the current location and append a newline.
>   * It's wrong to call this in a QMP monitor.  Use error_setg() there.
>   */
> +void qmsg_report(report_type type, const char *fmt, ...)
> +{
> +    va_list ap;
> +
> +    va_start(ap, fmt);
> +    qmsg_vreport(type, fmt, ap);
> +    va_end(ap);
> +}
> +
> +/*
> + * Print an error message to current monitor if we have one, else to stderr.
> + */
>  void error_report(const char *fmt, ...)
>  {
>      va_list ap;
>  
>      va_start(ap, fmt);
> -    error_vreport(fmt, ap);
> +    qmsg_vreport(REPORT_TYPE_ERROR, fmt, ap);
> +    va_end(ap);
> +}
> +
> +/*
> + * Print a warning message to current monitor if we have one, else to stderr.
> + */
> +void warn_report(const char *fmt, ...)
> +{
> +    va_list ap;
> +
> +    va_start(ap, fmt);
> +    qmsg_vreport(REPORT_TYPE_WARNING, fmt, ap);
> +    va_end(ap);
> +}
> +
> +/*
> + * Print an information message to current monitor if we have one, else to
> + * stderr.
> + */
> +void info_report(const char *fmt, ...)
> +{
> +    va_list ap;
> +
> +    va_start(ap, fmt);
> +    qmsg_vreport(REPORT_TYPE_INFO, fmt, ap);
>      va_end(ap);
>  }

  parent reply	other threads:[~2017-07-06  6:16 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-07-05 17:36 [Qemu-devel] [RFC v3 0/3] Implement a warning_report function Alistair Francis
2017-07-05 17:36 ` [Qemu-devel] [RFC v3 1/3] util/qemu-error: Rename error_print_loc() to be more generic Alistair Francis
2017-07-06  2:36   ` Thomas Huth
2017-07-05 17:36 ` [Qemu-devel] [RFC v3 2/3] qemu-error: Implement a more generic error reporting Alistair Francis
2017-07-06  2:42   ` Thomas Huth
2017-07-06  6:15   ` Markus Armbruster [this message]
2017-07-06  8:07     ` Daniel P. Berrange
2017-07-06 11:27       ` Markus Armbruster
2017-07-06 11:45         ` Daniel P. Berrange
2017-07-06 12:20           ` Markus Armbruster
2017-07-06 13:10             ` Daniel P. Berrange
2017-07-06 14:44               ` Markus Armbruster
2017-07-06 18:45                 ` Alistair Francis
2017-07-05 17:36 ` [Qemu-devel] [RFC v3 3/3] char-socket: Report TCP socket waiting as information Alistair Francis
2017-07-06  2:46   ` Thomas Huth
2017-07-06  6:18     ` Markus Armbruster

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87r2xuay5h.fsf@dusky.pond.sub.org \
    --to=armbru@redhat.com \
    --cc=alistair.francis@xilinx.com \
    --cc=alistair23@gmail.com \
    --cc=philippe@mathieu-daude.net \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.