All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: Eric Blake <eblake@redhat.com>
Cc: qemu-devel@nongnu.org, Luiz Capitulino <lcapitulino@redhat.com>
Subject: Re: [Qemu-devel] [PATCH v12 28/36] qapi: Simplify QObject
Date: Wed, 18 Nov 2015 19:23:29 +0100	[thread overview]
Message-ID: <87r3jnjhem.fsf@blackfin.pond.sub.org> (raw)
In-Reply-To: <1447836791-369-29-git-send-email-eblake@redhat.com> (Eric Blake's message of "Wed, 18 Nov 2015 01:53:03 -0700")

Eric Blake <eblake@redhat.com> writes:

> The QObject hierarchy is small enough, and unlikely to grow further
> (since we only use it to map to JSON and already cover all JSON
> types), that we can simplify things by not tracking a separate
> vtable, but just inline all two elements of the vtable QType
> directly into QObject.  We can drop qnull_destroy_obj() in the
> process.
>
> This also has the nice benefit of moving the typename 'QType'
> out of the way, so that the next patch can repurpose it for a
> nicer name for 'qtype_code'.
>
> The various objects are now 8 bytes larger on 64-bit platforms, but
> hopefully this is in the noise.  If size is absolutely critical due
> to cache line speed effects, we could do some bit packing to
> restore the previous size (qtype_code currently only requires three
> distinct bits, so we could assert an assumption that architecture
> ABIs will give function pointers at least an 8-byte alignment, and
> that the three low-order bits of destroy are always zero; or we
> could use a bitfield for refcnt, with a maximum of SIZE_MAX/8, and
> given that a QObject already occupies at least 8 bytes, that won't
> artificially limit us). Or we could expose the currently static
> destroy methods and instead create a table in qobject.h that maps
> QType to destructor.

That's what I'd do.

A type registration function would keep the destructors static.  But why
bother.

>                       But let's save any size compression for a
> followup patch, if at all.

Okay.

> On the other hand, by avoiding a separate vtable, there is less
> indirection, so use of QObjects may be slightly more efficient.
>
> However, as we don't have evidence pointing at either QObject size
> or access speed as being a hot spot, I didn't think it was worth
> benchmarking.
>
> Suggested-by: Markus Armbruster <armbru@redhat.com>
> Signed-off-by: Eric Blake <eblake@redhat.com>

Works for me.

  reply	other threads:[~2015-11-18 18:23 UTC|newest]

Thread overview: 102+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-11-18  8:52 [Qemu-devel] [PATCH v12 00/36] qapi member collision, alternate layout (post-introspection cleanups, subset D) Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 01/36] qapi: Track simple union tag in object.local_members Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 02/36] qapi-types: Consolidate gen_struct() and gen_union() Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 03/36] qapi-types: Simplify gen_struct_field[s] Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 04/36] qapi: Drop obsolete tag value collision assertions Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 05/36] qapi: Simplify QAPISchemaObjectTypeMember.check() Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 06/36] qapi: Clean up after previous commit Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 07/36] qapi: Fix up commit 7618b91's clash sanity checking change Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 08/36] qapi: Eliminate QAPISchemaObjectType.check() variable members Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 09/36] qapi: Factor out QAPISchemaObjectTypeMember.check_clash() Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 10/36] qapi: Simplify QAPISchemaObjectTypeVariants.check() Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 11/36] qapi: Check for qapi collisions involving variant members Eric Blake
2015-11-18 10:01   ` Markus Armbruster
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 12/36] qapi: Factor out QAPISchemaObjectType.check_clash() Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 13/36] qapi: Hoist tag collision check to Variants.check() Eric Blake
2015-11-18 10:08   ` Markus Armbruster
2015-11-18 10:24     ` Daniel P. Berrange
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 14/36] qapi: Remove outdated tests related to QMP/branch collisions Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 15/36] qapi: Track owner of each object member Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 16/36] qapi: Detect collisions in C member names Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 17/36] qapi: Fix c_name() munging Eric Blake
2015-11-18 10:18   ` Markus Armbruster
2015-11-18 16:20     ` Eric Blake
2015-11-18 17:59       ` Markus Armbruster
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 18/36] qapi: Remove dead visitor code Eric Blake
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 19/36] blkdebug: Merge hand-rolled and qapi BlkdebugEvent enum Eric Blake
2015-11-18 10:30   ` Markus Armbruster
2015-11-18 12:08     ` Kevin Wolf
2015-11-18 16:26       ` Eric Blake
2015-11-18 16:34         ` Kevin Wolf
2015-11-18 18:04           ` Markus Armbruster
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 20/36] blkdebug: Avoid '.' in enum values Eric Blake
2015-11-19  7:32   ` Markus Armbruster
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 21/36] qapi: Tighten the regex on valid names Eric Blake
2015-11-18 11:51   ` Markus Armbruster
2015-11-18 16:57     ` Eric Blake
2015-11-18 18:08       ` Markus Armbruster
2015-11-18 21:45   ` [Qemu-devel] [PATCH] fixup! " Eric Blake
2015-11-19  8:10     ` Markus Armbruster
2015-11-19 23:25       ` Eric Blake
2015-11-20  6:16         ` Markus Armbruster
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 22/36] qapi: Don't let implicit enum MAX member collide Eric Blake
2015-11-18 10:54   ` Juan Quintela
2015-11-18 13:12   ` Markus Armbruster
2015-11-18 17:00     ` Eric Blake
2015-11-18 18:09       ` Markus Armbruster
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 23/36] qapi: Remove dead tests for max collision Eric Blake
2015-11-19  7:42   ` Markus Armbruster
2015-11-18  8:52 ` [Qemu-devel] [PATCH v12 24/36] cpu: Convert CpuInfo into flat union Eric Blake
2015-11-19 16:12   ` Markus Armbruster
2015-11-19 16:46     ` Eric Blake
2015-11-19 17:03       ` Markus Armbruster
2016-02-02 12:25   ` James Hogan
2016-02-02 13:49     ` Markus Armbruster
2016-02-02 14:49     ` Eric Blake
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 25/36] qapi: Add alias for ErrorClass Eric Blake
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 26/36] qapi: Change munging of CamelCase enum values Eric Blake
2015-11-18 13:46   ` Markus Armbruster
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 27/36] qapi: Forbid case-insensitive clashes Eric Blake
2015-11-18 17:08   ` Markus Armbruster
2015-11-18 22:09     ` Eric Blake
2015-11-18 22:22       ` Eric Blake
2015-11-18 22:52   ` Eric Blake
2015-11-18 22:55   ` [Qemu-devel] [PATCH] fixup! " Eric Blake
2015-11-19 13:32     ` Markus Armbruster
2015-11-19 15:20       ` Eric Blake
2015-11-19 16:50   ` [Qemu-devel] [PATCH v12 27/36] " Markus Armbruster
2015-11-19 17:16     ` Eric Blake
2015-11-19 18:25       ` Markus Armbruster
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 28/36] qapi: Simplify QObject Eric Blake
2015-11-18 18:23   ` Markus Armbruster [this message]
2015-11-18 23:47   ` [Qemu-devel] [PATCH] fixup? " Eric Blake
2015-11-19  8:58     ` Markus Armbruster
2015-11-19  9:12       ` Markus Armbruster
2015-11-19 14:19       ` Eric Blake
2015-11-19 14:43         ` Markus Armbruster
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 29/36] qobject: Rename qtype_code to QType Eric Blake
2015-11-18 18:25   ` Markus Armbruster
2015-11-18 23:27     ` Eric Blake
2015-11-19  7:44       ` Markus Armbruster
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 30/36] qapi: Convert QType into qapi builtin enum type Eric Blake
2015-11-18 18:40   ` Markus Armbruster
2015-11-18 19:14   ` Markus Armbruster
2015-11-19  0:19   ` [Qemu-devel] [PATCH] fixup! " Eric Blake
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 31/36] qapi: Simplify visiting of alternate types Eric Blake
2015-11-18 18:46   ` Markus Armbruster
2015-11-18 20:08     ` Eric Blake
2015-11-19  8:01       ` Markus Armbruster
2015-11-19 14:08         ` Eric Blake
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 32/36] qapi: Inline _make_implicit_tag() Eric Blake
2015-11-18 18:48   ` Markus Armbruster
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 33/36] qapi: Fix alternates that accept 'number' but not 'int' Eric Blake
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 34/36] qapi: Add positive tests to qapi-schema-test Eric Blake
2015-11-20 22:49   ` Eric Blake
2015-11-23  7:34     ` Markus Armbruster
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 35/36] qapi: Simplify visits of optional fields Eric Blake
2015-11-18 18:54   ` Markus Armbruster
2015-11-18 20:10     ` Eric Blake
2015-11-18  8:53 ` [Qemu-devel] [PATCH v12 36/36] qapi: Shorter " Eric Blake
2015-11-18 19:04   ` Markus Armbruster
2015-11-18 19:19 ` [Qemu-devel] [PATCH v12 00/36] qapi member collision, alternate layout (post-introspection cleanups, subset D) Markus Armbruster
2015-11-19  0:25   ` Eric Blake

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87r3jnjhem.fsf@blackfin.pond.sub.org \
    --to=armbru@redhat.com \
    --cc=eblake@redhat.com \
    --cc=lcapitulino@redhat.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.