All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Ævar Arnfjörð Bjarmason" <avarab@gmail.com>
To: Jeff King <peff@peff.net>
Cc: Junio C Hamano <gitster@pobox.com>,
	git@vger.kernel.org, Emily Shaffer <emilyshaffer@google.com>,
	Derrick Stolee <stolee@gmail.com>
Subject: Re: [PATCH v3 2/5] strvec: add a strvec_pushvec()
Date: Fri, 03 Sep 2021 01:19:33 +0200	[thread overview]
Message-ID: <87v93i8svd.fsf@evledraar.gmail.com> (raw)
In-Reply-To: <YSm3ofxlRB1ViBf5@coredump.intra.peff.net>


On Sat, Aug 28 2021, Jeff King wrote:

> On Fri, Aug 27, 2021 at 06:29:30PM -0700, Junio C Hamano wrote:
>
>> Junio C Hamano <gitster@pobox.com> writes:
>> 
>> >> +void strvec_pushvec(struct strvec *array, const struct strvec *items)
>> >> +{
>> >> +	int i;
>> >> +
>> >> +	for (i = 0; i < items->nr; i++)
>> >> +		strvec_push(array, items->v[i]);
>> >> +}
>> >
>> > This implementation is not wrong per-se, but is somewhat
>> > disappointing.  When items->nr is large, especially relative to the
>> > original array->alloc, it would incur unnecessary reallocations that
>> > we can easily avoid by pre-sizing the array before pushing the
>> > elements of items from it.
>> >
>> > In the original code that became the first user of this helper, it
>> > may not have made much difference, but now it is becoming a more
>> > generally reusable API function, we should care.
>> 
>> And if we do not care, you can rewrite the code that became the
>> first user of this helper to instead call strvec_pushv() on the
>> items->v array that is guaranteed to be NULL terminated, without
>> inventing this new helper.
>
> I came here to say that. ;)
>
> I do not mind using pushv() directly, or a pushvec() that is a
> convenience wrapper for pushv(). Even better if that wrapper is smart
> enough to pre-allocate based on items->nr, as you mentioned, but that
> can also come later.
>
> One thing that did surprise me: the use of "int" here for iterating,
> rather than size_t. But it seems that strvec is already storing ints,
> which is an accident!

Is it really? If you temporarily try to say convert that to "size_t *nr"
to have the compiler catch all the cases where we use "nr", and then
s/size_t/int/g those all, you'll find that e.g. setup_revisions() and
the like expect to take either "int argc" or the strvec equivalent.

We can sensibly convert some of those to size_t, but not all, and the
int v.s. size_t inconsistency as a result feels weird.

Since the main point of this API is to be a wrapper for what a C main()
would take, shouldn't its prototype mirror its prototype? I.e. we should
stick to "int" here?

> I think we'd want the patch below. It can be applied independently
> (though if we do take the index-iterating version of Ævar's patch, I
> think it should switch to size_t).
>
> -- >8 --
> Subject: [PATCH] strvec: use size_t to store nr and alloc
>
> We converted argv_array (which later became strvec) to use size_t in
> 819f0e76b1 (argv-array: use size_t for count and alloc, 2020-07-28) in
> order to avoid the possibility of integer overflow. But later, commit
> d70a9eb611 (strvec: rename struct fields, 2020-07-28) accidentally
> converted these back to ints!
>
> Those two commits were part of the same patch series. I'm pretty sure
> what happened is that they were originally written in the opposite order
> and then cleaned up and re-ordered during an interactive rebase. And
> when resolving the inevitable conflict, I mistakenly took the "rename"
> patch completely, accidentally dropping the type change.
>
> We can correct it now; better late than never.
>
> Signed-off-by: Jeff King <peff@peff.net>
> ---
>  strvec.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/strvec.h b/strvec.h
> index fdcad75b45..6b3cbd6758 100644
> --- a/strvec.h
> +++ b/strvec.h
> @@ -29,8 +29,8 @@ extern const char *empty_strvec[];
>   */
>  struct strvec {
>  	const char **v;
> -	int nr;
> -	int alloc;
> +	size_t nr;
> +	size_t alloc;
>  };
>  
>  #define STRVEC_INIT { empty_strvec, 0, 0 }


  parent reply	other threads:[~2021-09-02 23:23 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-27  0:41 [PATCH 0/4] bundle: show progress on "unbundle" Ævar Arnfjörð Bjarmason
2021-07-27  0:41 ` [PATCH 1/4] bundle API: start writing API documentation Ævar Arnfjörð Bjarmason
2021-07-27  0:41 ` [PATCH 2/4] bundle API: change "flags" to be "extra_index_pack_args" Ævar Arnfjörð Bjarmason
2021-07-27  0:41 ` [PATCH 3/4] index-pack: add --progress-title option Ævar Arnfjörð Bjarmason
2021-07-27  0:41 ` [PATCH 4/4] bundle: show progress on "unbundle" Ævar Arnfjörð Bjarmason
2021-08-23 11:02 ` [PATCH v2 0/4] " Ævar Arnfjörð Bjarmason
2021-08-23 11:02   ` [PATCH v2 1/4] bundle API: start writing API documentation Ævar Arnfjörð Bjarmason
2021-08-24 17:01     ` Derrick Stolee
2021-08-24 21:48       ` Ævar Arnfjörð Bjarmason
2021-08-23 11:02   ` [PATCH v2 2/4] bundle API: change "flags" to be "extra_index_pack_args" Ævar Arnfjörð Bjarmason
2021-08-24 17:09     ` Derrick Stolee
2021-08-24 21:41       ` Ævar Arnfjörð Bjarmason
2021-08-24 21:48         ` Derrick Stolee
2021-08-23 11:02   ` [PATCH v2 3/4] index-pack: add --progress-title option Ævar Arnfjörð Bjarmason
2021-08-24 17:18     ` Derrick Stolee
2021-08-24 21:40       ` Ævar Arnfjörð Bjarmason
2021-08-23 11:02   ` [PATCH v2 4/4] bundle: show progress on "unbundle" Ævar Arnfjörð Bjarmason
2021-08-24 17:23     ` Derrick Stolee
2021-08-24 21:39       ` Ævar Arnfjörð Bjarmason
2021-08-26 14:05 ` [PATCH v3 0/5] " Ævar Arnfjörð Bjarmason
2021-08-26 14:05   ` [PATCH v3 1/5] bundle API: start writing API documentation Ævar Arnfjörð Bjarmason
2021-08-26 14:05   ` [PATCH v3 2/5] strvec: add a strvec_pushvec() Ævar Arnfjörð Bjarmason
2021-08-28  1:23     ` Junio C Hamano
2021-08-28  1:29       ` Junio C Hamano
2021-08-28  4:12         ` Jeff King
2021-08-29 23:54           ` Junio C Hamano
2021-08-30 17:30             ` Derrick Stolee
2021-09-02 23:19           ` Ævar Arnfjörð Bjarmason [this message]
2021-09-03  5:05             ` Junio C Hamano
2021-09-03 11:06             ` Jeff King
2021-08-26 14:05   ` [PATCH v3 3/5] bundle API: change "flags" to be "extra_index_pack_args" Ævar Arnfjörð Bjarmason
2021-08-28  1:44     ` Junio C Hamano
2021-08-26 14:05   ` [PATCH v3 4/5] index-pack: add --progress-title option Ævar Arnfjörð Bjarmason
2021-08-28  1:50     ` Junio C Hamano
2021-08-26 14:05   ` [PATCH v3 5/5] bundle: show progress on "unbundle" Ævar Arnfjörð Bjarmason
2021-08-28  1:54     ` Junio C Hamano
2021-09-02 22:47       ` Ævar Arnfjörð Bjarmason
2021-09-05  7:34   ` [PATCH v4 0/4] " Ævar Arnfjörð Bjarmason
2021-09-05  7:34     ` [PATCH v4 1/4] bundle API: start writing API documentation Ævar Arnfjörð Bjarmason
2021-09-05  7:34     ` [PATCH v4 2/4] bundle API: change "flags" to be "extra_index_pack_args" Ævar Arnfjörð Bjarmason
2021-09-05  7:34     ` [PATCH v4 3/4] index-pack: add --progress-title option Ævar Arnfjörð Bjarmason
2021-09-05  7:34     ` [PATCH v4 4/4] bundle: show progress on "unbundle" Ævar Arnfjörð Bjarmason

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87v93i8svd.fsf@evledraar.gmail.com \
    --to=avarab@gmail.com \
    --cc=emilyshaffer@google.com \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    --cc=peff@peff.net \
    --cc=stolee@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.