From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-13.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_CR_TRAILER,INCLUDES_PATCH, MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 2DEB0C433B4 for ; Mon, 12 Apr 2021 07:24:57 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 048CC6120B for ; Mon, 12 Apr 2021 07:24:56 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S236799AbhDLHZN (ORCPT ); Mon, 12 Apr 2021 03:25:13 -0400 Received: from mga01.intel.com ([192.55.52.88]:13015 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S230510AbhDLHZL (ORCPT ); Mon, 12 Apr 2021 03:25:11 -0400 IronPort-SDR: U9ZatO4MvkqWlifDt9H94SBGcTu7lt2Zo2ZyOpWjR9mqDaO47nZqf18mCUO9s2V15MR7xPUMBF d3epiS2MKTfQ== X-IronPort-AV: E=McAfee;i="6000,8403,9951"; a="214592458" X-IronPort-AV: E=Sophos;i="5.82,214,1613462400"; d="scan'208";a="214592458" Received: from fmsmga008.fm.intel.com ([10.253.24.58]) by fmsmga101.fm.intel.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 12 Apr 2021 00:24:54 -0700 IronPort-SDR: B9SU3wecjSe4accQUXOvGF+Iorh6vcLJJBTEy3kxZJASuwb0+V61dr3jxnQ6wrQkEILhccp2TO X/IJmGgNVlAg== X-IronPort-AV: E=Sophos;i="5.82,214,1613462400"; d="scan'208";a="417264247" Received: from yhuang6-desk1.sh.intel.com (HELO yhuang6-desk1.ccr.corp.intel.com) ([10.239.13.1]) by fmsmga008-auth.fm.intel.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 12 Apr 2021 00:24:50 -0700 From: "Huang, Ying" To: Miaohe Lin Cc: , , , , , , , , , , , , Subject: Re: [PATCH 1/5] mm/swapfile: add percpu_ref support for swap References: <20210408130820.48233-1-linmiaohe@huawei.com> <20210408130820.48233-2-linmiaohe@huawei.com> <87fszww55d.fsf@yhuang6-desk1.ccr.corp.intel.com> Date: Mon, 12 Apr 2021 15:24:48 +0800 In-Reply-To: <87fszww55d.fsf@yhuang6-desk1.ccr.corp.intel.com> (Ying Huang's message of "Mon, 12 Apr 2021 11:30:54 +0800") Message-ID: <87zgy4ufr3.fsf@yhuang6-desk1.ccr.corp.intel.com> User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/27.1 (gnu/linux) MIME-Version: 1.0 Content-Type: text/plain; charset=ascii Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org "Huang, Ying" writes: > Miaohe Lin writes: > >> We will use percpu-refcount to serialize against concurrent swapoff. This >> patch adds the percpu_ref support for later fixup. >> >> Signed-off-by: Miaohe Lin >> --- >> include/linux/swap.h | 2 ++ >> mm/swapfile.c | 25 ++++++++++++++++++++++--- >> 2 files changed, 24 insertions(+), 3 deletions(-) >> >> diff --git a/include/linux/swap.h b/include/linux/swap.h >> index 144727041e78..849ba5265c11 100644 >> --- a/include/linux/swap.h >> +++ b/include/linux/swap.h >> @@ -240,6 +240,7 @@ struct swap_cluster_list { >> * The in-memory structure used to track swap areas. >> */ >> struct swap_info_struct { >> + struct percpu_ref users; /* serialization against concurrent swapoff */ >> unsigned long flags; /* SWP_USED etc: see above */ >> signed short prio; /* swap priority of this type */ >> struct plist_node list; /* entry in swap_active_head */ >> @@ -260,6 +261,7 @@ struct swap_info_struct { >> struct block_device *bdev; /* swap device or bdev of swap file */ >> struct file *swap_file; /* seldom referenced */ >> unsigned int old_block_size; /* seldom referenced */ >> + struct completion comp; /* seldom referenced */ >> #ifdef CONFIG_FRONTSWAP >> unsigned long *frontswap_map; /* frontswap in-use, one bit per page */ >> atomic_t frontswap_pages; /* frontswap pages in-use counter */ >> diff --git a/mm/swapfile.c b/mm/swapfile.c >> index 149e77454e3c..724173cd7d0c 100644 >> --- a/mm/swapfile.c >> +++ b/mm/swapfile.c >> @@ -39,6 +39,7 @@ >> #include >> #include >> #include >> +#include >> >> #include >> #include >> @@ -511,6 +512,15 @@ static void swap_discard_work(struct work_struct *work) >> spin_unlock(&si->lock); >> } >> >> +static void swap_users_ref_free(struct percpu_ref *ref) >> +{ >> + struct swap_info_struct *si; >> + >> + si = container_of(ref, struct swap_info_struct, users); >> + complete(&si->comp); >> + percpu_ref_exit(&si->users); > > Because percpu_ref_exit() is used, we cannot use percpu_ref_tryget() in > get_swap_device(), better to add comments there. I just noticed that the comments of percpu_ref_tryget_live() says, * This function is safe to call as long as @ref is between init and exit. While we need to call get_swap_device() almost at any time, so it's better to avoid to call percpu_ref_exit() at all. This will waste some memory, but we need to follow the API definition to avoid potential issues in the long term. And we need to call percpu_ref_init() before insert the swap_info_struct into the swap_info[]. >> +} >> + >> static void alloc_cluster(struct swap_info_struct *si, unsigned long idx) >> { >> struct swap_cluster_info *ci = si->cluster_info; >> @@ -2500,7 +2510,7 @@ static void enable_swap_info(struct swap_info_struct *p, int prio, >> * Guarantee swap_map, cluster_info, etc. fields are valid >> * between get/put_swap_device() if SWP_VALID bit is set >> */ >> - synchronize_rcu(); >> + percpu_ref_reinit(&p->users); > > Although the effect is same, I think it's better to use > percpu_ref_resurrect() here to improve code readability. Check the original commit description for commit eb085574a752 "mm, swap: fix race between swapoff and some swap operations" and discussion email thread as follows again, https://lore.kernel.org/linux-mm/20171219053650.GB7829@linux.vnet.ibm.com/ I found that the synchronize_rcu() here is to avoid to call smp_rmb() or smp_load_acquire() in get_swap_device(). Now we will use percpu_ref_tryget_live() in get_swap_device(), so we will need to add the necessary memory barrier, or make sure percpu_ref_tryget_live() has ACQUIRE semantics. Per my understanding, we need to change percpu_ref_tryget_live() for that. >> spin_lock(&swap_lock); >> spin_lock(&p->lock); >> _enable_swap_info(p); >> @@ -2621,11 +2631,13 @@ SYSCALL_DEFINE1(swapoff, const char __user *, specialfile) >> p->flags &= ~SWP_VALID; /* mark swap device as invalid */ >> spin_unlock(&p->lock); >> spin_unlock(&swap_lock); >> + >> + percpu_ref_kill(&p->users); >> /* >> * wait for swap operations protected by get/put_swap_device() >> * to complete >> */ >> - synchronize_rcu(); >> + wait_for_completion(&p->comp); > > Better to move percpu_ref_kill() after the comments. And maybe revise > the comments. After reading the original commit description as above, I found that we need synchronize_rcu() here to protect the accessing to the swap cache data structure. Because there's call_rcu() during percpu_ref_kill(), it appears OK to keep the synchronize_rcu() here. And we need to revise the comments to make it clear what is protected by which operation. Best Regards, Huang, Ying [snip] From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-13.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_CR_TRAILER,INCLUDES_PATCH, MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 3ADADC43460 for ; Mon, 12 Apr 2021 07:24:59 +0000 (UTC) Received: from kanga.kvack.org (kanga.kvack.org [205.233.56.17]) by mail.kernel.org (Postfix) with ESMTP id C33256120B for ; Mon, 12 Apr 2021 07:24:58 +0000 (UTC) DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org C33256120B Authentication-Results: mail.kernel.org; dmarc=fail (p=none dis=none) header.from=intel.com Authentication-Results: mail.kernel.org; spf=pass smtp.mailfrom=owner-linux-mm@kvack.org Received: by kanga.kvack.org (Postfix) id 204836B006E; Mon, 12 Apr 2021 03:24:58 -0400 (EDT) Received: by kanga.kvack.org (Postfix, from userid 40) id 18EDB6B0070; Mon, 12 Apr 2021 03:24:58 -0400 (EDT) X-Delivered-To: int-list-linux-mm@kvack.org Received: by kanga.kvack.org (Postfix, from userid 63042) id 0329F6B0071; Mon, 12 Apr 2021 03:24:57 -0400 (EDT) X-Delivered-To: linux-mm@kvack.org Received: from forelay.hostedemail.com (smtprelay0021.hostedemail.com [216.40.44.21]) by kanga.kvack.org (Postfix) with ESMTP id D7A956B006E for ; Mon, 12 Apr 2021 03:24:57 -0400 (EDT) Received: from smtpin05.hostedemail.com (10.5.19.251.rfc1918.com [10.5.19.251]) by forelay05.hostedemail.com (Postfix) with ESMTP id 90492180265A8 for ; Mon, 12 Apr 2021 07:24:57 +0000 (UTC) X-FDA: 78022878234.05.231F65F Received: from mga02.intel.com (mga02.intel.com [134.134.136.20]) by imf30.hostedemail.com (Postfix) with ESMTP id 6E365E000119 for ; Mon, 12 Apr 2021 07:24:47 +0000 (UTC) IronPort-SDR: 3lggM+AuFa25bNkzRsxOhsW0ntcYQ5vEeTiHKzUIOdN2fHi0CmozbKxrHZYS97we5BBY/zsLQt JU6NYwGvJkAA== X-IronPort-AV: E=McAfee;i="6000,8403,9951"; a="181257110" X-IronPort-AV: E=Sophos;i="5.82,214,1613462400"; d="scan'208";a="181257110" Received: from fmsmga008.fm.intel.com ([10.253.24.58]) by orsmga101.jf.intel.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 12 Apr 2021 00:24:54 -0700 IronPort-SDR: B9SU3wecjSe4accQUXOvGF+Iorh6vcLJJBTEy3kxZJASuwb0+V61dr3jxnQ6wrQkEILhccp2TO X/IJmGgNVlAg== X-IronPort-AV: E=Sophos;i="5.82,214,1613462400"; d="scan'208";a="417264247" Received: from yhuang6-desk1.sh.intel.com (HELO yhuang6-desk1.ccr.corp.intel.com) ([10.239.13.1]) by fmsmga008-auth.fm.intel.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 12 Apr 2021 00:24:50 -0700 From: "Huang, Ying" To: Miaohe Lin Cc: , , , , , , , , , , , , Subject: Re: [PATCH 1/5] mm/swapfile: add percpu_ref support for swap References: <20210408130820.48233-1-linmiaohe@huawei.com> <20210408130820.48233-2-linmiaohe@huawei.com> <87fszww55d.fsf@yhuang6-desk1.ccr.corp.intel.com> Date: Mon, 12 Apr 2021 15:24:48 +0800 In-Reply-To: <87fszww55d.fsf@yhuang6-desk1.ccr.corp.intel.com> (Ying Huang's message of "Mon, 12 Apr 2021 11:30:54 +0800") Message-ID: <87zgy4ufr3.fsf@yhuang6-desk1.ccr.corp.intel.com> User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/27.1 (gnu/linux) MIME-Version: 1.0 Content-Type: text/plain; charset=ascii X-Rspamd-Server: rspam01 X-Rspamd-Queue-Id: 6E365E000119 X-Stat-Signature: 93ka6hywapfqsqnpcx84xmqnzzudyrkx Received-SPF: none (intel.com>: No applicable sender policy available) receiver=imf30; identity=mailfrom; envelope-from=""; helo=mga02.intel.com; client-ip=134.134.136.20 X-HE-DKIM-Result: none/none X-HE-Tag: 1618212287-109136 X-Bogosity: Ham, tests=bogofilter, spamicity=0.000000, version=1.2.4 Sender: owner-linux-mm@kvack.org Precedence: bulk X-Loop: owner-majordomo@kvack.org List-ID: "Huang, Ying" writes: > Miaohe Lin writes: > >> We will use percpu-refcount to serialize against concurrent swapoff. This >> patch adds the percpu_ref support for later fixup. >> >> Signed-off-by: Miaohe Lin >> --- >> include/linux/swap.h | 2 ++ >> mm/swapfile.c | 25 ++++++++++++++++++++++--- >> 2 files changed, 24 insertions(+), 3 deletions(-) >> >> diff --git a/include/linux/swap.h b/include/linux/swap.h >> index 144727041e78..849ba5265c11 100644 >> --- a/include/linux/swap.h >> +++ b/include/linux/swap.h >> @@ -240,6 +240,7 @@ struct swap_cluster_list { >> * The in-memory structure used to track swap areas. >> */ >> struct swap_info_struct { >> + struct percpu_ref users; /* serialization against concurrent swapoff */ >> unsigned long flags; /* SWP_USED etc: see above */ >> signed short prio; /* swap priority of this type */ >> struct plist_node list; /* entry in swap_active_head */ >> @@ -260,6 +261,7 @@ struct swap_info_struct { >> struct block_device *bdev; /* swap device or bdev of swap file */ >> struct file *swap_file; /* seldom referenced */ >> unsigned int old_block_size; /* seldom referenced */ >> + struct completion comp; /* seldom referenced */ >> #ifdef CONFIG_FRONTSWAP >> unsigned long *frontswap_map; /* frontswap in-use, one bit per page */ >> atomic_t frontswap_pages; /* frontswap pages in-use counter */ >> diff --git a/mm/swapfile.c b/mm/swapfile.c >> index 149e77454e3c..724173cd7d0c 100644 >> --- a/mm/swapfile.c >> +++ b/mm/swapfile.c >> @@ -39,6 +39,7 @@ >> #include >> #include >> #include >> +#include >> >> #include >> #include >> @@ -511,6 +512,15 @@ static void swap_discard_work(struct work_struct *work) >> spin_unlock(&si->lock); >> } >> >> +static void swap_users_ref_free(struct percpu_ref *ref) >> +{ >> + struct swap_info_struct *si; >> + >> + si = container_of(ref, struct swap_info_struct, users); >> + complete(&si->comp); >> + percpu_ref_exit(&si->users); > > Because percpu_ref_exit() is used, we cannot use percpu_ref_tryget() in > get_swap_device(), better to add comments there. I just noticed that the comments of percpu_ref_tryget_live() says, * This function is safe to call as long as @ref is between init and exit. While we need to call get_swap_device() almost at any time, so it's better to avoid to call percpu_ref_exit() at all. This will waste some memory, but we need to follow the API definition to avoid potential issues in the long term. And we need to call percpu_ref_init() before insert the swap_info_struct into the swap_info[]. >> +} >> + >> static void alloc_cluster(struct swap_info_struct *si, unsigned long idx) >> { >> struct swap_cluster_info *ci = si->cluster_info; >> @@ -2500,7 +2510,7 @@ static void enable_swap_info(struct swap_info_struct *p, int prio, >> * Guarantee swap_map, cluster_info, etc. fields are valid >> * between get/put_swap_device() if SWP_VALID bit is set >> */ >> - synchronize_rcu(); >> + percpu_ref_reinit(&p->users); > > Although the effect is same, I think it's better to use > percpu_ref_resurrect() here to improve code readability. Check the original commit description for commit eb085574a752 "mm, swap: fix race between swapoff and some swap operations" and discussion email thread as follows again, https://lore.kernel.org/linux-mm/20171219053650.GB7829@linux.vnet.ibm.com/ I found that the synchronize_rcu() here is to avoid to call smp_rmb() or smp_load_acquire() in get_swap_device(). Now we will use percpu_ref_tryget_live() in get_swap_device(), so we will need to add the necessary memory barrier, or make sure percpu_ref_tryget_live() has ACQUIRE semantics. Per my understanding, we need to change percpu_ref_tryget_live() for that. >> spin_lock(&swap_lock); >> spin_lock(&p->lock); >> _enable_swap_info(p); >> @@ -2621,11 +2631,13 @@ SYSCALL_DEFINE1(swapoff, const char __user *, specialfile) >> p->flags &= ~SWP_VALID; /* mark swap device as invalid */ >> spin_unlock(&p->lock); >> spin_unlock(&swap_lock); >> + >> + percpu_ref_kill(&p->users); >> /* >> * wait for swap operations protected by get/put_swap_device() >> * to complete >> */ >> - synchronize_rcu(); >> + wait_for_completion(&p->comp); > > Better to move percpu_ref_kill() after the comments. And maybe revise > the comments. After reading the original commit description as above, I found that we need synchronize_rcu() here to protect the accessing to the swap cache data structure. Because there's call_rcu() during percpu_ref_kill(), it appears OK to keep the synchronize_rcu() here. And we need to revise the comments to make it clear what is protected by which operation. Best Regards, Huang, Ying [snip]