All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Laight <David.Laight@ACULAB.COM>
To: 'Christoph Hellwig' <hch@lst.de>,
	Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: Petr Mladek <pmladek@suse.com>, Jiri Kosina <jikos@kernel.org>,
	"Andrew Donnellan" <ajd@linux.ibm.com>,
	"linux-kbuild@vger.kernel.org" <linux-kbuild@vger.kernel.org>,
	David Airlie <airlied@linux.ie>,
	"Masahiro Yamada" <masahiroy@kernel.org>,
	Josh Poimboeuf <jpoimboe@redhat.com>,
	Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Maxime Ripard <mripard@kernel.org>,
	"live-patching@vger.kernel.org" <live-patching@vger.kernel.org>,
	Michal Marek <michal.lkml@markovi.net>,
	"Joe Lawrence" <joe.lawrence@redhat.com>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	Jessica Yu <jeyu@kernel.org>,
	Frederic Barrat <fbarrat@linux.ibm.com>,
	Daniel Vetter <daniel@ffwll.ch>, Miroslav Benes <mbenes@suse.cz>,
	"linuxppc-dev@lists.ozlabs.org" <linuxppc-dev@lists.ozlabs.org>
Subject: RE: [PATCH 02/13] module: add a module_loaded helper
Date: Thu, 21 Jan 2021 17:44:55 +0000	[thread overview]
Message-ID: <8d59f11971764db2a104c87937e1d3ab@AcuMS.aculab.com> (raw)
In-Reply-To: <20210121171119.GA29916@lst.de>

> 
> On Thu, Jan 21, 2021 at 11:00:20AM +0100, Christophe Leroy wrote:
> > > +bool module_loaded(const char *name);
> >
> > Maybe module_is_loaded() would be a better name.
> 
> Fine with me.

It does look like both callers aren't 'unsafe'.
But it is a bit strange returning a stale value.

It did make be look a bit more deeply at try_module_get().
For THIS_MODULE (eg to get an extra reference for a kthread)
I doubt it can ever fail.

But the other cases require a 'module' structure be passed in.
ISTM that unloading the module could invalidate the pointer
that has just been read from some other structure.

I'm guessing that some other lock must always be held.

	David

-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)


WARNING: multiple messages have this Message-ID (diff)
From: David Laight <David.Laight@ACULAB.COM>
To: 'Christoph Hellwig' <hch@lst.de>,
	Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: Petr Mladek <pmladek@suse.com>,
	Michal Marek <michal.lkml@markovi.net>,
	Andrew Donnellan <ajd@linux.ibm.com>,
	Jessica Yu <jeyu@kernel.org>,
	"linux-kbuild@vger.kernel.org" <linux-kbuild@vger.kernel.org>,
	David Airlie <airlied@linux.ie>,
	Masahiro Yamada <masahiroy@kernel.org>,
	Jiri Kosina <jikos@kernel.org>,
	Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Maxime Ripard <mripard@kernel.org>,
	Joe Lawrence <joe.lawrence@redhat.com>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	Josh Poimboeuf <jpoimboe@redhat.com>,
	Frederic Barrat <fbarrat@linux.ibm.com>,
	"live-patching@vger.kernel.org" <live-patching@vger.kernel.org>,
	Daniel Vetter <daniel@ffwll.ch>, Miroslav Benes <mbenes@suse.cz>,
	"linuxppc-dev@lists.ozlabs.org" <linuxppc-dev@lists.ozlabs.org>
Subject: RE: [PATCH 02/13] module: add a module_loaded helper
Date: Thu, 21 Jan 2021 17:44:55 +0000	[thread overview]
Message-ID: <8d59f11971764db2a104c87937e1d3ab@AcuMS.aculab.com> (raw)
In-Reply-To: <20210121171119.GA29916@lst.de>

> 
> On Thu, Jan 21, 2021 at 11:00:20AM +0100, Christophe Leroy wrote:
> > > +bool module_loaded(const char *name);
> >
> > Maybe module_is_loaded() would be a better name.
> 
> Fine with me.

It does look like both callers aren't 'unsafe'.
But it is a bit strange returning a stale value.

It did make be look a bit more deeply at try_module_get().
For THIS_MODULE (eg to get an extra reference for a kthread)
I doubt it can ever fail.

But the other cases require a 'module' structure be passed in.
ISTM that unloading the module could invalidate the pointer
that has just been read from some other structure.

I'm guessing that some other lock must always be held.

	David

-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)


WARNING: multiple messages have this Message-ID (diff)
From: David Laight <David.Laight@ACULAB.COM>
To: 'Christoph Hellwig' <hch@lst.de>,
	Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: Petr Mladek <pmladek@suse.com>,
	Michal Marek <michal.lkml@markovi.net>,
	Andrew Donnellan <ajd@linux.ibm.com>,
	Jessica Yu <jeyu@kernel.org>,
	"linux-kbuild@vger.kernel.org" <linux-kbuild@vger.kernel.org>,
	David Airlie <airlied@linux.ie>,
	Masahiro Yamada <masahiroy@kernel.org>,
	Jiri Kosina <jikos@kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Joe Lawrence <joe.lawrence@redhat.com>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	Josh Poimboeuf <jpoimboe@redhat.com>,
	Frederic Barrat <fbarrat@linux.ibm.com>,
	"live-patching@vger.kernel.org" <live-patching@vger.kernel.org>,
	Miroslav Benes <mbenes@suse.cz>,
	"linuxppc-dev@lists.ozlabs.org" <linuxppc-dev@lists.ozlabs.org>
Subject: RE: [PATCH 02/13] module: add a module_loaded helper
Date: Thu, 21 Jan 2021 17:44:55 +0000	[thread overview]
Message-ID: <8d59f11971764db2a104c87937e1d3ab@AcuMS.aculab.com> (raw)
In-Reply-To: <20210121171119.GA29916@lst.de>

> 
> On Thu, Jan 21, 2021 at 11:00:20AM +0100, Christophe Leroy wrote:
> > > +bool module_loaded(const char *name);
> >
> > Maybe module_is_loaded() would be a better name.
> 
> Fine with me.

It does look like both callers aren't 'unsafe'.
But it is a bit strange returning a stale value.

It did make be look a bit more deeply at try_module_get().
For THIS_MODULE (eg to get an extra reference for a kthread)
I doubt it can ever fail.

But the other cases require a 'module' structure be passed in.
ISTM that unloading the module could invalidate the pointer
that has just been read from some other structure.

I'm guessing that some other lock must always be held.

	David

-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2021-01-21 17:50 UTC|newest]

Thread overview: 70+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-21  7:49 module loader dead code removal and cleanusp Christoph Hellwig
2021-01-21  7:49 ` Christoph Hellwig
2021-01-21  7:49 ` [PATCH 01/13] powerpc/powernv: remove get_cxl_module Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-21  9:09   ` Andrew Donnellan
2021-01-21  9:09     ` Andrew Donnellan
2021-01-21  9:09     ` Andrew Donnellan
2021-01-21  7:49 ` [PATCH 02/13] module: add a module_loaded helper Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-21  9:59   ` Christophe Leroy
2021-01-21 10:13     ` David Laight
2021-01-21 10:17       ` Christophe Leroy
2021-01-21 10:00   ` Christophe Leroy
2021-01-21 10:00     ` Christophe Leroy
2021-01-21 17:11     ` Christoph Hellwig
2021-01-21 17:11       ` Christoph Hellwig
2021-01-21 17:44       ` David Laight [this message]
2021-01-21 17:44         ` David Laight
2021-01-21 17:44         ` David Laight
2021-01-21  7:49 ` [PATCH 03/13] livepatch: refactor klp_init_object Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-27 12:58   ` Petr Mladek
2021-01-27 12:58     ` Petr Mladek
2021-01-27 12:58     ` Petr Mladek
2021-01-28 16:22     ` Christoph Hellwig
2021-01-28 16:22       ` Christoph Hellwig
2021-01-28 16:24       ` Christoph Hellwig
2021-01-28 16:24         ` Christoph Hellwig
2021-01-21  7:49 ` [PATCH 04/13] livepatch: move klp_find_object_module to module.c Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-21 21:45   ` Josh Poimboeuf
2021-01-21 21:45     ` Josh Poimboeuf
2021-01-21 21:45     ` Josh Poimboeuf
2021-01-26 14:25   ` Jessica Yu
2021-01-26 14:25     ` Jessica Yu
2021-01-26 14:25     ` Jessica Yu
2021-01-27 11:55     ` Petr Mladek
2021-01-27 11:55       ` Petr Mladek
2021-01-27 11:55       ` Petr Mladek
2021-01-21  7:49 ` [PATCH 05/13] kallsyms: refactor {,module_}kallsyms_on_each_symbol Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-21  7:49 ` [PATCH 06/13] kallsyms: only build {,module_}kallsyms_on_each_symbol when required Christoph Hellwig
2021-01-21  7:49   ` [PATCH 06/13] kallsyms: only build {, module_}kallsyms_on_each_symbol " Christoph Hellwig
2021-01-21  7:49 ` [PATCH 07/13] module: mark module_mutex static Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-21  7:49 ` [PATCH 08/13] drm: remove drm_fb_helper_modinit Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-21  8:25   ` Daniel Vetter
2021-01-21  8:25     ` Daniel Vetter
2021-01-21  8:25     ` Daniel Vetter
2021-01-21  8:28     ` Christoph Hellwig
2021-01-21  8:28       ` Christoph Hellwig
2021-01-21  8:39       ` Daniel Vetter
2021-01-21  8:39         ` Daniel Vetter
2021-01-21  8:39         ` Daniel Vetter
2021-01-21  7:49 ` [PATCH 09/13] module: remove each_symbol_in_section Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-21  7:49 ` [PATCH 10/13] module: merge each_symbol_section into find_symbol Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-21  7:49 ` [PATCH 11/13] module: pass struct find_symbol_args to find_symbol Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-21  7:49 ` [PATCH 12/13] module: remove EXPORT_SYMBOL_GPL_FUTURE Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-21  7:49 ` [PATCH 13/13] module: remove EXPORY_UNUSED_SYMBOL* Christoph Hellwig
2021-01-21  7:49   ` Christoph Hellwig
2021-01-27 13:49   ` Jessica Yu
2021-01-27 13:49     ` Jessica Yu
2021-01-27 13:49     ` Jessica Yu
2021-01-28 16:09     ` Christoph Hellwig
2021-01-28 16:09       ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8d59f11971764db2a104c87937e1d3ab@AcuMS.aculab.com \
    --to=david.laight@aculab.com \
    --cc=airlied@linux.ie \
    --cc=ajd@linux.ibm.com \
    --cc=christophe.leroy@csgroup.eu \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=fbarrat@linux.ibm.com \
    --cc=hch@lst.de \
    --cc=jeyu@kernel.org \
    --cc=jikos@kernel.org \
    --cc=joe.lawrence@redhat.com \
    --cc=jpoimboe@redhat.com \
    --cc=linux-kbuild@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=live-patching@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=masahiroy@kernel.org \
    --cc=mbenes@suse.cz \
    --cc=michal.lkml@markovi.net \
    --cc=mripard@kernel.org \
    --cc=pmladek@suse.com \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.