All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Leizhen (ThunderTown)" <thunder.leizhen@huawei.com>
To: Matthew Wilcox <willy@infradead.org>
Cc: Minchan Kim <minchan@kernel.org>, Nitin Gupta <ngupta@vflare.org>,
	Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com>,
	Jens Axboe <axboe@kernel.dk>,
	linux-block <linux-block@vger.kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	linux-mm <linux-mm@kvack.org>, Alasdair Kergon <agk@redhat.com>,
	Mike Snitzer <snitzer@redhat.com>, dm-devel <dm-devel@redhat.com>,
	Song Liu <song@kernel.org>,
	linux-raid <linux-raid@vger.kernel.org>,
	linux-kernel <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 2/4] mm/swap: use SECTORS_PER_PAGE_SHIFT to clean up code
Date: Wed, 6 May 2020 17:16:04 +0800	[thread overview]
Message-ID: <8fefbfb2-1100-fab2-0383-e57343dc44f5@huawei.com> (raw)
In-Reply-To: <bddd596b-2e8e-42aa-70cc-41583b15c548@huawei.com>



On 2020/5/6 11:47, Leizhen (ThunderTown) wrote:
> 
> 
> On 2020/5/6 9:33, Leizhen (ThunderTown) wrote:
>>
>>
>> On 2020/5/6 1:25, Matthew Wilcox wrote:
>>> On Tue, May 05, 2020 at 07:55:41PM +0800, Zhen Lei wrote:
>>>> +++ b/mm/swapfile.c
>>>> @@ -177,8 +177,8 @@ static int discard_swap(struct swap_info_struct *si)
>>>>  
>>>>  	/* Do not discard the swap header page! */
>>>>  	se = first_se(si);
>>>> -	start_block = (se->start_block + 1) << (PAGE_SHIFT - 9);
>>>> -	nr_blocks = ((sector_t)se->nr_pages - 1) << (PAGE_SHIFT - 9);
>>>> +	start_block = (se->start_block + 1) << SECTORS_PER_PAGE_SHIFT;
>>>> +	nr_blocks = ((sector_t)se->nr_pages - 1) << SECTORS_PER_PAGE_SHIFT;
>>>
>>> Thinking about this some more, wouldn't this look better?
>>>
>>> 	start_block = page_sectors(se->start_block + 1);
>>> 	nr_block = page_sectors(se->nr_pages - 1);
>>>
>>
>> OK,That's fine, it's clearer. And in this way, there won't be more than 80 columns.
> 
> Should we rename "page_sectors" to "page_to_sectors"? Because we may need to define
> "sectors_to_page" also.

Change the "sectors_to_page" to "sectors_to_npage", npage means "number of pages"
or "page number". To distinguish the use case of "pfn_to_page()" etc. The latter
returns the pointer of "struct page".

> 
>>
>>>
>>> .
>>>

  reply	other threads:[~2020-05-06  9:16 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-05 11:55 [PATCH 0/4] eliminate SECTOR related magic numbers and duplicated conversions Zhen Lei
2020-05-05 11:55 ` [PATCH 1/4] block: Move SECTORS_PER_PAGE and SECTORS_PER_PAGE_SHIFT definitions into <linux/blkdev.h> Zhen Lei
2020-05-05 12:10   ` Matthew Wilcox
2020-05-06  4:06     ` Leizhen (ThunderTown)
2020-05-05 11:55 ` [PATCH 2/4] mm/swap: use SECTORS_PER_PAGE_SHIFT to clean up code Zhen Lei
2020-05-05 17:25   ` Matthew Wilcox
2020-05-06  1:33     ` Leizhen (ThunderTown)
2020-05-06  3:47       ` Leizhen (ThunderTown)
2020-05-06  9:16         ` Leizhen (ThunderTown) [this message]
2020-05-05 11:55 ` [PATCH 3/4] block: use SECTORS_PER_PAGE_SHIFT and SECTORS_PER_PAGE " Zhen Lei
2020-05-05 11:55 ` [PATCH 4/4] mtd: eliminate SECTOR related magic numbers Zhen Lei
2020-05-05 17:32 ` [PATCH 0/4] eliminate SECTOR related magic numbers and duplicated conversions antlists
2020-05-05 18:01   ` Matthew Wilcox

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8fefbfb2-1100-fab2-0383-e57343dc44f5@huawei.com \
    --to=thunder.leizhen@huawei.com \
    --cc=agk@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=axboe@kernel.dk \
    --cc=dm-devel@redhat.com \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=minchan@kernel.org \
    --cc=ngupta@vflare.org \
    --cc=sergey.senozhatsky.work@gmail.com \
    --cc=snitzer@redhat.com \
    --cc=song@kernel.org \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.