From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-6.7 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, INCLUDES_PATCH,MAILING_LIST_MULTI,SIGNED_OFF_BY,SPF_HELO_NONE,SPF_PASS, UNPARSEABLE_RELAY autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 0E309C7618B for ; Thu, 25 Jul 2019 16:30:21 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id D40CB22C7B for ; Thu, 25 Jul 2019 16:30:20 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1729288AbfGYQaT (ORCPT ); Thu, 25 Jul 2019 12:30:19 -0400 Received: from bhuna.collabora.co.uk ([46.235.227.227]:45906 "EHLO bhuna.collabora.co.uk" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726950AbfGYQaS (ORCPT ); Thu, 25 Jul 2019 12:30:18 -0400 Received: from [127.0.0.1] (localhost [127.0.0.1]) (Authenticated sender: ezequiel) with ESMTPSA id 9544928B55F Message-ID: <92f197b5d45e5f250c001752b11749af2533f4c3.camel@collabora.com> Subject: Re: [PATCH v2 6/7] media: hantro: Move VP8 common code From: Ezequiel Garcia To: Mauro Carvalho Chehab Cc: linux-media@vger.kernel.org, Hans Verkuil , kernel@collabora.com, Nicolas Dufresne , Tomasz Figa , linux-rockchip@lists.infradead.org, Heiko Stuebner , Jonas Karlman , Philipp Zabel , Boris Brezillon , Paul Kocialkowski , Alexandre Courbot , fbuergisser@chromium.org, linux-kernel@vger.kernel.org Date: Thu, 25 Jul 2019 13:30:07 -0300 In-Reply-To: <20190725132230.6e7f0c22@coco.lan> References: <20190725141756.2518-1-ezequiel@collabora.com> <20190725141756.2518-7-ezequiel@collabora.com> <20190725132230.6e7f0c22@coco.lan> Organization: Collabora Content-Type: text/plain; charset="UTF-8" User-Agent: Evolution 3.30.5-1.1 MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 2019-07-25 at 13:22 -0300, Mauro Carvalho Chehab wrote: > Em Thu, 25 Jul 2019 11:17:55 -0300 > Ezequiel Garcia escreveu: > > > In order to introduce support for RK3399 VP8 decoding, > > move some common VP8 code. This will be reused by > > the RK3399 implementation, reducing code duplication. > > > > Signed-off-by: Ezequiel Garcia > > --- > > .../staging/media/hantro/hantro_g1_vp8_dec.c | 17 ----------------- > > drivers/staging/media/hantro/hantro_hw.h | 4 ++++ > > drivers/staging/media/hantro/hantro_vp8.c | 15 +++++++++++++++ > > 3 files changed, 19 insertions(+), 17 deletions(-) > > > > diff --git a/drivers/staging/media/hantro/hantro_g1_vp8_dec.c b/drivers/staging/media/hantro/hantro_g1_vp8_dec.c > > index cd1fbd3a0d5f..181e2f76d8cb 100644 > > --- a/drivers/staging/media/hantro/hantro_g1_vp8_dec.c > > +++ b/drivers/staging/media/hantro/hantro_g1_vp8_dec.c > > @@ -16,8 +16,6 @@ > > #include "hantro.h" > > #include "hantro_g1_regs.h" > > > > -#define DEC_8190_ALIGN_MASK 0x07U > > - > > /* DCT partition base address regs */ > > static const struct hantro_reg vp8_dec_dct_base[8] = { > > { G1_REG_ADDR_STR, 0, 0xffffffff }, > > @@ -131,21 +129,6 @@ static const struct hantro_reg vp8_dec_pred_bc_tap[8][4] = { > > }, > > }; > > > > -/* > > - * filter taps taken to 7-bit precision, > > - * reference RFC6386#Page-16, filters[8][6] > > - */ > > -static const u32 vp8_dec_mc_filter[8][6] = { > > - { 0, 0, 128, 0, 0, 0 }, > > - { 0, -6, 123, 12, -1, 0 }, > > - { 2, -11, 108, 36, -8, 1 }, > > - { 0, -9, 93, 50, -6, 0 }, > > - { 3, -16, 77, 77, -16, 3 }, > > - { 0, -6, 50, 93, -9, 0 }, > > - { 1, -8, 36, 108, -11, 2 }, > > - { 0, -1, 12, 123, -6, 0 } > > -}; > > - > > /* > > * Set loop filters > > */ > > diff --git a/drivers/staging/media/hantro/hantro_hw.h b/drivers/staging/media/hantro/hantro_hw.h > > index 34ef24e3a9ef..185e27d47e47 100644 > > --- a/drivers/staging/media/hantro/hantro_hw.h > > +++ b/drivers/staging/media/hantro/hantro_hw.h > > @@ -15,6 +15,8 @@ > > #include > > #include > > > > +#define DEC_8190_ALIGN_MASK 0x07U > > + > > struct hantro_dev; > > struct hantro_ctx; > > struct hantro_buf; > > @@ -93,6 +95,8 @@ extern const struct hantro_variant rk3399_vpu_variant; > > extern const struct hantro_variant rk3328_vpu_variant; > > extern const struct hantro_variant rk3288_vpu_variant; > > > > +extern const u32 vp8_dec_mc_filter[8][6]; > > Please don't do that, as a symbol like that can easily cause > namespace clashes in the future. For all exported symbols, > please prepend the driver name, like: > > hantro_vp8_dec_mc_filter > Right. Would you be OK, with taking Hans' PR and accept a follow-up patch fixing this? Thanks, Eze