From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Xing, Beilei" Subject: Re: [PATCH v4 17/17] net/i40e: flush tunnel filters Date: Tue, 3 Jan 2017 04:49:35 +0000 Message-ID: <94479800C636CB44BD422CB454846E013158D10E@SHSMSX101.ccr.corp.intel.com> References: <1483027473-89042-1-git-send-email-beilei.xing@intel.com> <1483068352-32272-1-git-send-email-beilei.xing@intel.com> <1483068352-32272-18-git-send-email-beilei.xing@intel.com> <3f58d1aa-a688-0281-6ffe-db37124c3680@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Cc: "dev@dpdk.org" To: "Guo, Jia" , "Wu, Jingjing" , "Zhang, Helin" Return-path: Received: from mga01.intel.com (mga01.intel.com [192.55.52.88]) by dpdk.org (Postfix) with ESMTP id AD8522946 for ; Tue, 3 Jan 2017 05:49:39 +0100 (CET) In-Reply-To: <3f58d1aa-a688-0281-6ffe-db37124c3680@intel.com> Content-Language: en-US List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Hi Jeff, > -----Original Message----- > From: Guo, Jia > Sent: Tuesday, January 3, 2017 11:25 AM > To: Xing, Beilei ; Wu, Jingjing > ; Zhang, Helin > Cc: dev@dpdk.org > Subject: Re: [dpdk-dev] [PATCH v4 17/17] net/i40e: flush tunnel filters >=20 >=20 >=20 > On 12/30/2016 11:25 AM, Beilei Xing wrote: > > This patch adds i40e_tunnel_filter_flush function to flush all tunnel > > filters, including filters in SW and HW. > > > > Signed-off-by: Beilei Xing > > --- > > drivers/net/i40e/i40e_flow.c | 37 > +++++++++++++++++++++++++++++++++++++ > > 1 file changed, 37 insertions(+) > > > > diff --git a/drivers/net/i40e/i40e_flow.c > > b/drivers/net/i40e/i40e_flow.c index 5c16fb8..fd0f0ec 100644 > > --- a/drivers/net/i40e/i40e_flow.c > > +++ b/drivers/net/i40e/i40e_flow.c > > @@ -105,6 +105,7 @@ static int i40e_dev_destroy_tunnel_filter(struct > i40e_pf *pf, > > struct i40e_tunnel_filter *filter); > > static int i40e_fdir_filter_flush(struct i40e_pf *pf); > > static int i40e_ethertype_filter_flush(struct i40e_pf *pf); > > +static int i40e_tunnel_filter_flush(struct i40e_pf *pf); > > > > const struct rte_flow_ops i40e_flow_ops =3D { > > .validate =3D i40e_flow_validate, > > @@ -1671,6 +1672,14 @@ i40e_flow_flush(struct rte_eth_dev *dev, struct > rte_flow_error *error) > > return -rte_errno; > > } > > > > + ret =3D i40e_tunnel_filter_flush(pf); > > + if (ret) { > > + rte_flow_error_set(error, -ret, > > + RTE_FLOW_ERROR_TYPE_HANDLE, NULL, > > + "Failed to flush tunnel flows."); > > + return -rte_errno; > > + } > > + > > return ret; > > } > > > > @@ -1733,3 +1742,31 @@ i40e_ethertype_filter_flush(struct i40e_pf *pf) > > > > return ret; > > } > > + > > +/* Flush all tunnel filters */ > > +static int > > +i40e_tunnel_filter_flush(struct i40e_pf *pf) { > > + struct i40e_tunnel_filter_list > > + *tunnel_list =3D &pf->tunnel.tunnel_list; > > + struct i40e_tunnel_filter *f; > Just a mini comment, could you replace the variables name from "f" to any > other obvious name , to let code to be more readable. Thanks for comments, and will update in next version. > > > > + struct i40e_flow *flow; > > + void *temp; > > + int ret =3D 0; > > + > > + while ((f =3D TAILQ_FIRST(tunnel_list))) { > > + ret =3D i40e_dev_destroy_tunnel_filter(pf, f); > > + if (ret) > > + return ret; > > + } > > + > > + /* Delete tunnel flows in flow list. */ > > + TAILQ_FOREACH_SAFE(flow, &pf->flow_list, node, temp) { > > + if (flow->filter_type =3D=3D RTE_ETH_FILTER_TUNNEL) { > > + TAILQ_REMOVE(&pf->flow_list, flow, node); > > + rte_free(flow); > > + } > > + } > > + > > + return ret; > > +}