All of lore.kernel.org
 help / color / mirror / Atom feed
From: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
To: Suzuki K Poulose <suzuki.poulose@arm.com>, linux-kernel@vger.kernel.org
Cc: gregkh@linuxfoundation.org, rafael@kernel.org,
	Alexander Shishkin <alexander.shishkin@linux.intel.com>,
	Andrew Lunn <andrew@lunn.ch>,
	Andreas Noever <andreas.noever@gmail.com>,
	Arnd Bergmann <arnd@arndb.de>,
	Bjorn Helgaas <bhelgaas@google.com>,
	Corey Minyard <minyard@acm.org>,
	Christian Borntraeger <borntraeger@de.ibm.com>,
	David Kershner <david.kershner@unisys.com>,
	"David S. Miller" <davem@davemloft.net>,
	David Airlie <airlied@linux.ie>, Felipe Balbi <balbi@kernel.org>,
	Frank Rowand <frowand.list@gmail.com>,
	Grygorii Strashko <grygorii.strashko@ti.com>,
	Harald Freudenberger <freude@linux.ibm.com>,
	Hartmut Knaack <knaack.h@gmx.de>,
	Heiko Stuebner <heiko@sntech.de>, Jason Gunthorpe <jgg@ziepe.ca>,
	Jonathan Cameron <jic23@kernel.org>,
	"James E.J. Bottomley" <jejb@linux.ibm.com>,
	Len Brown <lenb@kernel.org>, Mark Brown <broonie@kernel.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Michael Jamet <michael.jamet@intel.com>,
	"Martin K. Petersen" <martin.petersen@oracle.com>,
	Peter Oberparleiter <oberpar@linux.ibm.com>,
	Rob Herring <robh+dt@kernel.org>,
	Sebastian Ott <sebott@linux.ibm.com>,
	Yehezkel Bernat <YehezkelShB@gmail.com>,
	Wolfram Sang <wsa@the-dreams.de>
Subject: Re: [PATCH 02/13] bus_find_device: Unify the match callback with class_find_device
Date: Thu, 6 Jun 2019 10:01:30 +0100	[thread overview]
Message-ID: <958acbca-5322-d079-2d88-591ed3d12ed7@linaro.org> (raw)
In-Reply-To: <1559747630-28065-3-git-send-email-suzuki.poulose@arm.com>



On 05/06/2019 16:13, Suzuki K Poulose wrote:
> There is an arbitrary difference between the prototypes of
> bus_find_device() and class_find_device() preventing their callers
> from passing the same pair of data and match() arguments to both of
> them, which is the const qualifier used in the prototype of
> class_find_device().  If that qualifier is also used in the
> bus_find_device() prototype, it will be possible to pass the same
> match() callback function to both bus_find_device() and
> class_find_device(), which will allow some optimizations to be made in
> order to avoid code duplication going forward.  Also with that, constify
> the "data" parameter as it is passed as a const to the match function.
> 
> For this reason, change the prototype of bus_find_device() to match
> the prototype of class_find_device() and adjust its callers to use the
> const qualifier in accordance with the new prototype of it.
> 
> Cc: Alexander Shishkin<alexander.shishkin@linux.intel.com>
> Cc: Andrew Lunn<andrew@lunn.ch>
> Cc: Andreas Noever<andreas.noever@gmail.com>
> Cc: Arnd Bergmann<arnd@arndb.de>
> Cc: Bjorn Helgaas<bhelgaas@google.com>
> Cc: Corey Minyard<minyard@acm.org>
> Cc: Christian Borntraeger<borntraeger@de.ibm.com>
> Cc: David Kershner<david.kershner@unisys.com>
> Cc: "David S. Miller"<davem@davemloft.net>
> Cc: David Airlie<airlied@linux.ie>
> Cc: Felipe Balbi<balbi@kernel.org>
> Cc: Frank Rowand<frowand.list@gmail.com>
> Cc: Grygorii Strashko<grygorii.strashko@ti.com>
> Cc: Harald Freudenberger<freude@linux.ibm.com>
> Cc: Hartmut Knaack<knaack.h@gmx.de>
> Cc: Heiko Stuebner<heiko@sntech.de>
> Cc: Jason Gunthorpe<jgg@ziepe.ca>
> Cc: Jonathan Cameron<jic23@kernel.org>
> Cc: Jonathan Cameron<jic23@kernel.org>
> Cc: "James E.J. Bottomley"<jejb@linux.ibm.com>
> Cc: Len Brown<lenb@kernel.org>
> Cc: Mark Brown<broonie@kernel.org>
> Cc: Michael Ellerman<mpe@ellerman.id.au>
> Cc: Michael Jamet<michael.jamet@intel.com>
> Cc: "Martin K. Petersen"<martin.petersen@oracle.com>
> Cc: Peter Oberparleiter<oberpar@linux.ibm.com>
> Cc: Rob Herring<robh+dt@kernel.org>
> Cc: Sebastian Ott<sebott@linux.ibm.com>
> Cc: Srinivas Kandagatla<srinivas.kandagatla@linaro.org>
> Cc: Yehezkel Bernat<YehezkelShB@gmail.com>
> Cc: Wolfram Sang<wsa@the-dreams.de>
> Cc:rafael@kernel.org
> Cc: Greg Kroah-Hartman<gregkh@linuxfoundation.org>
> Signed-off-by: Suzuki K Poulose<suzuki.poulose@arm.com>
> ---
>   arch/powerpc/platforms/pseries/ibmebus.c           | 4 ++--
>   drivers/acpi/acpi_lpss.c                           | 4 ++--
>   drivers/acpi/sleep.c                               | 2 +-
>   drivers/acpi/utils.c                               | 4 ++--
>   drivers/base/bus.c                                 | 6 +++---
>   drivers/base/devcon.c                              | 2 +-
>   drivers/char/ipmi/ipmi_si_platform.c               | 2 +-
>   drivers/firmware/efi/dev-path-parser.c             | 4 ++--
>   drivers/gpu/drm/drm_mipi_dsi.c                     | 2 +-
>   drivers/hwtracing/coresight/coresight.c            | 6 +++---
>   drivers/hwtracing/coresight/of_coresight.c         | 2 +-
>   drivers/hwtracing/intel_th/core.c                  | 5 ++---
>   drivers/i2c/i2c-core-acpi.c                        | 4 ++--
>   drivers/i2c/i2c-core-of.c                          | 4 ++--
>   drivers/iio/inkern.c                               | 2 +-
>   drivers/infiniband/hw/hns/hns_roce_hw_v1.c         | 2 +-
>   drivers/net/ethernet/hisilicon/hns/hns_dsaf_misc.c | 2 +-
>   drivers/net/ethernet/ti/cpsw-phy-sel.c             | 4 ++--
>   drivers/net/ethernet/ti/davinci_emac.c             | 2 +-
>   drivers/net/ethernet/toshiba/tc35815.c             | 4 ++--
>   drivers/nvmem/core.c                               | 2 +-


For NVMEM changes,

Acked-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>


--srini

  parent reply	other threads:[~2019-06-06  9:01 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-06-05 15:13 [PATCH 00/13] drivers: Introduce generic device lookup helpers Suzuki K Poulose
2019-06-05 15:13 ` Suzuki K Poulose
2019-06-05 15:13 ` Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 01/13] acpi: utils: Cleanup acpi_dev_match_cb Suzuki K Poulose
2019-06-06  9:14   ` Rafael J. Wysocki
2019-06-06  9:21     ` Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 02/13] bus_find_device: Unify the match callback with class_find_device Suzuki K Poulose
2019-06-05 15:48   ` Corey Minyard
2019-06-05 15:51   ` Kershner, David A
2019-06-05 18:18   ` Mark Brown
2019-06-06  8:56   ` Rafael J. Wysocki
2019-06-06  9:01   ` Srinivas Kandagatla [this message]
2019-06-05 15:13 ` [PATCH 03/13] driver_find_device: Unify the match function with class_find_device() Suzuki K Poulose
2019-06-12  9:32   ` Lee Jones
2019-06-12  9:36     ` Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 04/13] drivers: Add generic helper to match by of_node Suzuki K Poulose
2019-06-05 15:13   ` Suzuki K Poulose
2019-06-05 15:13   ` Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 05/13] drivers: Add generic helper to match by fwnode Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 06/13] drivers: Add generic helper to match by devt Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 07/13] drivers: Add generic match helper by ACPI_COMPANION device Suzuki K Poulose
2019-06-06  9:17   ` Rafael J. Wysocki
2019-06-06  9:28     ` Suzuki K Poulose
2019-06-06  9:57       ` Rafael J. Wysocki
2019-06-12  9:43         ` Suzuki K Poulose
2019-06-12 22:07           ` Rafael J. Wysocki
2019-06-05 15:13 ` [PATCH 08/13] drivers: Add generic helper to match by name Suzuki K Poulose
2019-06-05 15:13   ` Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 09/13] drivers: Add generic helper to match any device Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 10/13] drivers: Introduce variants of class_find_device() Suzuki K Poulose
2019-06-05 15:13   ` Suzuki K Poulose
2019-06-05 16:14   ` Greg KH
2019-06-05 16:14     ` Greg KH
2019-06-05 18:13     ` Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 11/13] drivers: Introduce variants for bus_find_device() Suzuki K Poulose
2019-06-05 15:13   ` Suzuki K Poulose
2019-06-05 15:13   ` Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 12/13] drivers: Introduce variants of driver_find_device() Suzuki K Poulose
2019-06-05 15:13 ` [PATCH 13/13] platform: Add platform_find_device_by_driver() helper Suzuki K Poulose

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=958acbca-5322-d079-2d88-591ed3d12ed7@linaro.org \
    --to=srinivas.kandagatla@linaro.org \
    --cc=YehezkelShB@gmail.com \
    --cc=airlied@linux.ie \
    --cc=alexander.shishkin@linux.intel.com \
    --cc=andreas.noever@gmail.com \
    --cc=andrew@lunn.ch \
    --cc=arnd@arndb.de \
    --cc=balbi@kernel.org \
    --cc=bhelgaas@google.com \
    --cc=borntraeger@de.ibm.com \
    --cc=broonie@kernel.org \
    --cc=davem@davemloft.net \
    --cc=david.kershner@unisys.com \
    --cc=freude@linux.ibm.com \
    --cc=frowand.list@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=grygorii.strashko@ti.com \
    --cc=heiko@sntech.de \
    --cc=jejb@linux.ibm.com \
    --cc=jgg@ziepe.ca \
    --cc=jic23@kernel.org \
    --cc=knaack.h@gmx.de \
    --cc=lenb@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=michael.jamet@intel.com \
    --cc=minyard@acm.org \
    --cc=mpe@ellerman.id.au \
    --cc=oberpar@linux.ibm.com \
    --cc=rafael@kernel.org \
    --cc=robh+dt@kernel.org \
    --cc=sebott@linux.ibm.com \
    --cc=suzuki.poulose@arm.com \
    --cc=wsa@the-dreams.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.