All of lore.kernel.org
 help / color / mirror / Atom feed
From: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
To: Cezary Rojewski <cezary.rojewski@intel.com>,
	alsa-devel@alsa-project.org,  broonie@kernel.org
Cc: hdegoede@redhat.com, amadeuszx.slawinski@linux.intel.com, tiwai@suse.com
Subject: Re: [PATCH v4 00/17] ASoC: Intel: haswell and broadwell boards update
Date: Tue, 21 Jun 2022 11:36:20 -0500	[thread overview]
Message-ID: <95a7a219-8330-628f-aa10-28a078217de7@linux.intel.com> (raw)
In-Reply-To: <20220620101402.2684366-1-cezary.rojewski@intel.com>



On 6/20/22 05:13, Cezary Rojewski wrote:
> A number of patches improving overall quality and readability of
> haswell.c and broadwell.c source files found in sound/soc/intel/boards.
> Both files are first renamed and only then actual changes are being
> incrementally added. The respective names are: hsw_rt5640 and bdw_rt286
> to match the pattern found in more recent boards.
> 
> Most patches bring no functional change - the more impactful patches at
> are placed the end:
> 
> Refactor of suspend/resume flow for the bdw_rt286 board by dropping
> dev->remove() in favour of card->remove() and adjust jack handling to
> reduce code size slightly by implementing card_set_jack().
> 
> The last patch is removing of FE DAI ops. Given the existence of
> platform FE DAI capabilities (either static declaration or through
> topology file), this code is redundant.

Possibly a mistake in our tests, but this error seems to be introduced:

[  107.397637] kernel: rt286 i2c-INT343A:00: ASoC: DAPM unknown pin LDO1

I'll have to re-run the tests, sharing this information as is.


> Changes in v4:
> - just a rebase to fix missed conflicts with for-next
> 
> Changes in v3:
> - Patch 16/17 refactoring suspend/resume has been renamed to "Refactor
>   jack handling". Dropped the usage of card->remove() in favor of
>   link->exit() in that very patch
> 
> Changes in v2:
> - fixed wording error in patch 02/17 so it correctly mentions
>   'haswell_rt5640', not 'broadwell_rt286'
> - decided not to add kernel module names changes to this patchset so the
>   review is not complicated unnecessarily. Will send them separately
>   instead
> 
> Cezary Rojewski (17):
>   ASoC: Intel: Rename haswell source file to hsw_rt5640
>   ASoC: Intel: hsw_rt5640: Reword prefixes of all driver members
>   ASoC: Intel: hsw_rt5640: Reword driver name
>   ASoC: Intel: hsw_rt5640: Update code indentation
>   ASoC: Intel: hsw_rt5640: Update file comments
>   ASoC: Intel: hsw_rt5640: Improve probe() function quality
>   ASoC: Intel: hsw_rt5640: Improve hw_params() debug-ability
>   ASoC: Intel: Rename broadwell source file to bdw_rt286
>   ASoC: Intel: bdw_rt286: Reword prefixes of all driver members
>   ASoC: Intel: bdw_rt286: Reword driver name
>   ASoC: Intel: bdw_rt286: Update code indentation
>   ASoC: Intel: bdw_rt286: Update file comments
>   ASoC: Intel: bdw_rt286: Improve probe() function quality
>   ASoC: Intel: bdw_rt286: Improve hw_params() debug-ability
>   ASoC: Intel: bdw_rt286: Improve codec_init() quality
>   ASoC: Intel: bdw_rt286: Refactor jack handling
>   ASoC: Intel: bdw_rt286: Remove FE DAI ops
> 
>  sound/soc/intel/boards/Kconfig                |   4 +-
>  sound/soc/intel/boards/Makefile               |   4 +-
>  sound/soc/intel/boards/bdw_rt286.c            | 256 +++++++++++++
>  sound/soc/intel/boards/broadwell.c            | 338 ------------------
>  sound/soc/intel/boards/haswell.c              | 202 -----------
>  sound/soc/intel/boards/hsw_rt5640.c           | 176 +++++++++
>  .../common/soc-acpi-intel-hsw-bdw-match.c     |   6 +-
>  7 files changed, 439 insertions(+), 547 deletions(-)
>  create mode 100644 sound/soc/intel/boards/bdw_rt286.c
>  delete mode 100644 sound/soc/intel/boards/broadwell.c
>  delete mode 100644 sound/soc/intel/boards/haswell.c
>  create mode 100644 sound/soc/intel/boards/hsw_rt5640.c
> 

  parent reply	other threads:[~2022-06-21 16:37 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-06-20 10:13 [PATCH v4 00/17] ASoC: Intel: haswell and broadwell boards update Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 01/17] ASoC: Intel: Rename haswell source file to hsw_rt5640 Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 02/17] ASoC: Intel: hsw_rt5640: Reword prefixes of all driver members Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 03/17] ASoC: Intel: hsw_rt5640: Reword driver name Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 04/17] ASoC: Intel: hsw_rt5640: Update code indentation Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 05/17] ASoC: Intel: hsw_rt5640: Update file comments Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 06/17] ASoC: Intel: hsw_rt5640: Improve probe() function quality Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 07/17] ASoC: Intel: hsw_rt5640: Improve hw_params() debug-ability Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 08/17] ASoC: Intel: Rename broadwell source file to bdw_rt286 Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 09/17] ASoC: Intel: bdw_rt286: Reword prefixes of all driver members Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 10/17] ASoC: Intel: bdw_rt286: Reword driver name Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 11/17] ASoC: Intel: bdw_rt286: Update code indentation Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 12/17] ASoC: Intel: bdw_rt286: Update file comments Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 13/17] ASoC: Intel: bdw_rt286: Improve probe() function quality Cezary Rojewski
2022-06-20 10:13 ` [PATCH v4 14/17] ASoC: Intel: bdw_rt286: Improve hw_params() debug-ability Cezary Rojewski
2022-06-20 10:14 ` [PATCH v4 15/17] ASoC: Intel: bdw_rt286: Improve codec_init() quality Cezary Rojewski
2022-06-20 10:14 ` [PATCH v4 16/17] ASoC: Intel: bdw_rt286: Refactor jack handling Cezary Rojewski
2022-06-20 10:14 ` [PATCH v4 17/17] ASoC: Intel: bdw_rt286: Remove FE DAI ops Cezary Rojewski
2022-06-21 16:36 ` Pierre-Louis Bossart [this message]
2022-06-21 17:47   ` [PATCH v4 00/17] ASoC: Intel: haswell and broadwell boards update Cezary Rojewski
2022-06-21 21:11     ` Pierre-Louis Bossart
2022-06-22 18:15       ` Cezary Rojewski
2022-06-22 18:55         ` Pierre-Louis Bossart
2022-06-23  8:16           ` Cezary Rojewski
2022-06-24 10:59 ` (subset) " Mark Brown

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=95a7a219-8330-628f-aa10-28a078217de7@linux.intel.com \
    --to=pierre-louis.bossart@linux.intel.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=amadeuszx.slawinski@linux.intel.com \
    --cc=broonie@kernel.org \
    --cc=cezary.rojewski@intel.com \
    --cc=hdegoede@redhat.com \
    --cc=tiwai@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.