All of lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2020-03-13 23:16:35 to 2020-03-14 01:01:17 UTC [more...]

Waiting until first release of NFTABLES
 2020-03-14  1:01 UTC  (3+ messages)

[RFC][PATCHSET] sanitized pathwalk machinery (v2)
 2020-03-14  1:00 UTC  (79+ messages)
` [RFC][PATCHSET] sanitized pathwalk machinery (v3)
  ` [RFC][PATCHSET] sanitized pathwalk machinery (v4)
    ` [RFC][PATCH v4 01/69] do_add_mount(): lift lock_mount/unlock_mount into callers
      ` [RFC][PATCH v4 02/69] fix automount/automount race properly
      ` [RFC][PATCH v4 03/69] follow_automount(): get rid of dead^Wstillborn code
      ` [RFC][PATCH v4 04/69] follow_automount() doesn't need the entire nameidata
      ` [RFC][PATCH v4 05/69] make build_open_flags() treat O_CREAT | O_EXCL as implying O_NOFOLLOW
      ` [RFC][PATCH v4 06/69] handle_mounts(): start building a sane wrapper for follow_managed()
      ` [RFC][PATCH v4 07/69] atomic_open(): saner calling conventions (return dentry on success)
      ` [RFC][PATCH v4 08/69] lookup_open(): "
      ` [RFC][PATCH v4 09/69] do_last(): collapse the call of path_to_nameidata()
      ` [RFC][PATCH v4 10/69] handle_mounts(): pass dentry in, turn path into a pure out argument
      ` [RFC][PATCH v4 11/69] lookup_fast(): consolidate the RCU success case
      ` [RFC][PATCH v4 12/69] teach handle_mounts() to handle RCU mode
      ` [RFC][PATCH v4 13/69] lookup_fast(): take mount traversal into callers
      ` [RFC][PATCH v4 14/69] step_into() callers: dismiss the symlink earlier
      ` [RFC][PATCH v4 15/69] new step_into() flag: WALK_NOFOLLOW
      ` [RFC][PATCH v4 16/69] fold handle_mounts() into step_into()
      ` [RFC][PATCH v4 17/69] LOOKUP_MOUNTPOINT: fold path_mountpointat() into path_lookupat()
      ` [RFC][PATCH v4 18/69] expand the only remaining call of path_lookup_conditional()
      ` [RFC][PATCH v4 19/69] merging pick_link() with get_link(), part 1
      ` [RFC][PATCH v4 20/69] merging pick_link() with get_link(), part 2
      ` [RFC][PATCH v4 21/69] merging pick_link() with get_link(), part 3
      ` [RFC][PATCH v4 22/69] merging pick_link() with get_link(), part 4
      ` [RFC][PATCH v4 23/69] merging pick_link() with get_link(), part 5
      ` [RFC][PATCH v4 24/69] merging pick_link() with get_link(), part 6
      ` [RFC][PATCH v4 25/69] finally fold get_link() into pick_link()
      ` [RFC][PATCH v4 26/69] sanitize handling of nd->last_type, kill LAST_BIND
      ` [RFC][PATCH v4 27/69] namei: invert the meaning of WALK_FOLLOW
      ` [RFC][PATCH v4 28/69] pick_link(): check for WALK_TRAILING, not LOOKUP_PARENT
      ` [RFC][PATCH v4 29/69] link_path_walk(): simplify stack handling
      ` [RFC][PATCH v4 30/69] namei: have link_path_walk() maintain LOOKUP_PARENT
      ` [RFC][PATCH v4 31/69] massage __follow_mount_rcu() a bit
      ` [RFC][PATCH v4 32/69] new helper: traverse_mounts()
      ` [RFC][PATCH v4 33/69] atomic_open(): return the right dentry in FMODE_OPENED case
      ` [RFC][PATCH v4 34/69] atomic_open(): lift the call of may_open() into do_last()
      ` [RFC][PATCH v4 35/69] do_last(): merge the may_open() calls
      ` [RFC][PATCH v4 36/69] do_last(): don't bother with keeping got_write in FMODE_OPENED case
      ` [RFC][PATCH v4 37/69] do_last(): rejoing the common path earlier in FMODE_{OPENED,CREATED} case
      ` [RFC][PATCH v4 38/69] do_last(): simplify the liveness analysis past finish_open_created
      ` [RFC][PATCH v4 39/69] do_last(): rejoin the common path even earlier in FMODE_{OPENED,CREATED} case
      ` [RFC][PATCH v4 40/69] split the lookup-related parts of do_last() into a separate helper
      ` [RFC][PATCH v4 41/69] path_connected(): pass mount and dentry separately
      ` [RFC][PATCH v4 42/69] path_parent_directory(): leave changing path->dentry to callers
      ` [RFC][PATCH v4 43/69] expand path_parent_directory() in its callers
      ` [RFC][PATCH v4 44/69] follow_dotdot{,_rcu}(): lift switching nd->path to parent out of loop
      ` [RFC][PATCH v4 45/69] follow_dotdot{,_rcu}(): lift LOOKUP_BENEATH checks "
      ` [RFC][PATCH v4 46/69] move handle_dots(), follow_dotdot() and follow_dotdot_rcu() past step_into()
      ` [RFC][PATCH v4 47/69] handle_dots(), follow_dotdot{,_rcu}(): preparation to switch to step_into()
      ` [RFC][PATCH v4 48/69] follow_dotdot{,_rcu}(): switch to use of step_into()
      ` [RFC][PATCH v4 49/69] lift all calls of step_into() out of follow_dotdot/follow_dotdot_rcu
      ` [RFC][PATCH v4 50/69] follow_dotdot{,_rcu}(): massage loops
      ` [RFC][PATCH v4 51/69] follow_dotdot_rcu(): be lazy about changing nd->path
      ` [RFC][PATCH v4 52/69] follow_dotdot(): "
      ` [RFC][PATCH v4 53/69] helper for mount rootwards traversal
      ` [RFC][PATCH v4 54/69] non-RCU analogue of the previous commit
      ` [RFC][PATCH v4 55/69] fs/namei.c: kill follow_mount()
      ` [RFC][PATCH v4 56/69] pick_link(): more straightforward handling of allocation failures
      ` [RFC][PATCH v4 57/69] pick_link(): pass it struct path already with normal refcounting rules
      ` [RFC][PATCH v4 58/69] fold path_to_nameidata() into its only remaining caller
      ` [RFC][PATCH v4 59/69] pick_link(): take reserving space on stack into a new helper
      ` [RFC][PATCH v4 60/69] reserve_stack(): switch to __nd_alloc_stack()
      ` [RFC][PATCH v4 61/69] __nd_alloc_stack(): make it return bool
      ` [RFC][PATCH v4 62/69] link_path_walk(): sample parent's i_uid and i_mode for the last component
      ` [RFC][PATCH v4 63/69] take post-lookup part of do_last() out of loop
      ` [RFC][PATCH v4 64/69] open_last_lookups(): consolidate fsnotify_create() calls
      ` [RFC][PATCH v4 65/69] open_last_lookups(): don't abuse complete_walk() when all we want is unlazy
      ` [RFC][PATCH v4 66/69] open_last_lookups(): lift O_EXCL|O_CREAT handling into do_open()
      ` [RFC][PATCH v4 67/69] open_last_lookups(): move complete_walk() "
      ` [RFC][PATCH v4 68/69] atomic_open(): no need to pass struct open_flags anymore
      ` [RFC][PATCH v4 69/69] lookup_open(): don't bother with fallbacks to lookup+create

[PATCH V2 0/8] Add interconnect support to QSPI and QUP drivers
 2020-03-14  0:58 UTC  (7+ messages)
` [PATCH V2 5/8] i2c: i2c-qcom-geni: Add interconnect support
` [PATCH V2 6/8] spi: spi-geni-qcom: "
` [PATCH V2 7/8] spi: spi-qcom-qspi: "

[Xen-devel] [xen-unstable test] 148479: regressions - FAIL
 2020-03-14  0:57 UTC 

[PATCH v2 bpf] bpf: Sanitize the bpf_struct_ops tcp-cc name
 2020-03-14  0:57 UTC  (2+ messages)
` [Potential Spoof] "

[PATCH v2 0/4] kselftest: add fixture parameters
 2020-03-14  0:55 UTC  (5+ messages)
` [PATCH v2 1/4] selftests/seccomp: use correct FIXTURE macro
` [PATCH v2 2/4] kselftest: create fixture objects
` [PATCH v2 3/4] kselftest: add fixture parameters
` [PATCH v2 4/4] selftests: tls: run all tests for TLS 1.2 and TLS 1.3

[PATCH v2 0/4] DT related fixes for RISC-V UEFI
 2020-03-14  0:55 UTC  (10+ messages)
` [PATCH v2 1/4] riscv: Add boot hartid to Device tree
` [PATCH v2 2/4] cmd: bootefi: Parse reserved-memory node from DT
` [PATCH v2 3/4] riscv: Provide a mechanism for riscv boards to parse reserved memory
` [PATCH v2 4/4] riscv: Setup reserved-memory node for FU540

[PATCH 0/4] Add SS/HS-USB changes for Qualcomm SM8150 chipset
 2020-03-14  0:54 UTC  (5+ messages)
` [PATCH 1/4] dt-bindings: phy: Add binding for qcom,usb-hs-7nm
` [PATCH 2/4] phy: qcom-snps: Add SNPS USB PHY driver for QCOM based SOCs
` [PATCH 3/4] phy: qcom-qmp: Add SM8150 QMP USB3 PHY support
` [PATCH 4/4] phy: qcom-qmp: Use proper PWRDOWN offset for sm8150 USB

[PATCH v3] Staging: media: imx: eliminate unused code
 2020-03-14  0:54 UTC  (2+ messages)

[PATCH v2] mm/sparse.c: Use kvmalloc_node/kvfree to alloc/free memmap for the classic sparse
 2020-03-14  0:53 UTC  (4+ messages)
` [PATCH v3] "

[Intel-gfx] [PATCH] drm/i915/gt: Restrict gen7 w/a batch to Haswell
 2020-03-14  0:45 UTC  (3+ messages)

[PATCHv8 05/15] remoteproc/omap: Add the rproc ops .da_to_va() implementation
 2020-03-14  0:43 UTC  (3+ messages)
` [PATCHv8 RESEND "

[PATCHv8 03/15] remoteproc/omap: Add a sanity check for DSP boot address alignment
 2020-03-14  0:43 UTC  (3+ messages)
` [PATCHv8 RESEND "

[PATCH v2 bpf-next] bpf: Document bpf_inspect drgn tool
 2020-03-14  0:39 UTC 

[PATCH v5 00/60] target/riscv: support vector extension v0.7.1
 2020-03-14  0:36 UTC  (13+ messages)
` [PATCH v5 05/60] target/riscv: add vector stride load and store instructions
` [PATCH v5 08/60] target/riscv: add vector amo operations

[PATCH bpf-next] bpf: Document bpf_inspect drgn tool
 2020-03-14  0:35 UTC  (3+ messages)

linux-next: build warning after merge of the akpm-current tree
 2020-03-14  0:35 UTC  (4+ messages)

[PATCH v2 bpf-next] selftests/bpf: fix nanosleep for real this time
 2020-03-14  0:34 UTC  (2+ messages)

[PATCH bpf] bpf: Sanitize the bpf_struct_ops tcp-cc name
 2020-03-14  0:31 UTC  (3+ messages)

[PATCH 0/1] Bluetooth: Prioritize sco traffic on slow interfaces
 2020-03-14  0:30 UTC  (4+ messages)
` [PATCH 1/1] Bluetooth: Prioritize SCO "

[PATCH] sched: Use RCU-sched in core-scheduling balancing logic
 2020-03-14  0:30 UTC  (2+ messages)

[PATCH 0/1] coredump: Fix null pointer dereference when kernel.core_pattern is "|"
 2020-03-14  0:28 UTC  (4+ messages)

[PATCH 0/9] Lock ordering documentation and annotation for lockdep
 2020-03-14  0:26 UTC  (6+ messages)
` [PATCH 3/9] pci/switchtec: Don't abuse completion wait queue for poll
` [PATCH 4/9] sched/swait: Prepare usage in completions

[PATCH v2 bpf-next] selftest/bpf: fix compilation warning in sockmap_parse_prog.c
 2020-03-14  0:25 UTC  (2+ messages)

[PATCH 0/9] user-mode: Prune build dependencies (part 2)
 2020-03-14  0:23 UTC  (3+ messages)
` [PATCH 2/9] qapi/misc: Move add_client command with chardev code

[PATCH v8 0/4] linux-user: generate syscall_nr.sh for RISC-V
 2020-03-14  0:18 UTC  (12+ messages)
` [PATCH v8 1/4] linux-user: Protect more syscalls
` [PATCH v8 2/4] linux-user/syscall: Add support for clock_gettime64/clock_settime64
` [PATCH v8 3/4] linux-user: Support futex_time64
` [PATCH v8 4/4] linux-user/riscv: Update the syscall_nr's to the 5.5 kernel

[PATCH 0/2] Drop some mis-uses of READA
 2020-03-14  0:19 UTC  (5+ messages)
` [PATCH 1/2] btrfs: do not use READA for running delayed refs
` [PATCH 2/2] btrfs: do not READA in build_backref_tree

[PULL] drm-intel-next for 5.7-rc1
 2020-03-14  0:15 UTC  (2+ messages)
` [Intel-gfx] "

[PATCH 0/8][v2] relocation error handling fixes
 2020-03-14  0:13 UTC  (6+ messages)
` [PATCH 4/8] btrfs: free the reloc_control in a consistent way

[PATCH nf-next 0/3] Netfilter egress hook
 2020-03-14  0:12 UTC  (5+ messages)
` [PATCH nf-next 3/3] netfilter: Introduce "

[PATCH bpf-next] selftests/bpf: fix nanosleep for real this time
 2020-03-14  0:10 UTC  (3+ messages)
` [Potential Spoof] "

[PATCH 0/4] usb-serial: xHCI and timeout fixes
 2020-03-14  0:07 UTC  (5+ messages)
` [PATCH 1/4] usb-serial: Move USB_TOKEN_IN into a helper function
` [PATCH 2/4] usb-serial: chunk data to wMaxPacketSize

[PATCH 0/5] kselftest: add fixture parameters
 2020-03-14  0:05 UTC  (14+ messages)
` [PATCH 1/5] selftests/seccomp: use correct FIXTURE macro
` [PATCH 2/5] kselftest: create fixture objects
` [PATCH 3/5] kselftest: run tests by fixture
` [PATCH 4/5] kselftest: add fixture parameters
` [PATCH 5/5] selftests: tls: run all tests for TLS 1.2 and TLS 1.3

[PATCH v7 kunit-next 0/4] kunit: add debugfs representation to show results
 2020-03-14  0:03 UTC  (4+ messages)
` [PATCH v7 kunit-next 3/4] kunit: subtests should be indented 4 spaces according to TAP

[PATCH] NFS: Remove superfluous kmap in nfs_readdir_xdr_to_array
 2020-03-14  0:00 UTC  (3+ messages)

[igt-dev] [PATCH i-g-t] test/perf: Add test to verify OA TLB invalidation
 2020-03-14  0:00 UTC 

[RFC][PATCH] dma-mapping: align default segment_boundary_mask with dma_mask
 2020-03-14  0:00 UTC  (2+ messages)

[PATCH bpf-next] selftest/bpf: fix compilation warning in sockmap_parse_prog.c
 2020-03-13 23:58 UTC  (3+ messages)
` [Potential Spoof] "

Mailing list platform change March 20th
 2020-03-13 23:58 UTC  (2+ messages)

[PATCH] x86/vector: Allow to free vector for managed IRQ
 2020-03-13 23:54 UTC  (2+ messages)

[PATCH] linux-user: Update TASK_UNMAPPED_BASE for aarch64
 2020-03-13 23:52 UTC  (3+ messages)

Git performance on large repository on OS X is slow without core.preloadindex=false
 2020-03-13 23:52 UTC 

Endpoint address dns resolution - option to prefer IPv6 or IPv4
 2020-03-13 14:52 UTC 

[PATCH] ARM: qcom: Disable i2c device on gsbi4 for ipq806x
 2020-03-13 23:46 UTC  (4+ messages)
  ` R: "

[GIT PULL] SCSI fixes for 5.6-rc5
 2020-03-13 23:45 UTC  (2+ messages)

[Xen-devel] [XEN PATCH v3 0/2] xen/arm: Configure early printk via Kconfig
 2020-03-13 23:37 UTC  (5+ messages)
` [Xen-devel] [XEN PATCH v3 2/2] "

[dpdk-dev] [PATCH v3 0/7] MinGW-w64 support
 2020-03-13 23:38 UTC  (5+ messages)
` [dpdk-dev] [PATCH v4 "
  ` [dpdk-dev] [PATCH v4 1/7] eal: introduce portable format attribute

[PATCH v3] selftests: Fix seccomp to support relocatable build (O=objdir)
 2020-03-13 23:38 UTC  (3+ messages)

[PATCH v4] Documentation: kunit: Make the KUnit documentation less UML-specific
 2020-03-13 23:36 UTC  (5+ messages)

pull-request: bpf-next 2020-03-13
 2020-03-13 23:35 UTC 

[patch] mm, oom: prevent soft lockup on memcg oom for UP systems
 2020-03-13 23:32 UTC  (6+ messages)

[PATCH] platform/chrome: wilco_ec: Provide correct output format to 'h1_gpio' file
 2020-03-13 23:27 UTC 

[PATCH bpf-next v2] selftests/bpf: Fix spurious failures in accept due to EAGAIN
 2020-03-13 23:32 UTC  (3+ messages)

[PATCH v2 0/4] module autoloading fixes and cleanups
 2020-03-13 23:31 UTC  (6+ messages)
` [PATCH v2 3/4] docs: admin-guide: document the kernel.modprobe sysctl

[MPTCP] Re: [PATCH] tcp: mptcp: use mptcp receive buffer space to select rcv window
 2020-03-13 23:30 UTC 

[PATCH v3] ia64: replace setup_irq() by request_irq()
 2020-03-13 23:28 UTC  (4+ messages)
` [PATCH v4] "

[PATCH 0/2] radix-tree: fix some errors in comment
 2020-03-13 23:18 UTC  (7+ messages)
` [PATCH 1/2] radix-tree: fix kernel-doc for radix_tree_find_next_bit
` [PATCH 2/2] radix-tree: fix a typo

[patch part-II V2 00/13] x86/entry: Consolidation - Part II (syscalls)
 2020-03-13 23:17 UTC  (4+ messages)
` [patch part-II V2 07/13] x86/entry: Move irq tracing on syscall entry to C-code


This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.