All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4.
@ 2010-09-13 19:03 Paul Menzel
  2010-09-13 20:44 ` Khem Raj
  0 siblings, 1 reply; 7+ messages in thread
From: Paul Menzel @ 2010-09-13 19:03 UTC (permalink / raw)
  To: openembedded-devel

[-- Attachment #1: Type: text/plain, Size: 1311 bytes --]

Date: Mon, 13 Sep 2010 20:53:48 +0200

Cairo 1.10.0 was added in 1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d [1] and requires Pixman 0.18.4. This fixes at least the distribution Minimal which does not set the version of cairo explicitly.


[1] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d
[2] http://cgit.freedesktop.org/cairo/commit/?id=8127f1f5d52bb716dbd70efe096894f2a542f4a9

Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
---
 .../preferred-xorg-versions-X11R7.5-latest.inc     |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc b/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc
index 3c9aac0..634265e 100644
--- a/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc
+++ b/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc
@@ -108,7 +108,7 @@ PREFERRED_VERSION_libxxf86misc ?= "1.0.2"
 PREFERRED_VERSION_liblbxutil ?= "1.1.0"
 PREFERRED_VERSION_liboldx ?= "1.0.1"
 PREFERRED_VERSION_libxkbui ?= "1.0.2"
-PREFERRED_VERSION_pixman ?= "0.16.2"
+PREFERRED_VERSION_pixman ?= "0.18.4"
 #proto
 PREFERRED_VERSION_evieext ?= "1.1.0"
 PREFERRED_VERSION_fontcacheproto ?= "0.1.3"
-- 
1.7.1


[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 205 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4.
  2010-09-13 19:03 [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4 Paul Menzel
@ 2010-09-13 20:44 ` Khem Raj
  2010-09-14 13:17   ` Frans Meulenbroeks
  0 siblings, 1 reply; 7+ messages in thread
From: Khem Raj @ 2010-09-13 20:44 UTC (permalink / raw)
  To: openembedded-devel

On Mon, Sep 13, 2010 at 12:03 PM, Paul Menzel
<paulepanter@users.sourceforge.net> wrote:
> Date: Mon, 13 Sep 2010 20:53:48 +0200
>
> Cairo 1.10.0 was added in 1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d [1] and requires Pixman 0.18.4. This fixes at least the distribution Minimal which does not set the version of cairo explicitly.
>
>
> [1] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d
> [2] http://cgit.freedesktop.org/cairo/commit/?id=8127f1f5d52bb716dbd70efe096894f2a542f4a9
>
> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>

Acked-by: Khem Raj <raj.khem@gmail.com>

> ---
>  .../preferred-xorg-versions-X11R7.5-latest.inc     |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc b/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc
> index 3c9aac0..634265e 100644
> --- a/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc
> +++ b/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc
> @@ -108,7 +108,7 @@ PREFERRED_VERSION_libxxf86misc ?= "1.0.2"
>  PREFERRED_VERSION_liblbxutil ?= "1.1.0"
>  PREFERRED_VERSION_liboldx ?= "1.0.1"
>  PREFERRED_VERSION_libxkbui ?= "1.0.2"
> -PREFERRED_VERSION_pixman ?= "0.16.2"
> +PREFERRED_VERSION_pixman ?= "0.18.4"
>  #proto
>  PREFERRED_VERSION_evieext ?= "1.1.0"
>  PREFERRED_VERSION_fontcacheproto ?= "0.1.3"
> --
> 1.7.1
>
>
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
>
>



-- 
-Khem



^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4.
  2010-09-13 20:44 ` Khem Raj
@ 2010-09-14 13:17   ` Frans Meulenbroeks
  2010-09-14 20:29     ` Paul Menzel
  0 siblings, 1 reply; 7+ messages in thread
From: Frans Meulenbroeks @ 2010-09-14 13:17 UTC (permalink / raw)
  To: openembedded-devel

2010/9/13 Khem Raj <raj.khem@gmail.com>:
> On Mon, Sep 13, 2010 at 12:03 PM, Paul Menzel
> <paulepanter@users.sourceforge.net> wrote:
>> Date: Mon, 13 Sep 2010 20:53:48 +0200
>>
>> Cairo 1.10.0 was added in 1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d [1] and requires Pixman 0.18.4. This fixes at least the distribution Minimal which does not set the version of cairo explicitly.
>>
>>
>> [1] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d
>> [2] http://cgit.freedesktop.org/cairo/commit/?id=8127f1f5d52bb716dbd70efe096894f2a542f4a9
>>
>> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
>
> Acked-by: Khem Raj <raj.khem@gmail.com>

Paul, thanks for the fix!

Acked-by: Frans Meulenbroeks <frans.meulenbroeks@gmail.com>

>
>> ---
>>  .../preferred-xorg-versions-X11R7.5-latest.inc     |    2 +-
>>  1 files changed, 1 insertions(+), 1 deletions(-)
>>
>> diff --git a/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc b/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc
>> index 3c9aac0..634265e 100644
>> --- a/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc
>> +++ b/conf/distro/include/preferred-xorg-versions-X11R7.5-latest.inc
>> @@ -108,7 +108,7 @@ PREFERRED_VERSION_libxxf86misc ?= "1.0.2"
>>  PREFERRED_VERSION_liblbxutil ?= "1.1.0"
>>  PREFERRED_VERSION_liboldx ?= "1.0.1"
>>  PREFERRED_VERSION_libxkbui ?= "1.0.2"
>> -PREFERRED_VERSION_pixman ?= "0.16.2"
>> +PREFERRED_VERSION_pixman ?= "0.18.4"
>>  #proto
>>  PREFERRED_VERSION_evieext ?= "1.1.0"
>>  PREFERRED_VERSION_fontcacheproto ?= "0.1.3"
>> --
>> 1.7.1
>>
>>
>> _______________________________________________
>> Openembedded-devel mailing list
>> Openembedded-devel@lists.openembedded.org
>> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
>>
>>
>
>
>
> --
> -Khem
>
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
>



^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4.
  2010-09-14 13:17   ` Frans Meulenbroeks
@ 2010-09-14 20:29     ` Paul Menzel
  2010-09-14 22:32       ` pixman 0.18.4: `do_compile()` fails with minimal-uclibc: `../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'` (was: Re: [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4.) Paul Menzel
  0 siblings, 1 reply; 7+ messages in thread
From: Paul Menzel @ 2010-09-14 20:29 UTC (permalink / raw)
  To: openembedded-devel; +Cc: Leon Woestenberg

[-- Attachment #1: Type: text/plain, Size: 1636 bytes --]

Am Dienstag, den 14.09.2010, 15:17 +0200 schrieb Frans Meulenbroeks:
> 2010/9/13 Khem Raj <raj.khem@gmail.com>:
> > On Mon, Sep 13, 2010 at 12:03 PM, Paul Menzel <paulepanter@users.sourceforge.net> wrote:
> >> Date: Mon, 13 Sep 2010 20:53:48 +0200
> >>
> >> Cairo 1.10.0 was added in 1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d [1] and requires Pixman 0.18.4. This fixes at least the distribution Minimal which does not set the version of cairo explicitly.
> >>
> >>
> >> [1] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d
> >> [2] http://cgit.freedesktop.org/cairo/commit/?id=8127f1f5d52bb716dbd70efe096894f2a542f4a9
> >>
> >> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
> >
> > Acked-by: Khem Raj <raj.khem@gmail.com>
> 
> Paul, thanks for the fix!
> 
> Acked-by: Frans Meulenbroeks <frans.meulenbroeks@gmail.com>

Leon committed the same in f68f811ed20c32d3fb7c71fb41484ae6dd9908fc [3].

(Leon, I know it is a simple fix and it was probably easier to not apply
this patch but to change it yourself. (`pw-am.sh` [4] should have made
it easy.) But I spent some minutes to compose the commit message to
comply to the commit policy [5]. So it would have been nice if this had
been included. No, big deal though. Thanks again for fixing it in the
repository.)


Thanks,

Paul


[3] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=f68f811ed20c32d3fb7c71fb41484ae6dd9908fc
[4] http://cgit.openembedded.org/cgit.cgi/openembedded/tree/contrib/patchwork/pw-am.sh
[5] http://wiki.openembedded.net/index.php/Commit_Policy

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 205 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* pixman 0.18.4: `do_compile()` fails with minimal-uclibc: `../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'` (was: Re: [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4.)
  2010-09-14 20:29     ` Paul Menzel
@ 2010-09-14 22:32       ` Paul Menzel
  2010-09-14 22:49         ` Khem Raj
  0 siblings, 1 reply; 7+ messages in thread
From: Paul Menzel @ 2010-09-14 22:32 UTC (permalink / raw)
  To: openembedded-devel

[-- Attachment #1: Type: text/plain, Size: 2594 bytes --]

Am Dienstag, den 14.09.2010, 22:29 +0200 schrieb Paul Menzel:
> Am Dienstag, den 14.09.2010, 15:17 +0200 schrieb Frans Meulenbroeks:
> > 2010/9/13 Khem Raj <raj.khem@gmail.com>:
> > > On Mon, Sep 13, 2010 at 12:03 PM, Paul Menzel <paulepanter@users.sourceforge.net> wrote:
> > >> Date: Mon, 13 Sep 2010 20:53:48 +0200
> > >>
> > >> Cairo 1.10.0 was added in 1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d [1] and requires Pixman 0.18.4. This fixes at least the distribution Minimal which does not set the version of cairo explicitly.
> > >>
> > >>
> > >> [1] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d
> > >> [2] http://cgit.freedesktop.org/cairo/commit/?id=8127f1f5d52bb716dbd70efe096894f2a542f4a9
> > >>
> > >> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
> > >
> > > Acked-by: Khem Raj <raj.khem@gmail.com>
> > 
> > Paul, thanks for the fix!
> > 
> > Acked-by: Frans Meulenbroeks <frans.meulenbroeks@gmail.com>
> 
> Leon committed the same in f68f811ed20c32d3fb7c71fb41484ae6dd9908fc [3].

> [3] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=f68f811ed20c32d3fb7c71fb41484ae6dd9908fc

Unfortunately I just tested this patch with minimal-uclibc and it Pixman
0.18.4 fails with the following error when doing `bitbake
console-image`.

| […]
| /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/bin/ld: warning: libc.so, needed by /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/lib/libgcc_s.so.1, not found (try using -rpath or -rpath-link)
| ../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'
| collect2: ld returned 1 exit status
| make[2]: *** [a1-trap-test] Error 1
| make[2]: *** Waiting for unfinished jobs....
| /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/bin/ld: warning: libc.so, needed by /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/lib/libgcc_s.so.1, not found (try using -rpath or -rpath-link)
| ../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'
| collect2: ld returned 1 exit status
| make[2]: *** [region-test] Error 1
| […]


Please tell me, if I can provide more information. Thanks,

Paul

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 205 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: pixman 0.18.4: `do_compile()` fails with minimal-uclibc: `../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'` (was: Re: [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4.)
  2010-09-14 22:32       ` pixman 0.18.4: `do_compile()` fails with minimal-uclibc: `../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'` (was: Re: [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4.) Paul Menzel
@ 2010-09-14 22:49         ` Khem Raj
  2010-09-15 14:20           ` pixman 0.18.4: `do_compile()` fails with minimal-uclibc: `../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'` Paul Menzel
  0 siblings, 1 reply; 7+ messages in thread
From: Khem Raj @ 2010-09-14 22:49 UTC (permalink / raw)
  To: openembedded-devel

On Tue, Sep 14, 2010 at 3:32 PM, Paul Menzel
<paulepanter@users.sourceforge.net> wrote:
> Am Dienstag, den 14.09.2010, 22:29 +0200 schrieb Paul Menzel:
>> Am Dienstag, den 14.09.2010, 15:17 +0200 schrieb Frans Meulenbroeks:
>> > 2010/9/13 Khem Raj <raj.khem@gmail.com>:
>> > > On Mon, Sep 13, 2010 at 12:03 PM, Paul Menzel <paulepanter@users.sourceforge.net> wrote:
>> > >> Date: Mon, 13 Sep 2010 20:53:48 +0200
>> > >>
>> > >> Cairo 1.10.0 was added in 1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d [1] and requires Pixman 0.18.4. This fixes at least the distribution Minimal which does not set the version of cairo explicitly.
>> > >>
>> > >>
>> > >> [1] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=1d4c650b1d8dac6adee3d3d4208b81bc9b67bd3d
>> > >> [2] http://cgit.freedesktop.org/cairo/commit/?id=8127f1f5d52bb716dbd70efe096894f2a542f4a9
>> > >>
>> > >> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
>> > >
>> > > Acked-by: Khem Raj <raj.khem@gmail.com>
>> >
>> > Paul, thanks for the fix!
>> >
>> > Acked-by: Frans Meulenbroeks <frans.meulenbroeks@gmail.com>
>>
>> Leon committed the same in f68f811ed20c32d3fb7c71fb41484ae6dd9908fc [3].
>
>> [3] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=f68f811ed20c32d3fb7c71fb41484ae6dd9908fc
>
> Unfortunately I just tested this patch with minimal-uclibc and it Pixman
> 0.18.4 fails with the following error when doing `bitbake
> console-image`.
>
> | […]
> | /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/bin/ld: warning: libc.so, needed by /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/lib/libgcc_s.so.1, not found (try using -rpath or -rpath-link)
> | ../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'
> | collect2: ld returned 1 exit status
> | make[2]: *** [a1-trap-test] Error 1
> | make[2]: *** Waiting for unfinished jobs....
> | /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/bin/ld: warning: libc.so, needed by /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/lib/libgcc_s.so.1, not found (try using -rpath or -rpath-link)
> | ../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'
> | collect2: ld returned 1 exit status
> | make[2]: *** [region-test] Error 1
> | […]
>
>

It seems that TLS is needed/enabled by default for pixman. You can explore if
you can disable tls during configure like --disable-tls or some such option
if exists would be ideal then you can disable it for uclibc based builds.

Otherwise we have to patch it to work without TLS.

As a workaround you can use uclibc-git recipes which have TLS/NPTL enabled
by default and it should work with uclibc-git unmodified.

-Khem

> Please tell me, if I can provide more information. Thanks,
>
> Paul
>
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
>
>



-- 
-Khem



^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: pixman 0.18.4: `do_compile()` fails with minimal-uclibc: `../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'`
  2010-09-14 22:49         ` Khem Raj
@ 2010-09-15 14:20           ` Paul Menzel
  0 siblings, 0 replies; 7+ messages in thread
From: Paul Menzel @ 2010-09-15 14:20 UTC (permalink / raw)
  To: openembedded-devel

[-- Attachment #1: Type: text/plain, Size: 2428 bytes --]

Am Dienstag, den 14.09.2010, 15:49 -0700 schrieb Khem Raj:
> On Tue, Sep 14, 2010 at 3:32 PM, Paul Menzel wrote:
> > Am Dienstag, den 14.09.2010, 22:29 +0200 schrieb Paul Menzel:

[…]

> >> Leon committed the same in f68f811ed20c32d3fb7c71fb41484ae6dd9908fc [3].
> >
> >> [3] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=f68f811ed20c32d3fb7c71fb41484ae6dd9908fc
> >
> > Unfortunately I just tested this patch with minimal-uclibc and it Pixman
> > 0.18.4 fails with the following error when doing `bitbake
> > console-image`.
> >
> > | […]
> > | /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/bin/ld: warning: libc.so, needed by /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/lib/libgcc_s.so.1, not found (try using -rpath or -rpath-link)
> > | ../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'
> > | collect2: ld returned 1 exit status
> > | make[2]: *** [a1-trap-test] Error 1
> > | make[2]: *** Waiting for unfinished jobs....
> > | /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/bin/ld: warning: libc.so, needed by /oe/build-minimal-uclibc/minimal-uclibc-dev/sysroots/i686-linux/usr/armv7a/lib/gcc/arm-oe-linux-uclibceabi/4.4.4/../../../../arm-oe-linux-uclibceabi/lib/libgcc_s.so.1, not found (try using -rpath or -rpath-link)
> > | ../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'
> > | collect2: ld returned 1 exit status
> > | make[2]: *** [region-test] Error 1
> > | […]
> 
> It seems that TLS is needed/enabled by default for pixman. You can explore if
> you can disable tls during configure like --disable-tls or some such option
> if exists would be ideal then you can disable it for uclibc based builds.

I could not find a swith in the output of `./configure --help`.

> Otherwise we have to patch it to work without TLS.

On other option would be to pin an older cairo version for minimal until
uclibc is updated.

> As a workaround you can use uclibc-git recipes which have TLS/NPTL enabled
> by default and it should work with uclibc-git unmodified.

Yes this worked.

[…]


Thanks,

Paul

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 205 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2010-09-15 14:22 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-09-13 19:03 [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4 Paul Menzel
2010-09-13 20:44 ` Khem Raj
2010-09-14 13:17   ` Frans Meulenbroeks
2010-09-14 20:29     ` Paul Menzel
2010-09-14 22:32       ` pixman 0.18.4: `do_compile()` fails with minimal-uclibc: `../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'` (was: Re: [PATCH] preferred-xorg-versions-X11R7.5-latest.inc: Use Pixman 0.18.4.) Paul Menzel
2010-09-14 22:49         ` Khem Raj
2010-09-15 14:20           ` pixman 0.18.4: `do_compile()` fails with minimal-uclibc: `../pixman/.libs/libpixman-1.so: undefined reference to `__tls_get_addr'` Paul Menzel

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.