All of lore.kernel.org
 help / color / mirror / Atom feed
From: Pekka Enberg <penberg@kernel.org>
To: Ivan Bulatovic <combuster@gmx.com>
Cc: linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org,
	jbarnes@virtuousgeek.org, eric@anholt.net,
	chris@chris-wilson.co.uk
Subject: Re: i915: 2.6.36-rc2 wrong resolution on gdm start
Date: Tue, 24 Aug 2010 11:54:26 +0300	[thread overview]
Message-ID: <AANLkTikYjRQEvRD=6nYVO25yiUPPvEgMwejbMJzhVebm@mail.gmail.com> (raw)
In-Reply-To: <1282611655.2177.19.camel@localhost.localdomain>

On Tue, Aug 24, 2010 at 4:00 AM, Ivan Bulatovic <combuster@gmx.com> wrote:
> While in init3, resolution is native, KMS works fine, no problems at
> all. As soon as gdm starts it seems that TV1 output is recognized as
> connected even if it isn't so resolution on VGA output is degraded from
> native 1280x1024 to 1024x768 on startup.
>
> I've disabled LVDS output with video=LVDS-1:d because the cable looses
> connection in certain lid positions.
>
> 2.6.36-rc1 didn't have this issue, 2.6.36-rc2 did so I've bisected and
> it came down to this commit:
>
> 9d0498a2bf7455159b317f19531a3e5db2ecc9c4 is the first bad commit
> commit 9d0498a2bf7455159b317f19531a3e5db2ecc9c4
> Author: Jesse Barnes <jbarnes@virtuousgeek.org>
> Date:   Wed Aug 18 13:20:54 2010 -0700
>
>    drm/i915: wait for actual vblank, not just 20ms
>
> Waiting for a hard coded 20ms isn't always enough to make sure a vblank
> period has actually occurred, so add code to make sure we really have
> passed through a vblank period (or that the pipe is off when disabling).
>
> This prevents problems with mode setting and link training, and seems to
> fix a bug like https://bugs.freedesktop.org/show_bug.cgi?id=29278, but
> on an HP 8440p instead.  Hopefully also fixes
> https://bugs.freedesktop.org/show_bug.cgi?id=29141.
>
>    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
>    Signed-off-by: Eric Anholt <eric@anholt.net>
>
> :040000 040000 9941813d0f0bc4e141a87696d34f1d1b9087711b
> 2e407ad1d03b60f0e5b020313a8a63bd176b4005 M drivers
>
> I'm sending you dmesg, xorg and xrandr logs as attachements. GM965 on
> DELL Vostro 1310 is in question. Thanks,

On Tue, Aug 24, 2010 at 4:00 AM, Ivan Bulatovic <combuster@gmx.com> wrote:
> While in init3, resolution is native, KMS works fine, no problems at
> all. As soon as gdm starts it seems that TV1 output is recognized as
> connected even if it isn't so resolution on VGA output is degraded from
> native 1280x1024 to 1024x768 on startup.
>
> I've disabled LVDS output with video=LVDS-1:d because the cable looses
> connection in certain lid positions.
>
> 2.6.36-rc1 didn't have this issue, 2.6.36-rc2 did so I've bisected and
> it came down to this commit:
>
> 9d0498a2bf7455159b317f19531a3e5db2ecc9c4 is the first bad commit
> commit 9d0498a2bf7455159b317f19531a3e5db2ecc9c4
> Author: Jesse Barnes <jbarnes@virtuousgeek.org>
> Date:   Wed Aug 18 13:20:54 2010 -0700
>
>    drm/i915: wait for actual vblank, not just 20ms
>
> Waiting for a hard coded 20ms isn't always enough to make sure a vblank
> period has actually occurred, so add code to make sure we really have
> passed through a vblank period (or that the pipe is off when disabling).
>
> This prevents problems with mode setting and link training, and seems to
> fix a bug like https://bugs.freedesktop.org/show_bug.cgi?id=29278, but
> on an HP 8440p instead.  Hopefully also fixes
> https://bugs.freedesktop.org/show_bug.cgi?id=29141.
>
>    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
>    Signed-off-by: Eric Anholt <eric@anholt.net>
>
> :040000 040000 9941813d0f0bc4e141a87696d34f1d1b9087711b
> 2e407ad1d03b60f0e5b020313a8a63bd176b4005 M drivers
>
> I'm sending you dmesg, xorg and xrandr logs as attachements. GM965 on
> DELL Vostro 1310 is in question. Thanks,

FWIW, I saw this on my MacBook as well. I was debugging a boot time
oops at the time so I just changed screen resolution in Gnome to fix
it.

WARNING: multiple messages have this Message-ID
From: Pekka Enberg <penberg@kernel.org>
To: Ivan Bulatovic <combuster@gmx.com>
Cc: linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org
Subject: Re: i915: 2.6.36-rc2 wrong resolution on gdm start
Date: Tue, 24 Aug 2010 11:54:26 +0300	[thread overview]
Message-ID: <AANLkTikYjRQEvRD=6nYVO25yiUPPvEgMwejbMJzhVebm@mail.gmail.com> (raw)
In-Reply-To: <1282611655.2177.19.camel@localhost.localdomain>

On Tue, Aug 24, 2010 at 4:00 AM, Ivan Bulatovic <combuster@gmx.com> wrote:
> While in init3, resolution is native, KMS works fine, no problems at
> all. As soon as gdm starts it seems that TV1 output is recognized as
> connected even if it isn't so resolution on VGA output is degraded from
> native 1280x1024 to 1024x768 on startup.
>
> I've disabled LVDS output with video=LVDS-1:d because the cable looses
> connection in certain lid positions.
>
> 2.6.36-rc1 didn't have this issue, 2.6.36-rc2 did so I've bisected and
> it came down to this commit:
>
> 9d0498a2bf7455159b317f19531a3e5db2ecc9c4 is the first bad commit
> commit 9d0498a2bf7455159b317f19531a3e5db2ecc9c4
> Author: Jesse Barnes <jbarnes@virtuousgeek.org>
> Date:   Wed Aug 18 13:20:54 2010 -0700
>
>    drm/i915: wait for actual vblank, not just 20ms
>
> Waiting for a hard coded 20ms isn't always enough to make sure a vblank
> period has actually occurred, so add code to make sure we really have
> passed through a vblank period (or that the pipe is off when disabling).
>
> This prevents problems with mode setting and link training, and seems to
> fix a bug like https://bugs.freedesktop.org/show_bug.cgi?id=29278, but
> on an HP 8440p instead.  Hopefully also fixes
> https://bugs.freedesktop.org/show_bug.cgi?id=29141.
>
>    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
>    Signed-off-by: Eric Anholt <eric@anholt.net>
>
> :040000 040000 9941813d0f0bc4e141a87696d34f1d1b9087711b
> 2e407ad1d03b60f0e5b020313a8a63bd176b4005 M drivers
>
> I'm sending you dmesg, xorg and xrandr logs as attachements. GM965 on
> DELL Vostro 1310 is in question. Thanks,

On Tue, Aug 24, 2010 at 4:00 AM, Ivan Bulatovic <combuster@gmx.com> wrote:
> While in init3, resolution is native, KMS works fine, no problems at
> all. As soon as gdm starts it seems that TV1 output is recognized as
> connected even if it isn't so resolution on VGA output is degraded from
> native 1280x1024 to 1024x768 on startup.
>
> I've disabled LVDS output with video=LVDS-1:d because the cable looses
> connection in certain lid positions.
>
> 2.6.36-rc1 didn't have this issue, 2.6.36-rc2 did so I've bisected and
> it came down to this commit:
>
> 9d0498a2bf7455159b317f19531a3e5db2ecc9c4 is the first bad commit
> commit 9d0498a2bf7455159b317f19531a3e5db2ecc9c4
> Author: Jesse Barnes <jbarnes@virtuousgeek.org>
> Date:   Wed Aug 18 13:20:54 2010 -0700
>
>    drm/i915: wait for actual vblank, not just 20ms
>
> Waiting for a hard coded 20ms isn't always enough to make sure a vblank
> period has actually occurred, so add code to make sure we really have
> passed through a vblank period (or that the pipe is off when disabling).
>
> This prevents problems with mode setting and link training, and seems to
> fix a bug like https://bugs.freedesktop.org/show_bug.cgi?id=29278, but
> on an HP 8440p instead.  Hopefully also fixes
> https://bugs.freedesktop.org/show_bug.cgi?id=29141.
>
>    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
>    Signed-off-by: Eric Anholt <eric@anholt.net>
>
> :040000 040000 9941813d0f0bc4e141a87696d34f1d1b9087711b
> 2e407ad1d03b60f0e5b020313a8a63bd176b4005 M drivers
>
> I'm sending you dmesg, xorg and xrandr logs as attachements. GM965 on
> DELL Vostro 1310 is in question. Thanks,

FWIW, I saw this on my MacBook as well. I was debugging a boot time
oops at the time so I just changed screen resolution in Gnome to fix
it.

  parent reply	other threads:[~2010-08-24  8:54 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-08-24  1:00 Ivan Bulatovic
2010-08-24  7:49 ` Chris Wilson
2010-08-24  7:49   ` Chris Wilson
2010-08-24  8:35   ` Ivan Bulatovic
2010-08-24  8:50     ` Chris Wilson
2010-08-24  8:50       ` Chris Wilson
2010-08-24  9:12       ` Ivan Bulatovic
2010-08-24  9:21         ` [PATCH] drm/i915/tv: Flush register writes before sleeping Chris Wilson
2010-08-24  9:21           ` Chris Wilson
2010-08-24 11:03           ` Ivan Bulatovic
2010-08-24 15:11             ` [PATCH] drm/i915/tv: After disabling the pipe, use wait_for_vblank_off() Chris Wilson
2010-08-24 21:08               ` Ivan Bulatovic
2010-08-24 21:52                 ` Chris Wilson
2010-08-24 23:00                   ` Ivan Bulatovic
2010-08-24 23:04                   ` Ivan Bulatovic
2010-08-24 23:05                     ` Jesse Barnes
2010-08-24 23:06                   ` Ivan Bulatovic
2010-08-25  8:15                     ` Sitsofe Wheeler
2010-08-25  9:17                       ` Ivan Bulatovic
2010-08-25  9:31                       ` Ivan Bulatovic
2010-08-25  9:51                     ` Kan-Ru Chen
2010-08-29 11:29         ` i915: 2.6.36-rc2 wrong resolution on gdm start Pekka Enberg
2010-08-29 13:37           ` Sitsofe Wheeler
2010-08-24  8:54 ` Pekka Enberg [this message]
2010-08-24  8:54   ` Pekka Enberg
2010-08-29 12:59 ` Maciej Rutecki
2010-08-29 12:59   ` Maciej Rutecki

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='AANLkTikYjRQEvRD=6nYVO25yiUPPvEgMwejbMJzhVebm@mail.gmail.com' \
    --to=penberg@kernel.org \
    --cc=chris@chris-wilson.co.uk \
    --cc=combuster@gmx.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=eric@anholt.net \
    --cc=jbarnes@virtuousgeek.org \
    --cc=linux-kernel@vger.kernel.org \
    --subject='Re: i915: 2.6.36-rc2 wrong resolution on gdm start' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.