From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756370AbbDJRt1 (ORCPT ); Fri, 10 Apr 2015 13:49:27 -0400 Received: from mail-ie0-f170.google.com ([209.85.223.170]:35912 "EHLO mail-ie0-f170.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756075AbbDJRtW (ORCPT ); Fri, 10 Apr 2015 13:49:22 -0400 MIME-Version: 1.0 In-Reply-To: <20150410111427.GA30477@gmail.com> References: <1428561611.3506.78.camel@j-VirtualBox> <20150409075311.GA4645@gmail.com> <20150409175652.GI6464@linux.vnet.ibm.com> <20150409183926.GM6464@linux.vnet.ibm.com> <20150410090051.GA28549@gmail.com> <20150410091252.GA27630@gmail.com> <20150410092152.GA21332@gmail.com> <20150410111427.GA30477@gmail.com> Date: Fri, 10 Apr 2015 10:49:21 -0700 X-Google-Sender-Auth: kdRTsQLnjGiIwzhKPXVxLiPPBwY Message-ID: Subject: Re: [PATCH] x86/uaccess: Implement get_kernel() From: Linus Torvalds To: Ingo Molnar Cc: "Paul E. McKenney" , Jason Low , Peter Zijlstra , Davidlohr Bueso , Tim Chen , Aswin Chandramouleeswaran , LKML Content-Type: text/plain; charset=UTF-8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Apr 10, 2015 at 4:14 AM, Ingo Molnar wrote: > >> >> The next patch will implement efficient __copy_from_kernel_inatomic() >> for x86. > > The patch below does that. Note, for simplicity I've changed the > interface to 'get_kernel()' (will propagate this through the other > patches as well). So I think this needs a couple of changes: - That "get_kernel()" name is not clear enough about what the issue is. I think it should make it clearer that it's an unsafe access that could fault, and that we don't want a user access. So maybe "get_kernel_stalepointer()" or something like that. - you're just re-implementing "__get_user_asm_ex()" afaik. Try to share the code, renaming it to be something common. - I think we should look at sharing the code for __get_user(). Could we do something like this: (a) implement the basic "load with exceptions" as __get_with_exception() (b) #define get_kernel_stalepointer() __get_with_exception (c) make "__get_user()" be "stac(); __get_with_exception(); clac()" - finally, I wonder what the exact semantics of "get_kernel_stalepointer()" should be. I could well imagine that what we should do is #ifdef CONFIG_DEBUG_PAGEALLOC #define get_kernel_stalepointer(x,ptr) ((x)=READ_ONCE(*(ptr)), 0) #else #define get_kernel_stalepointer(x,ptr) __get_with_exception(x,ptr) #endif because I think it's reasonable to require that the kernel pointer is _stale_, and not "invalid". IOW, guarantee that it *has* been a kernel pointer, and that the only reason it would trap is for DEBUG_PAGEALLOC. That last point might need to be verified with hotplug memory. I think hotplug memory does a stop_machine() or similar, but I'm not sure. Hmm? Linus