On Fri, Jul 30, 2021 at 3:47 PM Richard Purdie < richard.purdie@linuxfoundation.org> wrote: > This change updates the datastore to use the new override syntax using > colons instead of underscores exclusively. It is expected layers would > have to be converted to work with bitbake after this change. > > Supporting mixed syntax isn't possible, it is only feasible to have > one internal representation of overrides. > > Whilst we can't warn for every possible override that may be set in the > old format, show errors for _append/_prepend/_remove since those should > never be present. > Thanks! Already helped me to catch few cases which weren't converted automatically with the script: ERROR: meta-webosose/meta-webos/recipes-webos/com.webos.app.notification/ com.webos.app.notification.bb: Variable webos_configure_manifest_comment_remover contains an operation using the old override syntax. Please convert this layer/metadata before attempting to use with a newer bitbake. ERROR: meta-webosose/meta-webos/recipes-webos/libpmscore/libpmscore.bb: Variable do_generate_toolchain_file_append contains an operation using the old override syntax. Please convert this layer/metadata before attempting to use with a newer bitbake. ERROR: meta-webosose/meta-webos/recipes-webos/media-resource-calculator/ media-resource-calculator.bb: Variable do_generate_toolchain_file_append contains an operation using the old override syntax. Please convert this layer/metadata before attempting to use with a newer bitbake. ERROR: meta-webosose/meta-webos/recipes-webos/com.webos.app.videoplayer/ com.webos.app.videoplayer.bb: Variable webos_configure_manifest_comment_remover contains an operation using the old override syntax. Please convert this layer/metadata before attempting to use with a newer bitbake. ERROR: meta-webosose/meta-webos/recipes-webos/jemalloc/jemalloc.bb: Variable do_generate_toolchain_file_append contains an operation using the old override syntax. Please convert this layer/metadata before attempting to use with a newer bitbake. ERROR: oe-core/meta/recipes-kernel/linux/linux-yocto_5.4.bb: Variable do_deploy_links_append contains an operation using the old override syntax. Please convert this layer/metadata before attempting to use with a newer bitbake. ERROR: meta-webosose/meta-webos/recipes-webos/videooutputd/ com.webos.service.videooutput.bb: Variable do_generate_toolchain_file_append contains an operation using the old override syntax. Please convert this layer/metadata before attempting to use with a newer bitbake. ERROR: Failed to parse recipe: meta-webosose/meta-webos/recipes-webos/com.webos.app.notification/ com.webos.app.notification.bb ERROR: meta-webosose/meta-webos/recipes-webos/com.webos.service.tts/ com.webos.service.tts.bb: Variable do_generate_toolchain_file_append contains an operation using the old override syntax. Please convert this layer/metadata before attempting to use with a newer bitbake. The webos_configure_manifest_comment_remover is a false positive, but I don't mind renaming it to something else (if it can confuse he regexp, then person could get confused as well). And the other 2 are real issues: $ git grep do_generate_toolchain_file_append meta-webos/classes/webos_cmake.bbclass:do_generate_toolchain_file_append() { meta-webos/recipes-webos/db8/db8.bb:cmake_do_generate_toolchain_file_append() {