From mboxrd@z Thu Jan 1 00:00:00 1970 From: Santosh Shukla Subject: Re: [PATCH v6 1/8] eal: pci: add api to rd/wr pci bar region Date: Tue, 2 Feb 2016 09:44:14 +0530 Message-ID: References: <1454091717-32251-1-git-send-email-sshukla@mvista.com> <20160201134854.GE4257@yliu-dev.sh.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Cc: dev@dpdk.org To: Yuanhan Liu Return-path: Received: from mail-pf0-f176.google.com (mail-pf0-f176.google.com [209.85.192.176]) by dpdk.org (Postfix) with ESMTP id BCCE68D8F for ; Tue, 2 Feb 2016 05:14:14 +0100 (CET) Received: by mail-pf0-f176.google.com with SMTP id 65so95638991pfd.2 for ; Mon, 01 Feb 2016 20:14:14 -0800 (PST) In-Reply-To: <20160201134854.GE4257@yliu-dev.sh.intel.com> List-Id: patches and discussions about DPDK List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Mon, Feb 1, 2016 at 7:18 PM, Yuanhan Liu wrote: > On Fri, Jan 29, 2016 at 11:51:50PM +0530, Santosh Shukla wrote: >> Introducing below api for pci bar region rd/wr. >> Api's are: >> - rte_eal_pci_read_bar >> - rte_eal_pci_write_bar >> >> Signed-off-by: Santosh Shukla >> --- >> v5-->v6: >> - update api infor in rte_eal_version.map file >> suggested by david manchand. >> >> lib/librte_eal/bsdapp/eal/eal_pci.c | 19 ++++++++++++ >> lib/librte_eal/bsdapp/eal/rte_eal_version.map | 3 ++ >> lib/librte_eal/common/include/rte_pci.h | 38 +++++++++++++++++++++++ >> lib/librte_eal/linuxapp/eal/eal_pci.c | 34 ++++++++++++++++++++ >> lib/librte_eal/linuxapp/eal/eal_pci_init.h | 6 ++++ >> lib/librte_eal/linuxapp/eal/eal_pci_vfio.c | 28 +++++++++++++++++ >> lib/librte_eal/linuxapp/eal/rte_eal_version.map | 3 ++ >> 7 files changed, 131 insertions(+) >> >> diff --git a/lib/librte_eal/bsdapp/eal/eal_pci.c b/lib/librte_eal/bsdapp/eal/eal_pci.c >> index 95c32c1..2e535ea 100644 >> --- a/lib/librte_eal/bsdapp/eal/eal_pci.c >> +++ b/lib/librte_eal/bsdapp/eal/eal_pci.c > ... >> +int rte_eal_pci_read_bar(const struct rte_pci_device *device, >> + void *buf, size_t len, off_t offset, >> + int bar_idx) >> + >> +{ >> + const struct rte_intr_handle *intr_handle = &device->intr_handle; > > I'd suggest to reference this var inside pci_vfio_read/write_bar(), and > pass device as the parmater instead. > (Sorry for late reply, I was travelling on Monday.) Make sense. >> + >> + switch (device->kdrv) { >> + case RTE_KDRV_VFIO: >> + return pci_vfio_read_bar(intr_handle, buf, len, >> + offset, bar_idx); >> + default: >> + RTE_LOG(ERR, EAL, "write bar not supported by driver\n"); > ^^^^^ > typo. > Oh, r / write / read, right? sorry for typo error (:- > > BTW, I have a question about this API. Obviously, reading/writing bar > space is supported with UIO (when memory resource is mmapped). And I > know why you introduced such 2 APIs, for reading IO bar. > > So, here is the question: what are the 2 APIs for, for being gerneric > APIs to read/write bar spaces, or just to read IO bar spaces? If it's > former, the message is wrong; if it's later, you may better rename it > to rte_eal_pci_read/write_io_bar()? > Current use-case is virtio: It is used as io_bar which is first bar[1]. But implementation is generic, can be used to do rd/wr for other bar index too. Also vfio facilitate user to do rd/wr to pci_bars w/o mapping that bar, So apis will be useful for such cases in future. AFAIU: uio has read/write_config api only and Yes if bar region mapped then no need to do rd/wr, user can directly access the pci_memory. But use-case of this api entirely different: unmapped memory by application context i.e.. vfio_rd/wr-way {pread/pwrite-way}. Is above explanation convincing? Pl. let me know. [1] https://en.wikipedia.org/wiki/PCI_configuration_space (first bar offset 0x010) > David, what do you think of that? > > >> + return -1; >> + } >> +} >> + > ... >> +int >> +pci_vfio_read_bar(const struct rte_intr_handle *intr_handle, >> + void *buf, size_t len, off_t offs, int bar_idx) >> +{ >> + if (bar_idx < VFIO_PCI_BAR0_REGION_INDEX >> + || bar_idx > VFIO_PCI_BAR5_REGION_INDEX) { > > A minor nit: it's more nature to put the '||' at the end of expression, > instead of at the front: > > if (bar_idx < VFIO_PCI_BAR0_REGION_INDEX || > bar_idx > VFIO_PCI_BAR5_REGION_INDEX) { > > > --yliu