From mboxrd@z Thu Jan 1 00:00:00 1970 From: Deepa Dinamani Subject: Re: [PATCH 2/8] sockopt: Rename SO_TIMESTAMP* to SO_TIMESTAMP*_OLD Date: Fri, 30 Nov 2018 14:38:27 -0800 Message-ID: References: <20181124022035.17519-1-deepa.kernel@gmail.com> <20181124022035.17519-3-deepa.kernel@gmail.com> Mime-Version: 1.0 Content-Type: text/plain; charset="UTF-8" Return-path: In-Reply-To: Sender: netdev-owner@vger.kernel.org To: willemdebruijn.kernel@gmail.com Cc: "David S. Miller" , Linux Kernel Mailing List , Linux Network Devel Mailing List , Alexander Viro , Arnd Bergmann , y2038 Mailman List , Helge Deller , David Howells , "James E.J. Bottomley" , Ralf Baechle , rth@twiddle.net, linux-afs@lists.infradead.org, linux-alpha@vger.kernel.org, linux-arch , "open list:RALINK MIPS ARCHITECTURE" , Parisc List , linux-rdma@vger.kernel.org, sparclinux List-Id: linux-rdma@vger.kernel.org On Sat, Nov 24, 2018 at 7:59 PM Willem de Bruijn wrote: > > On Sat, Nov 24, 2018 at 3:58 AM Deepa Dinamani wrote: > > > > SO_TIMESTAMP, SO_TIMESTAMPNS and SO_TIMESTAMPING options, the > > way they are currently defined, are not y2038 safe. > > Subsequent patches in the series add new y2038 safe versions > > of these options which provide 64 bit timestamps on all > > architectures uniformly. > > Hence, rename existing options with OLD tag suffixes. > > Why do the existing interfaces have to be renamed when new interfaces are added? Existing options need to be renamed because of the macro below: #define SO_TIMESTAMP (sizeof(time_t) == sizeof(__kernel_long_t) ? \ SO_TIMESTAMP_OLD : SO_TIMESTAMP_NEW) SO_TIMESTAMP is now dependent on size of time_t because of the libc flag. -Deepa From mboxrd@z Thu Jan 1 00:00:00 1970 From: Deepa Dinamani Date: Fri, 30 Nov 2018 22:38:27 +0000 Subject: Re: [PATCH 2/8] sockopt: Rename SO_TIMESTAMP* to SO_TIMESTAMP*_OLD Message-Id: List-Id: References: <20181124022035.17519-1-deepa.kernel@gmail.com> <20181124022035.17519-3-deepa.kernel@gmail.com> In-Reply-To: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: willemdebruijn.kernel@gmail.com Cc: "David S. Miller" , Linux Kernel Mailing List , Linux Network Devel Mailing List , Alexander Viro , Arnd Bergmann , y2038 Mailman List , Helge Deller , David Howells , "James E.J. Bottomley" , Ralf Baechle , rth@twiddle.net, linux-afs@lists.infradead.org, linux-alpha@vger.kernel.org, linux-arch , "open list:RALINK MIPS ARCHITECTURE" , Parisc List , linux-rdma@vger.kernel.org, sparclinux On Sat, Nov 24, 2018 at 7:59 PM Willem de Bruijn wrote: > > On Sat, Nov 24, 2018 at 3:58 AM Deepa Dinamani wrote: > > > > SO_TIMESTAMP, SO_TIMESTAMPNS and SO_TIMESTAMPING options, the > > way they are currently defined, are not y2038 safe. > > Subsequent patches in the series add new y2038 safe versions > > of these options which provide 64 bit timestamps on all > > architectures uniformly. > > Hence, rename existing options with OLD tag suffixes. > > Why do the existing interfaces have to be renamed when new interfaces are added? Existing options need to be renamed because of the macro below: #define SO_TIMESTAMP (sizeof(time_t) = sizeof(__kernel_long_t) ? \ SO_TIMESTAMP_OLD : SO_TIMESTAMP_NEW) SO_TIMESTAMP is now dependent on size of time_t because of the libc flag. -Deepa