All of lore.kernel.org
 help / color / mirror / Atom feed
From: Paolo Bonzini <pbonzini@redhat.com>
To: Markus Armbruster <armbru@redhat.com>
Cc: "Wolf, Kevin" <kwolf@redhat.com>, qemu-devel <qemu-devel@nongnu.org>
Subject: Re: [PATCH 2/3] qom: move user_creatable_add_opts logic to vl.c and QAPIfy it
Date: Sat, 13 Mar 2021 11:05:25 +0100	[thread overview]
Message-ID: <CABgObfZbaqiEeNcm7XrEMAgAzp8_xrROFof3VuUKsfK1CCeTdA@mail.gmail.com> (raw)
In-Reply-To: <87im5vv0j4.fsf@dusky.pond.sub.org>

[-- Attachment #1: Type: text/plain, Size: 2466 bytes --]

I will use ObjectOptionsQueue like the typedef just above.

Paolo


Il sab 13 mar 2021, 10:57 Markus Armbruster <armbru@redhat.com> ha scritto:

> One more little thing...
>
> Paolo Bonzini <pbonzini@redhat.com> writes:
>
> > Emulators are currently using OptsVisitor (via user_creatable_add_opts)
> > to parse the -object command line option.  This has one extra feature,
> > compared to keyval, which is automatic conversion of integers to lists
> > as well as support for lists as repeated options:
> >
> >   -object
> memory-backend-ram,id=pc.ram,size=1048576000,host-nodes=0,policy=bind
> >
> > So we cannot replace OptsVisitor with keyval right now.  Still, this
> > patch moves the user_creatable_add_opts logic to vl.c since it is
> > not needed anywhere else, and makes it go through
> user_creatable_add_qapi.
> >
> > In order to minimize code changes, the predicate still takes a string.
> > This can be changed later to use the ObjectType QAPI enum directly.
> >
> > Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
> [...]
> > diff --git a/softmmu/vl.c b/softmmu/vl.c
> > index ff488ea3e7..b245e912e5 100644
> > --- a/softmmu/vl.c
> > +++ b/softmmu/vl.c
> > @@ -117,6 +117,7 @@
> >  #include "qapi/qapi-commands-block-core.h"
> >  #include "qapi/qapi-commands-migration.h"
> >  #include "qapi/qapi-commands-misc.h"
> > +#include "qapi/qapi-visit-qom.h"
> >  #include "qapi/qapi-commands-ui.h"
> >  #include "qapi/qmp/qerror.h"
> >  #include "sysemu/iothread.h"
> > @@ -132,10 +133,16 @@ typedef struct BlockdevOptionsQueueEntry {
> >
> >  typedef QSIMPLEQ_HEAD(, BlockdevOptionsQueueEntry) BlockdevOptionsQueue;
> >
> > +typedef struct ObjectOption {
> > +    ObjectOptions *opts;
> > +    QTAILQ_ENTRY(ObjectOption) next;
> > +} ObjectOption;
> > +
>
> The names feel awkward.
>
> ObjectOption represents a -object option.  Fair enough.
>
> ObjectOptions represents the "options" in its option argument.
>
> Confusing.  Calling the whole thing and one of its parts the same is a
> bad idea.
>
> I never liked calling the key=value things in option arguments
> "options".  They aren't CLI options, they are optional CLI option
> parameters.
>
> I also don't like calling so many different things "object" (QObject,
> Object, ObjectOption, ObjectOptions), but that feels out of scope here.
>
> Can we please rename ObjectOptions?
>
> A naming convention for CLI option argument types and boxed QMP command
> argument types would be nice.
>
> [...]
>
>

[-- Attachment #2: Type: text/html, Size: 3397 bytes --]

  reply	other threads:[~2021-03-13 10:06 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-11 17:24 [PATCH 0/3] vl: QAPIfy -object Paolo Bonzini
2021-03-11 17:24 ` [PATCH 1/3] tests: convert check-qom-proplist to keyval Paolo Bonzini
2021-03-11 18:29   ` Eric Blake
2021-03-12 10:21   ` Kevin Wolf
2021-03-11 17:24 ` [PATCH 2/3] qom: move user_creatable_add_opts logic to vl.c and QAPIfy it Paolo Bonzini
2021-03-11 18:37   ` Eric Blake
2021-03-12 10:18   ` Kevin Wolf
2021-03-13  9:35   ` Markus Armbruster
2021-03-13  9:40     ` Paolo Bonzini
2021-03-13 12:32       ` Markus Armbruster
2021-03-13  9:57   ` Markus Armbruster
2021-03-13 10:05     ` Paolo Bonzini [this message]
2021-03-11 17:24 ` [PATCH 3/3] vl: allow passing JSON to -object Paolo Bonzini
2021-03-11 18:38   ` Eric Blake
2021-03-12 10:21   ` Kevin Wolf
2021-03-13  9:41   ` Markus Armbruster
2021-03-11 17:39 ` [PATCH 0/3] vl: QAPIfy -object no-reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CABgObfZbaqiEeNcm7XrEMAgAzp8_xrROFof3VuUKsfK1CCeTdA@mail.gmail.com \
    --to=pbonzini@redhat.com \
    --cc=armbru@redhat.com \
    --cc=kwolf@redhat.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.