From mboxrd@z Thu Jan 1 00:00:00 1970 From: Sean Harte Subject: Re: [PATCH v6 4/8] ethdev: add GTP items to support flow API Date: Tue, 3 Oct 2017 09:56:58 +0100 Message-ID: References: <1506565054-67690-1-git-send-email-beilei.xing@intel.com> <1506662342-18966-1-git-send-email-beilei.xing@intel.com> <1506662342-18966-5-git-send-email-beilei.xing@intel.com> <94479800C636CB44BD422CB454846E0132038E26@SHSMSX101.ccr.corp.intel.com> <20171002122737.GK3871@6wind.com> Mime-Version: 1.0 Content-Type: text/plain; charset="UTF-8" Cc: "Xing, Beilei" , "Wu, Jingjing" , "Chilikin, Andrey" , "dev@dpdk.org" To: Adrien Mazarguil Return-path: Received: from mail-oi0-f53.google.com (mail-oi0-f53.google.com [209.85.218.53]) by dpdk.org (Postfix) with ESMTP id AD2A01B2E6 for ; Tue, 3 Oct 2017 10:56:59 +0200 (CEST) Received: by mail-oi0-f53.google.com with SMTP id v9so987810oif.13 for ; Tue, 03 Oct 2017 01:56:59 -0700 (PDT) In-Reply-To: <20171002122737.GK3871@6wind.com> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On 2 October 2017 at 13:27, Adrien Mazarguil wrote: > On Fri, Sep 29, 2017 at 10:29:55AM +0100, Sean Harte wrote: >> On 29 September 2017 at 09:54, Xing, Beilei wrote: > >> >> > /** >> >> > + * RTE_FLOW_ITEM_TYPE_GTP. >> >> > + * >> >> > + * Matches a GTPv1 header. >> >> > + */ >> >> > +struct rte_flow_item_gtp { >> >> > + /** >> >> > + * Version (3b), protocol type (1b), reserved (1b), >> >> > + * Extension header flag (1b), >> >> > + * Sequence number flag (1b), >> >> > + * N-PDU number flag (1b). >> >> > + */ >> >> > + uint8_t v_pt_rsv_flags; >> >> > + uint8_t msg_type; /**< Message type. */ >> >> > + rte_be16_t msg_len; /**< Message length. */ >> >> > + rte_be32_t teid; /**< Tunnel endpoint identifier. */ }; >> >> >> >> In future, you might add support for GTPv2 (which is used since LTE). >> >> Maybe this structure should have v1 in its name to avoid confusion? >> > >> > I considered it before. But I think we can modify it when we support GTPv2 in future, and keep concise 'GTP' currently:) since I have described it matches v1 header. >> > >> >> You could rename v_pt_rsv_flags to version_flags to avoid some future >> code changes to support GTPv2. There's still the issue that not all >> GTPv2 messages have a TEID though. > > Although they have the same size, the header of these two protocols > obviously differs. My suggestion would be to go with a separate GTPv2 > pattern item using its own dedicated structure instead. > > -- > Adrien Mazarguil > 6WIND The 1st four bytes are the same (flags in first byte have different meanings, but the bits indicating the version are in the same location). After that, different fields in each version are optional, and the headers have variable size. A single structure could be used if the first field is renamed to something like "version_flags", and then check that the teid field in item->mask is not set if ((version_flags >> 5 == 2) && ((version_flags >> 4) & 1) == 1). If there's going to be two structures, it would be good to put v1 and v2 in the names, in my opinion.