From mboxrd@z Thu Jan 1 00:00:00 1970 From: Sean Harte Subject: Re: [PATCH v6 4/8] ethdev: add GTP items to support flow API Date: Fri, 29 Sep 2017 10:29:55 +0100 Message-ID: References: <1506565054-67690-1-git-send-email-beilei.xing@intel.com> <1506662342-18966-1-git-send-email-beilei.xing@intel.com> <1506662342-18966-5-git-send-email-beilei.xing@intel.com> <94479800C636CB44BD422CB454846E0132038E26@SHSMSX101.ccr.corp.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="UTF-8" Cc: "Wu, Jingjing" , "Chilikin, Andrey" , "dev@dpdk.org" To: "Xing, Beilei" Return-path: Received: from mail-oi0-f65.google.com (mail-oi0-f65.google.com [209.85.218.65]) by dpdk.org (Postfix) with ESMTP id B6D061B202 for ; Fri, 29 Sep 2017 11:29:56 +0200 (CEST) Received: by mail-oi0-f65.google.com with SMTP id l81so420434oib.1 for ; Fri, 29 Sep 2017 02:29:56 -0700 (PDT) In-Reply-To: <94479800C636CB44BD422CB454846E0132038E26@SHSMSX101.ccr.corp.intel.com> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On 29 September 2017 at 09:54, Xing, Beilei wrote: > > >> -----Original Message----- >> From: Sean Harte [mailto:seanbh@gmail.com] >> Sent: Friday, September 29, 2017 4:15 PM >> To: Xing, Beilei >> Cc: Wu, Jingjing ; Chilikin, Andrey >> ; dev@dpdk.org >> Subject: Re: [dpdk-dev] [PATCH v6 4/8] ethdev: add GTP items to support >> flow API >> >> On 29 September 2017 at 06:18, Beilei Xing wrote: >> > This patch adds GTP, GTPC and GTPU items for generic flow API, and >> > also exposes item fields through the flow command. >> > >> > Signed-off-by: Beilei Xing >> > Acked-by: Adrien Mazarguil >> > --- >> > app/test-pmd/cmdline_flow.c | 40 ++++++++++++++++++++++ >> > app/test-pmd/config.c | 3 ++ >> > doc/guides/prog_guide/rte_flow.rst | 17 ++++++++++ >> > doc/guides/testpmd_app_ug/testpmd_funcs.rst | 4 +++ >> > lib/librte_ether/rte_flow.h | 52 >> +++++++++++++++++++++++++++++ >> > 5 files changed, 116 insertions(+) >> >> >> >> > /** >> > + * RTE_FLOW_ITEM_TYPE_GTP. >> > + * >> > + * Matches a GTPv1 header. >> > + */ >> > +struct rte_flow_item_gtp { >> > + /** >> > + * Version (3b), protocol type (1b), reserved (1b), >> > + * Extension header flag (1b), >> > + * Sequence number flag (1b), >> > + * N-PDU number flag (1b). >> > + */ >> > + uint8_t v_pt_rsv_flags; >> > + uint8_t msg_type; /**< Message type. */ >> > + rte_be16_t msg_len; /**< Message length. */ >> > + rte_be32_t teid; /**< Tunnel endpoint identifier. */ }; >> >> In future, you might add support for GTPv2 (which is used since LTE). >> Maybe this structure should have v1 in its name to avoid confusion? > > I considered it before. But I think we can modify it when we support GTPv2 in future, and keep concise 'GTP' currently:) since I have described it matches v1 header. > You could rename v_pt_rsv_flags to version_flags to avoid some future code changes to support GTPv2. There's still the issue that not all GTPv2 messages have a TEID though. >> >> > + >> > +/** Default mask for RTE_FLOW_ITEM_TYPE_GTP. */ #ifndef __cplusplus >> > +static const struct rte_flow_item_gtp rte_flow_item_gtp_mask = { >> > + .teid = RTE_BE32(0xffffffff), >> > +}; >> > +#endif >> > + >> > +/** >> > * Matching pattern item definition. >> > * >> > * A pattern is formed by stacking items starting from the lowest >> > protocol >> > -- >> > 2.5.5 >> >