All of lore.kernel.org
 help / color / mirror / Atom feed
From: Roy Franz <roy.franz@linaro.org>
To: Jan Beulich <JBeulich@suse.com>
Cc: keir <keir@xen.org>, Ian Campbell <ian.campbell@citrix.com>,
	tim <tim@xen.org>, xen-devel <xen-devel@lists.xen.org>,
	Stefano Stabellini <stefano.stabellini@citrix.com>,
	linaro-uefi <linaro-uefi@lists.linaro.org>,
	Fu Wei <fu.wei@linaro.org>
Subject: Re: [PATCH V2 04/12] Refactor read_file() so it can be shared.
Date: Wed, 6 Aug 2014 11:38:09 -0700	[thread overview]
Message-ID: <CAFECyb-S38iVd8f=iT_Qk4OMgdb8hO47z1dKVyJP33wf1DpXLA@mail.gmail.com> (raw)
In-Reply-To: <53D0CD3F02000078000255D5@mail.emea.novell.com>

On Thu, Jul 24, 2014 at 12:09 AM, Jan Beulich <JBeulich@suse.com> wrote:
>>>> On 22.07.14 at 02:43, <roy.franz@linaro.org> wrote:
>> The read_file() function updated some multiboot specific data structures
>> as it was loading a file.  These changes make read_file() more generic,
>> and create a load_file() wrapper for x86 that updates the multiboot
>> data structures.  read_file() no longer does special handling of
>> the configuration file, as this was only needed to avoid adding
>> it to the multiboot structures.  read_file() and load_file() return
>> error codes rather than directly exiting on error to facilicate
>> sharing.  Different architectures may require different max allocation
>> addresses so take that as an argument.
>
> Unless you expect an architecture to pass in different values on
> different invocations this clearly can be a #define rather than a
> function parameter.
I'll remove the argument - Ian's module freeing patch removes the need
for this.

>
>> @@ -405,12 +399,21 @@ static bool_t __init read_file(EFI_FILE_HANDLE dir_handle, CHAR16 *name,
>>
>>      if ( what )
>>      {
>> -        PrintErr(what);
>> -        PrintErr(L" failed for ");
>> -        PrintErrMesgExit(name, ret);
>> +        PrintErrMesg(what, ret);
>> +        PrintErr(L"Unable to load file");
>
> Is it intentional to make the message less useful by dripping the
> printing of the file name?

No, I have fixed this.
>
>> +        return 0;
>> +    }
>> +    else
>
> No need for an "else" after an unconditional "return" in the "if"
> branch.
>
>> @@ -470,6 +473,21 @@ static char *__init get_value(const struct file *cfg, const char *section,
>>      }
>>      return NULL;
>>  }
>> +/* Only call with non-config files. */
>
> Missing blank line before this comment.
>
>> +bool_t __init load_file(EFI_FILE_HANDLE dir_handle, CHAR16 *name,
>> +                               struct file *file)
>> +{
>> +    EFI_PHYSICAL_ADDRESS max = min(1UL << (32 + PAGE_SHIFT),
>> +                                   HYPERVISOR_VIRT_END - DIRECTMAP_VIRT_START);
>> +    if ( read_file(dir_handle, name, file, max) )
>
> Missing blank line between declaration and first statement.

Fixed this and above issues

>
>> @@ -896,16 +921,20 @@ efi_start(EFI_HANDLE ImageHandle, EFI_SYSTEM_TABLE *SystemTable)
>>      {
>>          microcode_set_module(mbi.mods_count);
>>          split_value(name.s);
>> -        read_file(dir_handle, s2w(&name), &ucode);
>> +        load_ok = load_file(dir_handle, s2w(&name), &ucode);
>>          efi_bs->FreePool(name.w);
>> +        if ( !load_ok )
>> +            blexit(L"Unable to load ucode image.");
>>      }
>>
>>      name.s = get_value(&cfg, section.s, "xsm");
>>      if ( name.s )
>>      {
>>          split_value(name.s);
>> -        read_file(dir_handle, s2w(&name), &xsm);
>> +        load_ok = load_file(dir_handle, s2w(&name), &xsm);
>>          efi_bs->FreePool(name.w);
>> +        if ( !load_ok )
>> +            blexit(L"Unable to load ucode image.");
>
> Apart from the same comment made on an earlier patch - no need
> for an extra message here when the called function already printed
> one - this is a copy'n'paste mistake: You mean XSM instead of ucode
> here.

Fixed, and I'll review redundant messages.
>
> Jan
>

  reply	other threads:[~2014-08-06 18:38 UTC|newest]

Thread overview: 50+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-07-22  0:43 [PATCH V2 00/12] arm64 EFI stub Roy Franz
2014-07-22  0:43 ` [PATCH V2 01/12] Create efi-shared.[ch], and move string functions Roy Franz
2014-07-23 16:31   ` Jan Beulich
2014-07-28 15:41     ` Ian Campbell
2014-07-28 15:52       ` Jan Beulich
2014-07-28 15:56         ` Ian Campbell
2014-07-28 16:00           ` Jan Beulich
2014-07-28 16:04             ` Ian Campbell
2014-07-28 16:10               ` Jan Beulich
2014-08-06 23:55                 ` Roy Franz
2014-08-07  6:17                   ` Jan Beulich
2014-08-09  0:27                     ` Roy Franz
2014-08-06 23:42     ` Roy Franz
2014-07-22  0:43 ` [PATCH V2 02/12] rename printErrMsg to PrintErrMesgExit Roy Franz
2014-07-23 16:33   ` Jan Beulich
2014-07-22  0:43 ` [PATCH V2 03/12] Refactor get_parent_handle for sharing Roy Franz
2014-07-23 16:37   ` Jan Beulich
2014-07-22  0:43 ` [PATCH V2 04/12] Refactor read_file() so it can be shared Roy Franz
2014-07-24  7:09   ` Jan Beulich
2014-08-06 18:38     ` Roy Franz [this message]
2014-08-07  6:20       ` Jan Beulich
2014-08-07 17:26         ` Roy Franz
2014-07-22  0:43 ` [PATCH V2 05/12] replace split_value() with truncate_string() Roy Franz
2014-07-24  7:19   ` Jan Beulich
2014-08-06 22:37     ` Roy Franz
2014-08-07  6:24       ` Jan Beulich
2014-08-18 23:38         ` Roy Franz
2014-08-19 12:56           ` Jan Beulich
2014-07-22  0:43 ` [PATCH V2 06/12] add read_config_file() function for XEN EFI config file Roy Franz
2014-07-24  7:32   ` Jan Beulich
2014-08-06 22:42     ` Roy Franz
2014-07-22  0:43 ` [PATCH V2 07/12] create handle_cmdline() function Roy Franz
2014-07-24  7:36   ` Jan Beulich
2014-07-28 15:44     ` Ian Campbell
2014-07-28 15:57       ` Jan Beulich
2014-07-22  0:43 ` [PATCH V2 08/12] Refactor get_argv() for sharing Roy Franz
2014-07-24  7:38   ` Jan Beulich
2014-07-22  0:43 ` [PATCH V2 09/12] Move shared EFI functions to efi-shared.c Roy Franz
2014-07-22  0:43 ` [PATCH V2 10/12] add arm64 cache flushing code from linux Roy Franz
2014-07-28 15:53   ` Ian Campbell
2014-07-28 16:24     ` Ian Campbell
2014-07-22  0:43 ` [PATCH V2 11/12] Add fdt_create_empty_tree() function Roy Franz
2014-07-22 16:36   ` [Linaro-uefi] " Julien Grall
2014-07-22 17:12     ` Roy Franz
2014-07-22 17:15       ` Julien Grall
2014-07-23  9:58         ` Ian Campbell
2014-07-23 16:15           ` Roy Franz
2014-07-22  0:43 ` [PATCH V2 12/12] Add EFI stub for arm64 Roy Franz
2014-07-29  9:46   ` Ian Campbell
2014-07-28 15:30 ` [PATCH V2 00/12] arm64 EFI stub Ian Campbell

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAFECyb-S38iVd8f=iT_Qk4OMgdb8hO47z1dKVyJP33wf1DpXLA@mail.gmail.com' \
    --to=roy.franz@linaro.org \
    --cc=JBeulich@suse.com \
    --cc=fu.wei@linaro.org \
    --cc=ian.campbell@citrix.com \
    --cc=keir@xen.org \
    --cc=linaro-uefi@lists.linaro.org \
    --cc=stefano.stabellini@citrix.com \
    --cc=tim@xen.org \
    --cc=xen-devel@lists.xen.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.