From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S965397AbcKKWYI (ORCPT ); Fri, 11 Nov 2016 17:24:08 -0500 Received: from mail-wm0-f43.google.com ([74.125.82.43]:38629 "EHLO mail-wm0-f43.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932616AbcKKWYF (ORCPT ); Fri, 11 Nov 2016 17:24:05 -0500 MIME-Version: 1.0 In-Reply-To: <1476774814-6840-1-git-send-email-nobuhiro.iwamatsu.kw@hitachi.com> References: <1476774814-6840-1-git-send-email-nobuhiro.iwamatsu.kw@hitachi.com> From: Kees Cook Date: Fri, 11 Nov 2016 14:24:03 -0800 X-Google-Sender-Auth: FCQXzqBRpQoIrJygvqnD82S8hEo Message-ID: Subject: Re: [PATCH v3 0/8] pstore: ramoops: support multiple pmsg instances To: Nobuhiro Iwamatsu Cc: Anton Vorontsov , Colin Cross , Tony Luck , LKML , cti.systems-productivity-manager.ts@hitachi.com Content-Type: text/plain; charset=UTF-8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Oct 18, 2016 at 12:13 AM, Nobuhiro Iwamatsu wrote: > The following series implements multiple pmsg. This feature allows > userspace program to control individual content aging or priority. > > If a pstore backend module(e.g. ramoops) requires the multiple pmsg > instances when registering itself to pstore, multiple /dev/pmsg[ID] > are created. Writes to each /dev/pmsg[ID] are isolated each other. After > reboot, the contents are available in /sys/fs/pstore/pmsg-[backend]-[ID]. > > In addition, we add multiple pmsg support for ramoops. We can > specify multiple pmsg area size by its module parameter as follows. > > pmsg_size=0x1000,0x2000,... > > I did check the operation of this feature on CycloneV (socfpga) Helio board. > > v3: > Rebase to v4.8. > Split patch. > merged device_create(). > Remove Blank lines. > Update documentiation of DT binding. > Update parsing function of ramoops_pmsg_size, add NULL termination. > Update module parameters for pmsg_size list. Thanks for this v3! Sorry for the delay, I should be able to review this shortly. -Kees > > Hiraku Toyooka (2): > pstore: support multiple pmsg instances > selftests/pstore: add testcases for multiple pmsg instances > > Nobuhiro Iwamatsu (6): > pstore: Replace four kzalloc() calls by kcalloc() in ramoops_init_przs() > pstore: Change parameter of ramoops_free_przs() > ramoops: Add __ramoops_init_prz() as generic function > pstore: Rename 'przs' to 'dprzs' in struct ramoops_context > ramoops: Rename ramoops_init_prz() to ramoops_init_dprzs() > ramoops: support multiple pmsg instances > > .../bindings/reserved-memory/ramoops.txt | 6 +- > Documentation/ramoops.txt | 22 ++ > fs/pstore/pmsg.c | 23 +- > fs/pstore/ram.c | 344 ++++++++++++++++----- > include/linux/pstore.h | 1 + > include/linux/pstore_ram.h | 8 +- > tools/testing/selftests/pstore/common_tests | 21 +- > .../selftests/pstore/pstore_post_reboot_tests | 27 +- > tools/testing/selftests/pstore/pstore_tests | 14 +- > 9 files changed, 360 insertions(+), 106 deletions(-) > > -- > 2.9.3 > > -- Kees Cook Nexus Security