From: Linus Torvalds <torvalds@linux-foundation.org>
To: Christoph Hellwig <hch@lst.de>
Cc: "the arch/x86 maintainers" <x86@kernel.org>,
Alexei Starovoitov <ast@kernel.org>,
Daniel Borkmann <daniel@iogearbox.net>,
Masami Hiramatsu <mhiramat@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
linux-parisc@vger.kernel.org,
linux-um <linux-um@lists.infradead.org>,
Netdev <netdev@vger.kernel.org>,
bpf@vger.kernel.org, Linux-MM <linux-mm@kvack.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 14/18] maccess: allow architectures to provide kernel probing directly
Date: Wed, 13 May 2020 12:48:54 -0700 [thread overview]
Message-ID: <CAHk-=whtGLxezkdMP6+859LFDgb++6dgYa6Vrc=zJ9+GB7UMFQ@mail.gmail.com> (raw)
In-Reply-To: <20200513194003.GA31028@lst.de>
On Wed, May 13, 2020 at 12:40 PM Christoph Hellwig <hch@lst.de> wrote:
>
> We do export something like it, currently it is called
> probe_kernel_address, and the last patch renames it to
> get_kernel_nofault. However it is implemented as a wrapper
> around probe_kernel_address / copy_from_kernel_nofault and thus
> not quite as efficient and without the magic goto semantics.
Looking at the current users of "probe_kernel_read()", it looks like
it's almost mostly things that just want a single byte or word.
It's not 100% that: we definitely do several things that want the
"copy" semantics vs the "get" semantics: on the x86 side we have
CALL_INSN_SIZE and MAX_INSN_SIZE, and the ldttss_desc.
But the bulk of them do seem to be a single value.
I don't know if performance really matters here, but to me the whole
"most users seem to want to read a single value" is what makes me
think that maybe that should be the primary model, rather than have
the copy model be the primary one and then we implement the single
value case (badly) with a copy.
It probably doesn't matter that much. I certainly wouldn't hold this
series up over it - it can be a future thing.
Linus
WARNING: multiple messages have this Message-ID (diff)
From: Linus Torvalds <torvalds@linux-foundation.org>
To: Christoph Hellwig <hch@lst.de>
Cc: Daniel Borkmann <daniel@iogearbox.net>,
linux-parisc@vger.kernel.org, Netdev <netdev@vger.kernel.org>,
the arch/x86 maintainers <x86@kernel.org>,
linux-um <linux-um@lists.infradead.org>,
Alexei Starovoitov <ast@kernel.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Linux-MM <linux-mm@kvack.org>,
Masami Hiramatsu <mhiramat@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
bpf@vger.kernel.org
Subject: Re: [PATCH 14/18] maccess: allow architectures to provide kernel probing directly
Date: Wed, 13 May 2020 12:48:54 -0700 [thread overview]
Message-ID: <CAHk-=whtGLxezkdMP6+859LFDgb++6dgYa6Vrc=zJ9+GB7UMFQ@mail.gmail.com> (raw)
In-Reply-To: <20200513194003.GA31028@lst.de>
On Wed, May 13, 2020 at 12:40 PM Christoph Hellwig <hch@lst.de> wrote:
>
> We do export something like it, currently it is called
> probe_kernel_address, and the last patch renames it to
> get_kernel_nofault. However it is implemented as a wrapper
> around probe_kernel_address / copy_from_kernel_nofault and thus
> not quite as efficient and without the magic goto semantics.
Looking at the current users of "probe_kernel_read()", it looks like
it's almost mostly things that just want a single byte or word.
It's not 100% that: we definitely do several things that want the
"copy" semantics vs the "get" semantics: on the x86 side we have
CALL_INSN_SIZE and MAX_INSN_SIZE, and the ldttss_desc.
But the bulk of them do seem to be a single value.
I don't know if performance really matters here, but to me the whole
"most users seem to want to read a single value" is what makes me
think that maybe that should be the primary model, rather than have
the copy model be the primary one and then we implement the single
value case (badly) with a copy.
It probably doesn't matter that much. I certainly wouldn't hold this
series up over it - it can be a future thing.
Linus
_______________________________________________
linux-um mailing list
linux-um@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-um
next prev parent reply other threads:[~2020-05-13 19:49 UTC|newest]
Thread overview: 100+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-05-13 16:00 clean up and streamline probe_kernel_* and friends v2 Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 01/18] maccess: unexport probe_kernel_write and probe_user_write Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 02/18] maccess: remove various unused weak aliases Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 03/18] maccess: remove duplicate kerneldoc comments Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 04/18] maccess: clarify " Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 05/18] maccess: update the top of file comment Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 06/18] maccess: rename strncpy_from_unsafe_user to strncpy_from_user_nofault Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 07/18] maccess: rename strncpy_from_unsafe_strict to strncpy_from_kernel_nofault Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 08/18] maccess: rename strnlen_unsafe_user to strnlen_user_nofault Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 09/18] maccess: remove probe_read_common and probe_write_common Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 10/18] maccess: unify the probe kernel arch hooks Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-14 1:13 ` Masami Hiramatsu
2020-05-14 1:13 ` Masami Hiramatsu
2020-05-19 5:46 ` Christoph Hellwig
2020-05-19 5:46 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 11/18] maccess: remove strncpy_from_unsafe Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 19:11 ` Linus Torvalds
2020-05-13 19:11 ` Linus Torvalds
2020-05-13 19:11 ` Linus Torvalds
2020-05-13 19:28 ` Christoph Hellwig
2020-05-13 19:28 ` Christoph Hellwig
2020-05-13 22:36 ` Daniel Borkmann
2020-05-13 22:36 ` Daniel Borkmann
2020-05-13 23:03 ` Linus Torvalds
2020-05-13 23:03 ` Linus Torvalds
2020-05-13 23:03 ` Linus Torvalds
2020-05-13 23:24 ` Daniel Borkmann
2020-05-13 23:24 ` Daniel Borkmann
2020-05-13 23:20 ` Masami Hiramatsu
2020-05-13 23:20 ` Masami Hiramatsu
2020-05-13 23:59 ` Linus Torvalds
2020-05-13 23:59 ` Linus Torvalds
2020-05-13 23:59 ` Linus Torvalds
2020-05-14 1:00 ` Masami Hiramatsu
2020-05-14 1:00 ` Masami Hiramatsu
2020-05-14 2:43 ` Linus Torvalds
2020-05-14 2:43 ` Linus Torvalds
2020-05-14 2:43 ` Linus Torvalds
2020-05-14 9:44 ` Masami Hiramatsu
2020-05-14 9:44 ` Masami Hiramatsu
2020-05-14 10:27 ` Daniel Borkmann
2020-05-14 10:27 ` Daniel Borkmann
2020-05-13 23:28 ` Al Viro
2020-05-13 23:28 ` Al Viro
2020-05-13 23:58 ` Daniel Borkmann
2020-05-13 23:58 ` Daniel Borkmann
2020-05-14 10:01 ` David Laight
2020-05-14 10:01 ` David Laight
2020-05-14 10:21 ` Daniel Borkmann
2020-05-14 10:21 ` Daniel Borkmann
2020-05-13 16:00 ` [PATCH 12/18] maccess: always use strict semantics for probe_kernel_read Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 13/18] maccess: move user access routines together Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 14/18] maccess: allow architectures to provide kernel probing directly Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 19:36 ` Linus Torvalds
2020-05-13 19:36 ` Linus Torvalds
2020-05-13 19:36 ` Linus Torvalds
2020-05-13 19:40 ` Christoph Hellwig
2020-05-13 19:40 ` Christoph Hellwig
2020-05-13 19:48 ` Linus Torvalds [this message]
2020-05-13 19:48 ` Linus Torvalds
2020-05-13 19:48 ` Linus Torvalds
2020-05-13 19:54 ` Christoph Hellwig
2020-05-13 19:54 ` Christoph Hellwig
2020-05-16 3:42 ` Masami Hiramatsu
2020-05-16 3:42 ` Masami Hiramatsu
2020-05-18 15:09 ` Christoph Hellwig
2020-05-18 15:09 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 15/18] x86: use non-set_fs based maccess routines Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 16:00 ` [PATCH 16/18] maccess: rename probe_kernel_{read,write} to copy_{from,to}_kernel_nofault Christoph Hellwig
2020-05-13 16:00 ` [PATCH 16/18] maccess: rename probe_kernel_{read, write} to copy_{from, to}_kernel_nofault Christoph Hellwig
2020-05-13 16:00 ` [PATCH 17/18] maccess: rename probe_user_{read,write} to copy_{from,to}_user_nofault Christoph Hellwig
2020-05-13 16:00 ` [PATCH 17/18] maccess: rename probe_user_{read, write} to copy_{from, to}_user_nofault Christoph Hellwig
2020-05-13 16:00 ` [PATCH 18/18] maccess: rename probe_kernel_address to get_kernel_nofault Christoph Hellwig
2020-05-13 16:00 ` Christoph Hellwig
2020-05-13 19:37 ` clean up and streamline probe_kernel_* and friends v2 Linus Torvalds
2020-05-13 19:37 ` Linus Torvalds
2020-05-13 19:37 ` Linus Torvalds
2020-05-13 23:04 ` Daniel Borkmann
2020-05-13 23:04 ` Daniel Borkmann
2020-05-13 23:20 ` Linus Torvalds
2020-05-13 23:20 ` Linus Torvalds
2020-05-13 23:20 ` Linus Torvalds
2020-05-19 5:50 ` Christoph Hellwig
2020-05-19 5:50 ` Christoph Hellwig
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to='CAHk-=whtGLxezkdMP6+859LFDgb++6dgYa6Vrc=zJ9+GB7UMFQ@mail.gmail.com' \
--to=torvalds@linux-foundation.org \
--cc=akpm@linux-foundation.org \
--cc=ast@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=daniel@iogearbox.net \
--cc=hch@lst.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=linux-parisc@vger.kernel.org \
--cc=linux-um@lists.infradead.org \
--cc=mhiramat@kernel.org \
--cc=netdev@vger.kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.