All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Marchand <david.marchand@redhat.com>
To: Honnappa Nagarahalli <Honnappa.Nagarahalli@arm.com>
Cc: Amit Gupta <agupta3@marvell.com>,
	"Wang, Yipeng1" <yipeng1.wang@intel.com>,
	"Gobriel, Sameh" <sameh.gobriel@intel.com>,
	"thomas@monjalon.net" <thomas@monjalon.net>, dev <dev@dpdk.org>,
	 nd <nd@arm.com>
Subject: Re: [dpdk-dev] [PATCH v2 3/5] test/hash: add lock free reader writer functional tests
Date: Wed, 5 Feb 2020 17:41:38 +0100	[thread overview]
Message-ID: <CAJFAV8wXe0mjT-9eT_wQ5Qh_qODbDSW2K77yM2e_=BeAGEa3sg@mail.gmail.com> (raw)
In-Reply-To: <VE1PR08MB5149905796CA08D184501E8398020@VE1PR08MB5149.eurprd08.prod.outlook.com>

On Wed, Feb 5, 2020 at 5:22 PM Honnappa Nagarahalli
<Honnappa.Nagarahalli@arm.com> wrote:
>
> >
> > On Mon, Feb 3, 2020 at 8:49 PM Honnappa Nagarahalli
> > <honnappa.nagarahalli@arm.com> wrote:
> > >
> > > Add lock-free reader writer concurrency functional tests.
> > > These tests will provide the same coverage that non lock-free APIs
> > > have.
> > >
> > > Signed-off-by: Honnappa Nagarahalli <honnappa.nagarahalli@arm.com>
> > > ---
> > >  app/test/test_hash_readwrite.c | 58
> > > +++++++++++++++++++++-------------
> > >  1 file changed, 36 insertions(+), 22 deletions(-)
> > >
> > > diff --git a/app/test/test_hash_readwrite.c
> > > b/app/test/test_hash_readwrite.c index 635ed5a9f..a9429091c 100644
> > > --- a/app/test/test_hash_readwrite.c
> > > +++ b/app/test/test_hash_readwrite.c
> > > @@ -121,7 +121,7 @@
> > test_hash_readwrite_worker(__attribute__((unused))
> > > void *arg)  }
> > >
> > >  static int
> > > -init_params(int use_ext, int use_htm, int use_jhash)
> > > +init_params(int use_ext, int use_htm, int rw_lf, int use_jhash)
> > >  {
> > >         unsigned int i;
> > >
> > > @@ -140,15 +140,16 @@ init_params(int use_ext, int use_htm, int
> > use_jhash)
> > >         else
> > >                 hash_params.hash_func = rte_hash_crc;
> > >
> > > +       hash_params.extra_flag =
> > > + RTE_HASH_EXTRA_FLAGS_MULTI_WRITER_ADD;
> > >         if (use_htm)
> > > -               hash_params.extra_flag =
> > > -                       RTE_HASH_EXTRA_FLAGS_TRANS_MEM_SUPPORT |
> > > -                       RTE_HASH_EXTRA_FLAGS_RW_CONCURRENCY |
> > > -                       RTE_HASH_EXTRA_FLAGS_MULTI_WRITER_ADD;
> > > +               hash_params.extra_flag |=
> > > +                       RTE_HASH_EXTRA_FLAGS_TRANS_MEM_SUPPORT;
> > > +       if (rw_lf)
> > > +               hash_params.extra_flag |=
> > > +                       RTE_HASH_EXTRA_FLAGS_RW_CONCURRENCY_LF;
> > >         else
> > > -               hash_params.extra_flag =
> > > -                       RTE_HASH_EXTRA_FLAGS_RW_CONCURRENCY |
> > > -                       RTE_HASH_EXTRA_FLAGS_MULTI_WRITER_ADD;
> > > +               hash_params.extra_flag |=
> > > +                       RTE_HASH_EXTRA_FLAGS_RW_CONCURRENCY;
> > >
> > >         if (use_ext)
> > >                 hash_params.extra_flag |= @@ -195,7 +196,7 @@
> > > init_params(int use_ext, int use_htm, int use_jhash)  }
> > >
> > >  static int
> > > -test_hash_readwrite_functional(int use_ext, int use_htm)
> > > +test_hash_readwrite_functional(int use_htm, int use_rw_lf, int
> > > +use_ext)
> >
> > This is a bit hard to read, please keep the same order than init_params.
> It looks like it is better to change the init_params. Otherwise, the code in test_hash_rw_func_main becomes hard to read. See the comment below.
>
> >
> >
> > >  {
> > >         unsigned int i;
> > >         const void *next_key;
> > > @@ -214,7 +215,7 @@ test_hash_readwrite_functional(int use_ext, int
> > use_htm)
> > >         rte_atomic64_init(&ginsertions);
> > >         rte_atomic64_clear(&ginsertions);
> > >
> > > -       if (init_params(use_ext, use_htm, use_jhash) != 0)
> > > +       if (init_params(use_ext, use_htm, use_rw_lf, use_jhash) != 0)
> > >                 goto err;
> > >
> > >         if (use_ext)
> > > @@ -229,6 +230,8 @@ test_hash_readwrite_functional(int use_ext, int
> > use_htm)
> > >                 tbl_rw_test_param.num_insert
> > >                 * slave_cnt;
> > >
> > > +       printf("\nHTM = %d, RW-LF = %d, EXT-Table = %d\n",
> > > +               use_htm, use_rw_lf, use_ext);
> > >         printf("++++++++Start function tests:+++++++++\n");
> > >
> > >         /* Fire all threads. */
> > > @@ -379,7 +382,7 @@ test_hash_readwrite_perf(struct perf *perf_results,
> > int use_htm,
> > >         rte_atomic64_init(&gwrite_cycles);
> > >         rte_atomic64_clear(&gwrite_cycles);
> > >
> > > -       if (init_params(0, use_htm, use_jhash) != 0)
> > > +       if (init_params(0, use_htm, 0, use_jhash) != 0)
> > >                 goto err;
> > >
> > >         /*
> > > @@ -700,7 +703,6 @@ test_hash_rw_func_main(void)
> > >          * than writer threads. This is to timing either reader threads or
> > >          * writer threads for performance numbers.
> > >          */
> > > -       int use_htm, use_ext;
> >
> > The comments block just before is out of sync.
> >
> >
> > >         unsigned int i = 0, core_id = 0;
> > >
> > >         if (rte_lcore_count() < 3) {
> > > @@ -721,29 +723,41 @@ test_hash_rw_func_main(void)
> > >
> > >                 printf("Test read-write with Hardware transactional
> > > memory\n");
> > >
> > > -               use_htm = 1;
> > > -               use_ext = 0;
> > > +               /* htm = 1, rw_lf = 0, ext = 0 */
> >
> > I didn't like those local variables.
> > But comments tend to get out of sync fairly easily, please remove too.
> >
> >
> > > +               if (test_hash_readwrite_functional(1, 0, 0) < 0)
> > > +                       return -1;
> > >
> > > -               if (test_hash_readwrite_functional(use_ext, use_htm) < 0)
> > > +               /* htm = 1, rw_lf = 1, ext = 0 */
> > > +               if (test_hash_readwrite_functional(1, 1, 0) < 0)
> > >                         return -1;
> > >
> > > -               use_ext = 1;
> > > -               if (test_hash_readwrite_functional(use_ext, use_htm) < 0)
> > > +               /* htm = 1, rw_lf = 0, ext = 1 */
> > > +               if (test_hash_readwrite_functional(1, 0, 1) < 0)
> > >                         return -1;
> > >
> > > +               /* htm = 1, rw_lf = 1, ext = 1 */
> > > +               if (test_hash_readwrite_functional(1, 1, 1) < 0)
> > > +                       return -1;
> > >         } else {
> > >                 printf("Hardware transactional memory (lock elision) "
> > >                         "is NOT supported\n");
> > >         }
> > >
> > >         printf("Test read-write without Hardware transactional memory\n");
> > > -       use_htm = 0;
> > > -       use_ext = 0;
> > > -       if (test_hash_readwrite_functional(use_ext, use_htm) < 0)
> > > +       /* htm = 0, rw_lf = 0, ext = 0 */
> > > +       if (test_hash_readwrite_functional(0, 0, 0) < 0)
> > > +               return -1;
> > > +
> > > +       /* htm = 0, rw_lf = 1, ext = 0 */
> > > +       if (test_hash_readwrite_functional(0, 1, 0) < 0)
> > > +               return -1;
> > > +
> > > +       /* htm = 0, rw_lf = 0, ext = 1 */
> > > +       if (test_hash_readwrite_functional(0, 0, 1) < 0)
> > >                 return -1;
> > >
> > > -       use_ext = 1;
> > > -       if (test_hash_readwrite_functional(use_ext, use_htm) < 0)
> > > +       /* htm = 0, rw_lf = 1, ext = 1 */
> > > +       if (test_hash_readwrite_functional(0, 1, 1) < 0)
> > >                 return -1;
> The ordering of bits (0-0-0, 0-1-0, 0-0-1, 0-1-1) looks better here.

Ok, forget my comment.
I just want to get rid of this series and we stop getting random
timeout in the CI.
I will take it as is and cleanup if I find some time later.


-- 
David Marchand


  reply	other threads:[~2020-02-05 16:41 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-09-06  5:49 [dpdk-dev] [PATCH 0/2] test/meson: fix hash readwrite timeout failure agupta3
2019-09-06  5:49 ` [dpdk-dev] [PATCH 1/2] test/meson: hash test split into shorter subtests agupta3
2019-09-11 17:05   ` Wang, Yipeng1
2019-10-17  5:02     ` Amit Gupta
2019-11-01  4:54       ` Amit Gupta
2019-11-01 17:04         ` Wang, Yipeng1
2019-11-05 16:37           ` Ferruh Yigit
2019-11-07  3:32             ` [dpdk-dev] [EXT] " Amit Gupta
2019-12-31  4:56               ` Amit Gupta
2019-09-06  5:49 ` [dpdk-dev] [PATCH 2/2] test/meson: hash lf test moved to dpdk perf testsuite agupta3
2019-09-11 17:13   ` Wang, Yipeng1
2019-09-12 15:00     ` Honnappa Nagarahalli
2019-09-13  8:24       ` Amit Gupta
2019-09-13  8:12   ` [dpdk-dev] [PATCH v2 1/1] " agupta3
2019-09-13 14:40     ` Aaron Conole
2019-09-13 15:09       ` Wang, Yipeng1
2019-09-13 15:46         ` Honnappa Nagarahalli
2019-09-16  4:39           ` Amit Gupta
2019-10-17  4:57           ` Amit Gupta
2019-10-17 13:16             ` Aaron Conole
2019-10-24  7:22               ` David Marchand
2019-09-13  8:15   ` agupta3
2019-09-11  5:55 ` [dpdk-dev] [PATCH 0/2] test/meson: fix hash readwrite timeout failure Amit Gupta
2020-02-03 19:49 ` [dpdk-dev] [PATCH v2 0/5] " Honnappa Nagarahalli
2020-02-03 19:49   ` [dpdk-dev] [PATCH v2 1/5] test/meson: hash test split into shorter subtests Honnappa Nagarahalli
2020-02-03 19:49   ` [dpdk-dev] [PATCH v2 2/5] test/hash: remove duplicated test code Honnappa Nagarahalli
2020-02-05  8:48     ` David Marchand
2020-02-05 16:42       ` David Marchand
2020-02-03 19:49   ` [dpdk-dev] [PATCH v2 3/5] test/hash: add lock free reader writer functional tests Honnappa Nagarahalli
2020-02-05  9:07     ` David Marchand
2020-02-05 16:22       ` Honnappa Nagarahalli
2020-02-05 16:41         ` David Marchand [this message]
2020-02-05 19:34           ` Wang, Yipeng1
2020-02-05 19:52             ` Honnappa Nagarahalli
2020-02-05 19:57               ` Wang, Yipeng1
2020-02-03 19:49   ` [dpdk-dev] [PATCH v2 4/5] test/hash: move reader writer lock free tests to perf tests Honnappa Nagarahalli
2020-02-03 19:49   ` [dpdk-dev] [PATCH v2 5/5] hash: correct lock free extendable table support Honnappa Nagarahalli
2020-02-05 18:41   ` [dpdk-dev] [PATCH v2 0/5] test/meson: fix hash readwrite timeout failure David Marchand

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAJFAV8wXe0mjT-9eT_wQ5Qh_qODbDSW2K77yM2e_=BeAGEa3sg@mail.gmail.com' \
    --to=david.marchand@redhat.com \
    --cc=Honnappa.Nagarahalli@arm.com \
    --cc=agupta3@marvell.com \
    --cc=dev@dpdk.org \
    --cc=nd@arm.com \
    --cc=sameh.gobriel@intel.com \
    --cc=thomas@monjalon.net \
    --cc=yipeng1.wang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.