All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Marchand <david.marchand@redhat.com>
To: Stephen Hemminger <stephen@networkplumber.org>
Cc: dev <dev@dpdk.org>,
	techboard@dpdk.org, Luca Boccassi <bluca@debian.org>,
	 "Mcnamara, John" <john.mcnamara@intel.com>
Subject: Re: [dpdk-dev] [PATCH v3 00/10] rename blacklist/whitelist to block/allow
Date: Fri, 10 Jul 2020 17:06:11 +0200	[thread overview]
Message-ID: <CAJFAV8xuv8y07Euy7vrbxnsXK4fiFC+Hp1geXzKKZdpdGONbCg@mail.gmail.com> (raw)
In-Reply-To: <20200613000055.7909-1-stephen@networkplumber.org>

On Sat, Jun 13, 2020 at 2:01 AM Stephen Hemminger
<stephen@networkplumber.org> wrote:
>
> The terms blacklist and whitelist are often seen as reminders
> of the divisions in society. Instead, use more exact terms for
> handling of which devices are used in DPDK.
>
> This is a proposed change for DPDK 20.08 to replace the names
> blacklist and whitelist in API and command lines.
>
> The first three patches fix some other unnecessary use of
> blacklist/whitelist and have no user visible impact.
>
> The rest change the PCI blacklist to be blocklist and
> whitelist to be allowlist.

Thanks for working on this.

I agree, the first patches can go in right now.

But I have some concerns about the rest.

New options in EAL are not consistent with "allow"/"block" list:
+    "b:" /* pci-skip-probe */
+    "w:" /* pci-only-probe */
+#define OPT_PCI_SKIP_PROBE     "pci-skip-probe"
+    OPT_PCI_SKIP_PROBE_NUM  = 'b',
+#define OPT_PCI_ONLY_PROBE     "pci-only-probe"
+    OPT_PCI_ONLY_PROBE_NUM  = 'w',

The CI flagged the series as failing, because the unit test for EAL
flags is unaligned:
+#define pci_allowlist "--pci-allowlist"
https://travis-ci.com/github/ovsrobot/dpdk/jobs/348668299#L5657


The ABI check complains about the enum update:
https://travis-ci.com/github/ovsrobot/dpdk/jobs/348668301#L2400
Either we deal with this, or we need a libabigail exception rule.


About deprecating existing API/EAL flags in this release, this should
go through the standard deprecation process.
I would go with introducing new options + full compatibility + a
deprecation notice in the 20.08 release.
The actual deprecation/API flagging will go in 20.11.
Removal will come later.


-- 
David Marchand


  parent reply	other threads:[~2020-07-10 15:06 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-13  0:00 [dpdk-dev] [PATCH v3 00/10] rename blacklist/whitelist to block/allow Stephen Hemminger
2020-06-13  0:00 ` [dpdk-dev] [PATCH v3 01/10] rte_ethdev: change comment to rte_dev_eth_mac_addr_add Stephen Hemminger
2020-06-13  0:00 ` [dpdk-dev] [PATCH v3 02/10] mk: replace reference to blacklist/whitelist Stephen Hemminger
2020-06-13  0:00 ` [dpdk-dev] [PATCH v3 03/10] check_maintainers: change variable names Stephen Hemminger
2020-07-10 17:01   ` Thomas Monjalon
2020-06-13  0:00 ` [dpdk-dev] [PATCH v3 04/10] eal: replace usage of blacklist/whitelist in enum Stephen Hemminger
2020-06-13  0:00 ` [dpdk-dev] [PATCH v3 05/10] drivers: replace references to blacklist Stephen Hemminger
2020-06-15  6:32   ` Hemant Agrawal
2020-06-13  0:00 ` [dpdk-dev] [PATCH v3 06/10] eal: replace pci-whitelist/pci-blacklist options Stephen Hemminger
2020-06-13  0:00 ` [dpdk-dev] [PATCH v3 07/10] doc: replace references to blacklist/whitelist Stephen Hemminger
2020-06-13  0:00 ` [dpdk-dev] [PATCH v3 08/10] app/test: use new allowlist and blocklist Stephen Hemminger
2020-06-13  0:00 ` [dpdk-dev] [PATCH v3 09/10] doc: add note about blacklist/whitelist changes Stephen Hemminger
2020-06-13  0:00 ` [dpdk-dev] [PATCH v3 10/10] eal: mark old macros for blacklist/whitelist as deprecated Stephen Hemminger
2020-06-17 12:05 ` [dpdk-dev] [PATCH v3 00/10] rename blacklist/whitelist to block/allow Mcnamara, John
2020-07-10 15:06 ` David Marchand [this message]
2020-07-14  4:43   ` Stephen Hemminger
2020-07-14  5:33   ` Stephen Hemminger
2020-07-15 10:01     ` [dpdk-dev] [dpdk-techboard] " Thomas Monjalon
2020-09-22 14:28       ` Stephen Hemminger
2020-09-22 16:16         ` Thomas Monjalon
2020-09-22 16:18           ` Thomas Monjalon
2020-09-22 17:12           ` Stephen Hemminger
2020-07-14  5:39 ` [dpdk-dev] [PATCH v4 00/11] rename blacklist/whitelist to exclude/include Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 01/11] rte_ethdev: change comment to rte_dev_eth_mac_addr_add Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 02/11] mk: replace reference to blacklist/whitelist Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 03/11] check_maintainers: change variable names Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 04/11] eal: replace usage of blacklist/whitelist in enum Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 05/11] drivers: replace references to blacklist Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 06/11] eal: replace pci-whitelist/pci-blacklist options Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 07/11] doc: replace references to blacklist/whitelist Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 08/11] app/test: use new allowlist and blocklist Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 09/11] doc: add note about blacklist/whitelist changes Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 10/11] eal: mark old macros for blacklist/whitelist as deprecated Stephen Hemminger
2020-07-14  5:39   ` [dpdk-dev] [PATCH v4 11/11] doc: update examples to new config options Stephen Hemminger
2020-07-14  6:05   ` [dpdk-dev] [PATCH v4 00/11] rename blacklist/whitelist to exclude/include Stephen Hemminger

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAJFAV8xuv8y07Euy7vrbxnsXK4fiFC+Hp1geXzKKZdpdGONbCg@mail.gmail.com \
    --to=david.marchand@redhat.com \
    --cc=bluca@debian.org \
    --cc=dev@dpdk.org \
    --cc=john.mcnamara@intel.com \
    --cc=stephen@networkplumber.org \
    --cc=techboard@dpdk.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.