All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jassi Brar <jaswinder.singh@linaro.org>
To: Barry Song <21cnbao@gmail.com>
Cc: dan.j.williams@intel.com, sundaram@ti.com,
	linus.walleij@linaro.org, vinod.koul@intel.com,
	rmk+kernel@arm.linux.org.uk, linux-omap@vger.kernel.org,
	DL-SHA-WorkGroupLinux <workgroup.linux@csr.com>
Subject: Re: [PATCH] DMAEngine: Define generic transfer request api
Date: Thu, 15 Sep 2011 12:13:14 +0530	[thread overview]
Message-ID: <CAJe_ZheZwHM7qH=s0KCQAyoZDmXmdX0ZK5oBgJ7dTw5Vg8tHVw@mail.gmail.com> (raw)
In-Reply-To: <CAGsJ_4y_Qp-F8z5m_nK5rTjCy4p-Cgr5DoHD0rzRjnLrTq=TEQ@mail.gmail.com>

On 15 September 2011 12:01, Barry Song <21cnbao@gmail.com> wrote:
> 2011/9/13 Barry Song <21cnbao@gmail.com>:
>> 2011/9/13 Jassi Brar <jaswinder.singh@linaro.org>:
>>> On 13 September 2011 13:16, Barry Song <21cnbao@gmail.com> wrote:
>>>>> if test pass, to the patch, and even for the moment, to the API's idea
>>>>> Acked-by: Barry Song <baohua.song@csr.com>
>>>>
>>>> one issue i noticed is with a device_prep_dma_genxfer, i don't need
>>>> device_prep_slave_sg any more,
>>> Yeah, the damengine would need to adapt to the fact that these
>>> interleaved tranfers could be Mem->Mem as well as Mem<->Dev
>>> (even though yours could be only one type, but some dmacs could
>>> do both).
>>>
>>>> How about:
>>>>
>>>>       BUG_ON(dma_has_cap(DMA_MEMCPY, device->cap_mask) &&
>>>> -               !device->device_prep_dma_memcpy);
>>>> +               !device->device_prep_dma_memcpy &&
>>>> +               !device->device_prep_dma_genxfer);
>>>>
>>>>        BUG_ON(dma_has_cap(DMA_SLAVE, device->cap_mask) &&
>>>>  -               !device->device_prep_slave_sg);
>>>> +               !device->device_prep_slave_sg &&
>>>> +               !device->device_prep_dma_genxfer);
>>>>
>>> Seems ok, but please modify in a way you think is best and submit a patch
>>> on top of this new api. Then it'll be easier to evaluate everything.
>>
>> i think it should be handled by this patch but not a new one.
>
> and i also think xfer_template is a bad name for a structure which is
> an API. i'd like to add namespace for it and rename it to dma_genxfer.
> or have any good suggestion?
I think xfer_template is better - which stresses the usage as having prepared
templates of transfers and only change src/dst address before submitting.
'device_prep_dma_genxfer' is the API which is already named so.

> i'd like to send this together with "BUG_ON(dma_has_cap(DMA_SLAVE,
> device->cap_mask) &&!device->device_prep_dma_genxfer)" as v2.
Is there no change other than skipping check for SLAVE when using this api ?
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

  reply	other threads:[~2011-09-15  6:43 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <CAGsJ_4wXURUwbf-fcNOq1m5-NJ9+VMuDq+9OJpBjFZK4C_X3cw@mail.gmail.com>
2011-09-12 16:26 ` [PATCH] DMAEngine: Define generic transfer request api Barry Song
2011-09-12 16:54   ` Jassi Brar
2011-09-13  1:21     ` Barry Song
2011-09-13  7:46       ` Barry Song
2011-09-13  8:43         ` Jassi Brar
2011-09-13  8:58           ` Barry Song
2011-09-15  6:31             ` Barry Song
2011-09-15  6:43               ` Jassi Brar [this message]
2011-09-15  6:49                 ` Barry Song
2011-09-15  8:17                 ` Barry Song
2011-08-12 11:14 Jassi Brar
2011-08-16 12:56 ` Koul, Vinod
2011-08-16 13:06   ` Linus Walleij
2011-08-19 13:43     ` Koul, Vinod
2011-08-19 14:19       ` Linus Walleij
2011-08-19 15:46         ` Jassi Brar
2011-08-19 17:28           ` Koul, Vinod
2011-08-19 18:45             ` Jassi Brar
2011-08-23 14:43       ` Matt Porter
2011-08-23 14:43         ` Matt Porter
2011-08-16 14:32   ` Jassi Brar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAJe_ZheZwHM7qH=s0KCQAyoZDmXmdX0ZK5oBgJ7dTw5Vg8tHVw@mail.gmail.com' \
    --to=jaswinder.singh@linaro.org \
    --cc=21cnbao@gmail.com \
    --cc=dan.j.williams@intel.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-omap@vger.kernel.org \
    --cc=rmk+kernel@arm.linux.org.uk \
    --cc=sundaram@ti.com \
    --cc=vinod.koul@intel.com \
    --cc=workgroup.linux@csr.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.