All of lore.kernel.org
 help / color / mirror / Atom feed
* Query regarding emxx_udc
@ 2017-02-03  8:04 Deeksha varshney
  2017-02-03 11:17 ` Amit Kumar
  0 siblings, 1 reply; 6+ messages in thread
From: Deeksha varshney @ 2017-02-03  8:04 UTC (permalink / raw)
  To: kernelnewbies

In the checkpatch.pl for the file drivers/staging /emxx_udc/emxx_udc.c
there are checks for Camel case naming . How should I send patches for
them? I mean there are Epn_ type variables should I correct them all in one
patch then there is iWriteLength variables ,correct them in another patch
then there are pointer variables.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.kernelnewbies.org/pipermail/kernelnewbies/attachments/20170203/9b230033/attachment.html 

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Query regarding emxx_udc
  2017-02-03  8:04 Query regarding emxx_udc Deeksha varshney
@ 2017-02-03 11:17 ` Amit Kumar
  2017-02-03 12:00   ` Greg KH
  0 siblings, 1 reply; 6+ messages in thread
From: Amit Kumar @ 2017-02-03 11:17 UTC (permalink / raw)
  To: kernelnewbies

On Fri, Feb 03, 2017 at 01:34:11PM +0530, Deeksha varshney wrote:
> In the checkpatch.pl for the file drivers/staging /emxx_udc/emxx_udc.c
> there are checks for Camel case naming . How should I send patches for
> them? I mean there are Epn_ type variables should I correct them all in one
> patch then there is iWriteLength variables ,correct them in another patch
> then there are pointer variables.
Yes, you can send all modifications in one patch.
> _______________________________________________
> Kernelnewbies mailing list
> Kernelnewbies at kernelnewbies.org
> https://lists.kernelnewbies.org/mailman/listinfo/kernelnewbies

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Query regarding emxx_udc
  2017-02-03 11:17 ` Amit Kumar
@ 2017-02-03 12:00   ` Greg KH
  2017-02-04  4:27     ` Deeksha varshney
  0 siblings, 1 reply; 6+ messages in thread
From: Greg KH @ 2017-02-03 12:00 UTC (permalink / raw)
  To: kernelnewbies

On Fri, Feb 03, 2017 at 11:17:55AM +0000, Amit Kumar wrote:
> On Fri, Feb 03, 2017 at 01:34:11PM +0530, Deeksha varshney wrote:
> > In the checkpatch.pl for the file drivers/staging /emxx_udc/emxx_udc.c
> > there are checks for Camel case naming . How should I send patches for
> > them? I mean there are Epn_ type variables should I correct them all in one
> > patch then there is iWriteLength variables ,correct them in another patch
> > then there are pointer variables.
> Yes, you can send all modifications in one patch.

If you do that, I will reject it, for the obvious reasons :)

(hint iWriteLength probably comes from a hardware spec, be careful about
that...)

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Query regarding emxx_udc
  2017-02-03 12:00   ` Greg KH
@ 2017-02-04  4:27     ` Deeksha varshney
  0 siblings, 0 replies; 6+ messages in thread
From: Deeksha varshney @ 2017-02-04  4:27 UTC (permalink / raw)
  To: kernelnewbies

So sir every Epn_ type variable should also be modified in seperate patches
i.e each patch containing unique Epn_ type variables.

On 3 Feb 2017 17:30, "Greg KH" <greg@kroah.com> wrote:

On Fri, Feb 03, 2017 at 11:17:55AM +0000, Amit Kumar wrote:
> On Fri, Feb 03, 2017 at 01:34:11PM +0530, Deeksha varshney wrote:
> > In the checkpatch.pl for the file drivers/staging /emxx_udc/emxx_udc.c
> > there are checks for Camel case naming . How should I send patches for
> > them? I mean there are Epn_ type variables should I correct them all in
one
> > patch then there is iWriteLength variables ,correct them in another
patch
> > then there are pointer variables.
> Yes, you can send all modifications in one patch.

If you do that, I will reject it, for the obvious reasons :)

(hint iWriteLength probably comes from a hardware spec, be careful about
that...)

thanks,

greg k-h
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.kernelnewbies.org/pipermail/kernelnewbies/attachments/20170204/2abff1b3/attachment.html 

^ permalink raw reply	[flat|nested] 6+ messages in thread

* query regarding emxx_udc
  2017-02-08  7:16 query " Deeksha varshney
@ 2017-02-08  7:26 ` Greg KH
  0 siblings, 0 replies; 6+ messages in thread
From: Greg KH @ 2017-02-08  7:26 UTC (permalink / raw)
  To: kernelnewbies

On Wed, Feb 08, 2017 at 12:46:58PM +0530, Deeksha varshney wrote:
> In the file file drivers/staging /emxx_udc/emxx_udc.c every EPn_ type variable
> should be modified in seperate patches ?
> like EPn_BUF_TYPE should be modified as? EPN_BUF_TYPE in one patch
> and EPn_MPKT as EPN_MPKT in another patch.?

Step back and think about what you are changing here.  Why is the
current naming scheme not correct?  It properly describes what the
define is, and what it is for.  I would strongly recommend just leaving
it as-is, there is nothing wrong with it.

Remember, checkpatch.pl is a _hint_, you always have to use your brain
when reading the output of it.

hope this helps,

greg k-h

^ permalink raw reply	[flat|nested] 6+ messages in thread

* query regarding emxx_udc
@ 2017-02-08  7:16 Deeksha varshney
  2017-02-08  7:26 ` Greg KH
  0 siblings, 1 reply; 6+ messages in thread
From: Deeksha varshney @ 2017-02-08  7:16 UTC (permalink / raw)
  To: kernelnewbies

In the file file drivers/staging /emxx_udc/emxx_udc.c every EPn_ type
variable should be modified in seperate patches ?
like EPn_BUF_TYPE should be modified as  EPN_BUF_TYPE in one patch
and EPn_MPKT as EPN_MPKT in another patch.?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.kernelnewbies.org/pipermail/kernelnewbies/attachments/20170208/26ebffc1/attachment.html 

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2017-02-08  7:26 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-02-03  8:04 Query regarding emxx_udc Deeksha varshney
2017-02-03 11:17 ` Amit Kumar
2017-02-03 12:00   ` Greg KH
2017-02-04  4:27     ` Deeksha varshney
2017-02-08  7:16 query " Deeksha varshney
2017-02-08  7:26 ` Greg KH

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.