On Wed, Mar 11, 2020, 5:38 PM Stefano Brivio wrote: > On Wed, 11 Mar 2020 14:58:15 +0530 > Payal Kshirsagar wrote: > > > Remove unneeded temporary local variable, cleanup suggested by > coccinelle. > > > > Signed-off-by: Payal Kshirsagar > > --- > > drivers/staging/qlge/qlge_ethtool.c | 5 +---- > > 1 file changed, 1 insertion(+), 4 deletions(-) > > > > diff --git a/drivers/staging/qlge/qlge_ethtool.c > b/drivers/staging/qlge/qlge_ethtool.c > > index 592ca7edfc44..e15f9723b5c0 100644 > > --- a/drivers/staging/qlge/qlge_ethtool.c > > +++ b/drivers/staging/qlge/qlge_ethtool.c > > @@ -692,7 +692,6 @@ static int ql_set_pauseparam(struct net_device > *netdev, > > struct ethtool_pauseparam *pause) > > { > > struct ql_adapter *qdev = netdev_priv(netdev); > > - int status = 0; > > > > if ((pause->rx_pause) && (pause->tx_pause)) > > qdev->link_config |= CFG_PAUSE_STD; > > @@ -700,9 +699,7 @@ static int ql_set_pauseparam(struct net_device > *netdev, > > qdev->link_config &= ~CFG_PAUSE_STD; > > else > > return -EINVAL; > > - > > - status = ql_mb_set_port_cfg(qdev); > > - return status; > > + return ql_mb_set_port_cfg(qdev); > > Here, you're also removing a newline that is typically inserted before > a second return (or the last one in a function) for readability, or > whenever there are two logically distinct branches, same in 3/4. > Thanks for the suggestion. I thought there is no need to keep the newline as is:D But I did not understand what do you want me to do, patch is okay or need to be resend by adding a newline for readability:) payal And in 1/4, you might want to add one. In 2/4, there's no need. > > -- > Stefano >