All of lore.kernel.org
 help / color / mirror / Atom feed
From: Alexander Duyck <alexander.duyck@gmail.com>
To: Yunsheng Lin <linyunsheng@huawei.com>
Cc: David Miller <davem@davemloft.net>,
	Jakub Kicinski <kuba@kernel.org>,
	Russell King - ARM Linux <linux@armlinux.org.uk>,
	Marcin Wojtas <mw@semihalf.com>,
	linuxarm@openeuler.org, yisen.zhuang@huawei.com,
	Salil Mehta <salil.mehta@huawei.com>,
	thomas.petazzoni@bootlin.com, hawk@kernel.org,
	Ilias Apalodimas <ilias.apalodimas@linaro.org>,
	Alexei Starovoitov <ast@kernel.org>,
	Daniel Borkmann <daniel@iogearbox.net>,
	John Fastabend <john.fastabend@gmail.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Peter Zijlstra <peterz@infradead.org>,
	Will Deacon <will@kernel.org>,
	Matthew Wilcox <willy@infradead.org>,
	Vlastimil Babka <vbabka@suse.cz>,
	fenghua.yu@intel.com, guro@fb.com, Peter Xu <peterx@redhat.com>,
	Feng Tang <feng.tang@intel.com>, Jason Gunthorpe <jgg@ziepe.ca>,
	Matteo Croce <mcroce@microsoft.com>,
	Hugh Dickins <hughd@google.com>,
	Jonathan Lemon <jonathan.lemon@gmail.com>,
	Alexander Lobakin <alobakin@pm.me>,
	Willem de Bruijn <willemb@google.com>,
	wenxu@ucloud.cn, Cong Wang <cong.wang@bytedance.com>,
	Kevin Hao <haokexin@gmail.com>,
	nogikh@google.com, Marco Elver <elver@google.com>,
	Yonghong Song <yhs@fb.com>,
	kpsingh@kernel.org, andrii@kernel.org,
	Martin KaFai Lau <kafai@fb.com>,
	songliubraving@fb.com, Netdev <netdev@vger.kernel.org>,
	LKML <linux-kernel@vger.kernel.org>, bpf <bpf@vger.kernel.org>
Subject: Re: [PATCH rfc v4 2/4] page_pool: add interface to manipulate bias in page pool
Date: Tue, 13 Jul 2021 11:41:01 -0700	[thread overview]
Message-ID: <CAKgT0UevHk7n=Lnfkvw1t04HvRCX9vtyc0a6_2cda3c6hgDdJg@mail.gmail.com> (raw)
In-Reply-To: <1626168272-25622-3-git-send-email-linyunsheng@huawei.com>

On Tue, Jul 13, 2021 at 2:25 AM Yunsheng Lin <linyunsheng@huawei.com> wrote:
>
> As suggested by Alexander, "A DMA mapping should be page
> aligned anyway so the lower 12 bits would be reserved 0",
> so it might make more sense to repurpose the lower 12 bits
> of the dma address to store the bias for frag page support
> in page pool for 32 bit systems with 64 bit dma, which
> should be rare those days.
>
> For normal system, the dma_addr[1] in 'struct page' is not
> used, so we can reuse the dma_addr[1] for storing bias.
>
> The PAGE_POOP_USE_DMA_ADDR_1 macro is used to decide where
> to store the bias, as the "sizeof(dma_addr_t) > sizeof(
> unsigned long)" is false for normal system, so hopefully the
> compiler will optimize out the unused code for those system.

I assume the name is a typo and you meant PAGE_POOL_USE_DMA_ADDR_1?

> The newly added page_pool_set_bias() should be called before
> the page is passed to any user. Otherwise, call the newly
> added page_pool_atomic_sub_bias_return().
>
> Signed-off-by: Yunsheng Lin <linyunsheng@huawei.com>
> ---
>  include/net/page_pool.h | 70 ++++++++++++++++++++++++++++++++++++++++++++++---
>  net/core/page_pool.c    | 10 +++++++
>  2 files changed, 77 insertions(+), 3 deletions(-)
>
> diff --git a/include/net/page_pool.h b/include/net/page_pool.h
> index 8d7744d..315b9f2 100644
> --- a/include/net/page_pool.h
> +++ b/include/net/page_pool.h
> @@ -198,21 +198,85 @@ static inline void page_pool_recycle_direct(struct page_pool *pool,
>         page_pool_put_full_page(pool, page, true);
>  }
>
> +#define PAGE_POOP_USE_DMA_ADDR_1       (sizeof(dma_addr_t) > sizeof(unsigned long))
> +
>  static inline dma_addr_t page_pool_get_dma_addr(struct page *page)
>  {
> -       dma_addr_t ret = page->dma_addr[0];
> -       if (sizeof(dma_addr_t) > sizeof(unsigned long))
> +       dma_addr_t ret;
> +
> +       if (PAGE_POOP_USE_DMA_ADDR_1) {
> +               ret = READ_ONCE(page->dma_addr[0]) & PAGE_MASK;
>                 ret |= (dma_addr_t)page->dma_addr[1] << 16 << 16;

Alternatively we could change things a bit and rename things so we
have the MSB of dma_addr where dma_addr[1] is and we rename
dma_addr[0] to pp_frag_count we could have it also contain the lower
bits and handle it like so:
    ret = page->dma_addr;
    if (PAGE_POOL_DMA_USE_PP_FRAG_COUNT) {
        ret <<= 32;
        ret |= atomic_long_read(&page->pp_frag_count) & PAGE_MASK;
    }

> +       } else {
> +               ret = page->dma_addr[0];
> +       }
> +
>         return ret;
>  }
>
>  static inline void page_pool_set_dma_addr(struct page *page, dma_addr_t addr)
>  {
>         page->dma_addr[0] = addr;
> -       if (sizeof(dma_addr_t) > sizeof(unsigned long))
> +       if (PAGE_POOP_USE_DMA_ADDR_1)
>                 page->dma_addr[1] = upper_32_bits(addr);

So assuming similar logic to above we could do something like:
    if (PAGE_POOL_DMA_USE_PP_FRAG_COUNT) {
        atomic_long_set(&page->pp_frag_count, addr & PAGE_MASK);
        addr >>= 32;
    }
    pp->dma_addr = addr;

>  }
>
> +static inline int page_pool_atomic_sub_bias_return(struct page *page, int nr)
> +{
> +       int bias;
> +
> +       if (PAGE_POOP_USE_DMA_ADDR_1) {
> +               unsigned long *bias_ptr = &page->dma_addr[0];
> +               unsigned long old_bias = READ_ONCE(*bias_ptr);
> +               unsigned long new_bias;
> +
> +               do {
> +                       bias = (int)(old_bias & ~PAGE_MASK);
> +
> +                       /* Warn when page_pool_dev_alloc_pages() is called
> +                        * with PP_FLAG_PAGE_FRAG flag in driver.
> +                        */
> +                       WARN_ON(!bias);
> +
> +                       /* already the last user */
> +                       if (!(bias - nr))
> +                               return 0;
> +
> +                       new_bias = old_bias - nr;
> +               } while (!try_cmpxchg(bias_ptr, &old_bias, new_bias));
> +
> +               WARN_ON((new_bias & PAGE_MASK) != (old_bias & PAGE_MASK));
> +
> +               bias = new_bias & ~PAGE_MASK;
> +       } else {
> +               atomic_t *v = (atomic_t *)&page->dma_addr[1];

The problem with casting like this is that it makes assumptions about
byte ordering in the case that atomic_t is a 32b value and dma_addr is
a long value.

> +
> +               if (atomic_read(v) == nr)
> +                       return 0;
> +
> +               bias = atomic_sub_return(nr, v);
> +               WARN_ON(bias < 0);
> +       }

Rather than have 2 versions of this function it might work better to
just use the atomic_long version of these functions instead. Then you
shouldn't need to have two versions of the code.

You could just modify the block on the end to check for new_frag_count
vs old_frag_count if PAGE_POOL_USE_PP_FRAG_COUNT is true, or
new_frag_count < 0 if false.

> +
> +       return bias;
> +}
> +
> +static inline void page_pool_set_bias(struct page *page, int bias)
> +{
> +       if (PAGE_POOP_USE_DMA_ADDR_1) {
> +               unsigned long dma_addr_0 = READ_ONCE(page->dma_addr[0]);
> +
> +               dma_addr_0 &= PAGE_MASK;
> +               dma_addr_0 |= bias;
> +
> +               WRITE_ONCE(page->dma_addr[0], dma_addr_0);
> +       } else {
> +               atomic_t *v = (atomic_t *)&page->dma_addr[1];
> +
> +               atomic_set(v, bias);
> +       }

Similarly here you could just update bias to include the dma_addr in
the if case, and then use atomic_long_set for both cases.

> +}
> +
>  static inline bool is_page_pool_compiled_in(void)
>  {
>  #ifdef CONFIG_PAGE_POOL
> diff --git a/net/core/page_pool.c b/net/core/page_pool.c
> index 78838c6..6ac5b00 100644
> --- a/net/core/page_pool.c
> +++ b/net/core/page_pool.c
> @@ -198,6 +198,16 @@ static bool page_pool_dma_map(struct page_pool *pool, struct page *page)
>         if (dma_mapping_error(pool->p.dev, dma))
>                 return false;
>
> +       if (PAGE_POOP_USE_DMA_ADDR_1 &&
> +           WARN_ON(pool->p.flags & PP_FLAG_PAGE_FRAG &&
> +                   dma & ~PAGE_MASK)) {
> +               dma_unmap_page_attrs(pool->p.dev, dma,
> +                                    PAGE_SIZE << pool->p.order,
> +                                    pool->p.dma_dir,
> +                                    DMA_ATTR_SKIP_CPU_SYNC);
> +               return false;
> +       }
> +
>         page_pool_set_dma_addr(page, dma);
>
>         if (pool->p.flags & PP_FLAG_DMA_SYNC_DEV)
> --
> 2.7.4
>

  reply	other threads:[~2021-07-13 18:41 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-13  9:24 [PATCH rfc v4 0/4] add frag page support in page pool Yunsheng Lin
2021-07-13  9:24 ` [PATCH rfc v4 1/4] page_pool: keep pp info as long as page pool owns the page Yunsheng Lin
2021-07-13 11:49   ` Ilias Apalodimas
2021-07-13  9:24 ` [PATCH rfc v4 2/4] page_pool: add interface to manipulate bias in page pool Yunsheng Lin
2021-07-13 18:41   ` Alexander Duyck [this message]
2021-07-14  6:24     ` Yunsheng Lin
2021-07-13  9:24 ` [PATCH rfc v4 3/4] page_pool: add frag page recycling support " Yunsheng Lin
2021-07-13  9:24 ` [PATCH rfc v4 4/4] net: hns3: support skb's frag page recycling based on " Yunsheng Lin
2021-07-13 11:42   ` Denis Kirjanov
2021-07-14  6:13     ` Yunsheng Lin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAKgT0UevHk7n=Lnfkvw1t04HvRCX9vtyc0a6_2cda3c6hgDdJg@mail.gmail.com' \
    --to=alexander.duyck@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=alobakin@pm.me \
    --cc=andrii@kernel.org \
    --cc=ast@kernel.org \
    --cc=bpf@vger.kernel.org \
    --cc=cong.wang@bytedance.com \
    --cc=daniel@iogearbox.net \
    --cc=davem@davemloft.net \
    --cc=elver@google.com \
    --cc=feng.tang@intel.com \
    --cc=fenghua.yu@intel.com \
    --cc=guro@fb.com \
    --cc=haokexin@gmail.com \
    --cc=hawk@kernel.org \
    --cc=hughd@google.com \
    --cc=ilias.apalodimas@linaro.org \
    --cc=jgg@ziepe.ca \
    --cc=john.fastabend@gmail.com \
    --cc=jonathan.lemon@gmail.com \
    --cc=kafai@fb.com \
    --cc=kpsingh@kernel.org \
    --cc=kuba@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=linuxarm@openeuler.org \
    --cc=linyunsheng@huawei.com \
    --cc=mcroce@microsoft.com \
    --cc=mw@semihalf.com \
    --cc=netdev@vger.kernel.org \
    --cc=nogikh@google.com \
    --cc=peterx@redhat.com \
    --cc=peterz@infradead.org \
    --cc=salil.mehta@huawei.com \
    --cc=songliubraving@fb.com \
    --cc=thomas.petazzoni@bootlin.com \
    --cc=vbabka@suse.cz \
    --cc=wenxu@ucloud.cn \
    --cc=will@kernel.org \
    --cc=willemb@google.com \
    --cc=willy@infradead.org \
    --cc=yhs@fb.com \
    --cc=yisen.zhuang@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.