All of lore.kernel.org
 help / color / mirror / Atom feed
From: Pavel Shilovsky <piastryyy@gmail.com>
To: Al Viro <viro@zeniv.linux.org.uk>
Cc: Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com>,
	Steve French <stfrench@microsoft.com>,
	Ronnie Sahlberg <lsahlber@redhat.com>,
	linux-cifs <linux-cifs@vger.kernel.org>,
	Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: build_path_from_dentry_optional_prefix() may schedule from invalid context
Date: Mon, 30 Sep 2019 10:32:16 -0700	[thread overview]
Message-ID: <CAKywueSC=MoBB6t2OeUiyc6+GST2Jgg8FTO-kkXif-pn+1k-cw@mail.gmail.com> (raw)
In-Reply-To: <20190921223847.GB29065@ZenIV.linux.org.uk>

сб, 21 сент. 2019 г. в 15:38, Al Viro <viro@zeniv.linux.org.uk>:
>
> On Thu, Sep 19, 2019 at 05:11:54PM -0700, Pavel Shilovsky wrote:
>
> > Good catch. I think we should have another version of
> > build_path_from_dentry() which takes pre-allocated (probably on stack)
> > full_path as an argument. This would allow us to avoid allocations
> > under the spin lock.
>
> On _stack_?  For relative pathname?  Er...  You do realize that
> kernel stack is small, right?  And said relative pathname can
> bloody well be up to 4Kb (i.e. the half of said stack already,
> on top of whatever the call chain has already eaten up)...

My idea was to use a small stack-allocated array which satisfies most
cases (say 100-200 bytes) and fallback to dynamic a heap allocation
for longer path names.

>
> BTW, looking at build_path_from_dentry()...  WTF is this?
>                 temp = temp->d_parent;
>                 if (temp == NULL) {
>                         cifs_dbg(VFS, "corrupt dentry\n");
>                         rcu_read_unlock();
>                         return NULL;
>                 }
> Why not check for any number of other forms of memory corruption?
> Like, say it, if (temp == (void *)0xf0adf0adf0adf0ad)?
>
> IOW, kindly lose that nonsense.  More importantly, why bother
> with that kmalloc()?  Just __getname() in the very beginning
> and __putname() on failure (and for freeing the result afterwards).
>
> What's more, you are open-coding dentry_path_raw(), badly.
> The only differences are
>         * use of dirsep instead of '/' and
>         * a prefix slapped in the beginning.
>
> I'm fairly sure that
>         char *buf = __getname();
>         char *s;
>
>         *to_free = NULL;
>         if (unlikely(!buf))
>                 return NULL;
>
>         s = dentry_path_raw(dentry, buf, PATH_MAX);
>         if (IS_ERR(s) || s < buf + prefix_len)
>                 __putname(buf);
>                 return NULL; // assuming that you don't care about details
>         }
>
>         if (dirsep != '/') {
>                 char *p = s;
>                 while ((p = strchr(p, '/')) != NULL)
>                         *p++ = dirsep;
>         }
>
>         s -= prefix_len;
>         memcpy(s, prefix, prefix_len);
>
>         *to_free = buf;
>         return s;
>
> would end up being faster, not to mention much easier to understand.
> With the caller expected to pass &to_free among the arguments and
> __putname() it once it's done.
>
> Or just do __getname() in the caller and pass it to the function -
> in that case freeing (in all cases) would be up to the caller.

Thanks for pointing this out. Someone should look at this closely and
clean it up.

--
Best regards,
Pavel Shilovsky

  reply	other threads:[~2019-09-30 21:38 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-29  5:02 build_path_from_dentry_optional_prefix() may schedule from invalid context Sergey Senozhatsky
2019-09-20  0:11 ` Pavel Shilovsky
2019-09-21 22:38   ` Al Viro
2019-09-30 17:32     ` Pavel Shilovsky [this message]
2019-12-09  0:34       ` Al Viro
2019-12-10 19:14         ` Pavel Shilovsky

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAKywueSC=MoBB6t2OeUiyc6+GST2Jgg8FTO-kkXif-pn+1k-cw@mail.gmail.com' \
    --to=piastryyy@gmail.com \
    --cc=linux-cifs@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lsahlber@redhat.com \
    --cc=sergey.senozhatsky.work@gmail.com \
    --cc=stfrench@microsoft.com \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.